Answered

have to unplug sonos and plug back in to get Atmos

  • 26 February 2023
  • 6 replies
  • 155 views

On my tv setup with lg oled and Apple TV, in order to get Atmos sound each time I use the tv, I have unplug the Arc and plug back in..then everything works fine until the next time i watch tv…

 

any idea how to fix this?

icon

Best answer by Corry P 2 March 2023, 10:41

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 7

Try this:

Disconnect everything from the TV and unplug the TV, Arc, and Apple TV from power for a couple of minutes. Plug everything back in but keep everything disconnected. Make sure Simplink is enabled in the TV settings. Then run TV Setup in the Sonos app and follow the instructions. When the app instructs you, connect the Arc to the TV using the Sonos-supplied HDMI cable. After the Arc has been successfully connected, connect the Apple TV to the TV.

 

Also be sure to set the TV to these settings:

HDMI Input Audio Format: Bitstream

Digital Sound Output: Pass Through

eARC Support: On

 

Thanks for the quick reply… Ive done those things multiple times already..

Userlevel 7

Thanks for the quick reply… Ive done those things multiple times already..

In that specific order?

Do you have anything else connected to the TV? Have you tried using a different HDMI cable with the Apple TV or connecting it to a different HDMI port?

The issue is the same for Apple TV and playing directly from Apps on the TV

Userlevel 7

What apps are you using to play Dolby Atmos audio? Does it affect one app or all apps? What audio format does the Atmos audio play as?

Userlevel 7
Badge +18

Hi @Scbryan2160 

Welcome to the Sonos Community!

I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.