Fix for Sonos Beam and LG CX OLED via HDMI-ARC loosing connection

  • 28 October 2021
  • 2 replies
  • 3834 views

Userlevel 1

I hesitate to even suggest this solution, as for many months my LG CX 55 inch OLED (OLED55CXAUA) randomly stopped outputting ARC audio to my [Sonos Beam Gen1 + Play:1x2] system requiring me to physically unplug the Beam’s HDMI cable from HDMI Port 2 on the TV multiple times a week. The TV would just output to its internal speakers while completely ignoring the Sonos setup until I re plugged it in. I was getting to the point of worrying about the TV’s HDMI port 2 getting worn out.

All prior suggested solutions on this website have been temporary at best, but I seem to have found a durable solution that has lasted me the past four weeks of regular usage, found by reading multiple posts about this issue and parsing together a solution through trial and error. 

Of note, I first thought this was an Apple TV / LG CX / Beam problem, but I have realized after changing multiple settings on my Apple TV 4K Gen 2 (tvOS 15.1 with output forced to Dolby 5.1) over many months that it was a red herring because I was just using the Apple TV all the time as the source.

Ultimately, I believe that that LG and Beam are not playing nice through the HDMI-CEC protocols, specifically something to do with power. Sonos and LG engineering will need to figure this out.

 

First, my firmware versions:

LG CX: 04.30.10

Sonos system: 13.3

 

Second, my fix:

Gear button on LG remote → All Settings → Connection→ Device Connection Settings → Universal Control Settings → HDMI2(Arc)  - > Manage Settings → Set Manually → Bluetooth / SoundBar → HDMI2 (ARC) → Yes to reset → DO NOT ENABLE “Auto Power Sync” (SIMPLINK is OK to be on) → Scroll down and select Sonos → Next → Done

 

The only thing that I have noticed different with this setting disabled is that my Apple TV remote’s power button now does not turn on the TV. I have to do this on the LG remote. For me this is a fair trade rather than having to be constantly annoyed that my supposedly first in class, rather expensive system is randomly not working. 

 

To confirm this fix, two days ago I went back and re enabled Auto Power Sync and I had my first random disconnection in a month today.

 

 At least for me, having Auto Power Sync disabled is the fix.

 

Hopefully this is a universal fix for others undergoing this same frustrating issue.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Just gave this a shot & it seems to fix the issue of losing sound to the Beam when the Apple TV turns on. Have the same set-up here, LG CX 65, Sonos Beam, Apple TV 4K.

Only downside is exactly what you pointed out, you lose the ability to turn the TV on & off with the Apple TV remote. Fair trade off but definitely wish there was a full fix as I primarily turn my TV on & off with the Apple remote.

My guess is we will need an update from Sonos/LG for a permanent fix. 

Badge

Hello

I have the same problem with my connection with the ARCsoundbar and LG TV65C8PLA.

I keep loosing conneciton with my HDMIarc, and is reall getting into my nerves!!!!

Well, i am trying to use your solution with all the steps to config the HDMI port and hope to work.

I have just a small detail: when configurating the HDM port connection, in the last step where you choose your soundbar brand, the SONOS option doesn´t show, and I had to choose “unknown”. I dont know if this will make any difference.

 

Tku