Answered

Change WiFi network

  • 3 January 2021
  • 8 replies
  • 478 views

Badge +2

Good morning all

 

i have a Sonos system (arc, 2 Sonos one and 1 sub)

i did change my router and WiFi network but when I try to change my WiFi with Sonos app is not working.

i did try with Ethernet cable but nothing happens cannot detect my network I guess.

i switch the Ethernet wire but still nothing change.

do someone got this issue or can advice any other option?

 

thank you

icon

Best answer by GuitarSuperstar 3 January 2021, 12:14

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Userlevel 7

Your Sonos products are probably looking for your old wireless network. Have you tried resetting all of your Sonos speakers and redoing the setup process?

Or setup your new router to broadcast same SSID and with same password as your previous router. This will prevent your playlist from being deleted.

Badge +2

Thank you for your reply.

actually I was connected before to the WiFi complex I live in.

now I did subscribe to an home internet box.

so I could not do this manipulation.

May I ask the process if ever I want to proceed by resetting my system?

https://support.sonos.com/s/article/1096?language=en_US

Badge +2

That would be the only way otherwise to change WiFi?

Userlevel 7

That would be the only way otherwise to change WiFi?

You can try going to System > Network > Wireless Setup in the Sonos app first.

Make sure your new router broadcasts 2,4 GHz b/g

https://support.sonos.com/s/article/126?language=en_US

Some routers do not bridge 2,4 and 5 GHz. You could try disabling 5 GHz in the router and see if that helps, and also try again with your Arc connected directly into the router by ethernet. 

Badge +2

Thank you for your advice 

my router support 2,4 and 5ghz

 

i did try to plug my Sonos arc as well directly but not plug in power since not enough length with the wire 

I just did follow this step from the apps but still the problem haven’t been solved...