Answered

Cant add new Sub. ”App update needed” but have latest version.

  • 19 November 2022
  • 2 replies
  • 271 views

Hi,
 

I have an existing system with Arc and two Ones. Ordered a Sub that arrived today, but the Sonos app wont let me add the Sub :(

 

In Settings there is a greyed out option ”Add Sub”, when clicked I get a popup message: ”App update required. Update the Sonos app to the latest version. Functionality may be limited until update is finished”.

I have the latest version available in the App Store (14.19) already. 
 

Clicking the ”Update” button in the Sonos app leads to a ”Searching for updates” message that loads for about 30 seconds, then an error message with error code 1101. Any ideas? Anyone else having the same issue?

 

 

 

 

 

 

 

 

icon

Best answer by Airgetlam 19 November 2022, 17:22

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

As a guess, the software on your speakers needs to be updated, and for some reason, they’re being blocked from reaching the update servers (that 1101 error) in order to do so. This means your controller is on one version, and your speakers are on an older one, hence the greyed out options you are seeing.

Are you running any VPN or virus protection software that may be blocking your speaker’s ability to reach out to Sonos’ update servers? Have you tried wiring a single Sonos device to your router with an Ethernet cable temporarily, which sometimes can help if there is just enough wifi interference to get in the way?

It was indeed a firewall setting in the router, it must have been auto-changed with an update just a few days ago, since the autoupdate always have worked previously. Got the sub up and running now. Thanks!