Beam gen 2 buzzing at certain sound levels

  • 27 December 2021
  • 3 replies
  • 154 views

Userlevel 1
Badge +1

Hi, I have just recieved the beam gen 2, and after only a couple of days usage I am getting a really annoying buzz at certain sound levels from the right hand side of the unit. I have looked this issue up on the net, and someone else had what sounded to be a similar issue. They reported that if they applied pressure by pressing down on the right hand side of the beam then it didn’t happen. This appears to be the case for me as well. Is this a known common issue? Is there anything I can do about it, or is it a return job, which I really can’t be bothered doing lol.

Many Thanks


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

It’s not common. It sounds like a manufacturing defect. Contact Sonos Support by phone and -- lol or not -- they ought to be able to organise a return and replacement. 

Userlevel 1
Badge +1

It’s not common. It sounds like a manufacturing defect. Contact Sonos Support by phone and -- lol or not -- they ought to be able to organise a return and replacement. 

Ok thanks for the reply. It was actually bought from a large retailer as they offer a longer warranty. The thing is though that nobody, and I mean nobody (that I would by from anyway) appears to have them in stock now. I am in the uk. Not even Sonos. Obviously a popular Christmas present. Best estimate is Mid January. Ohhhh the frustration!!

I suspect not only the holidays, but I would expect the international chip shortage is impacting Sonos as well. Not to mention shipping issues across the various oceans, due to COVID-19.