Answered

Arc + sonos sub (gen3) does not let me add sonos one

  • 30 November 2020
  • 11 replies
  • 967 views

I already had the sonos arc+ sub(gen3) connected to my TV. And it works fine. I just wanted the little extra experience of the all surround. I bought 2 sonos One.

When i added these to the app, and tried to put them in the same room as the arc and sub. the app created an additional room for it with a number 2 (tvroom2). The app also says it cannot find two compatible sonos speakers if i try to set up surround. they are powered on and connected to the wifi. 

 

I am able to connect my sub to the sonos one speakers, but not the sonos arc for some reason. Any suggestions?

icon

Best answer by Mr. T 1 December 2020, 15:34

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

11 replies

Userlevel 7

Create a stereo pair with the Ones, then try to add them as surrounds

I am using them as a stereo pair now. It is nice for left right depth. But the front and back depth is completely missing. I wanted to make use of the surround feature.

 

Userlevel 7

Sorry just tried it with my playbar. Thought it was the opposite.

Separate the Ones as being in a stereo pair, then add them as surrounds for the Arc

That's exactly what I want to do, but it won't let me. When I want to pair the Sonos one in the same room as the arc. It makes a copy of that room instead of adding it there.

Hi. ‘Pair the Sonos One in the same room as the Arc’ doesn’t really mean anything.  You can start with the Arc and the two Ones as three ‘Rooms’. ‘Room’ is just a label for a speaker or specified configuration of speakers.

I would suggest you start from that position - 3 rooms - Arc + Sub and the two Ones.

Power off your router and the Sonos speakers.  Power up the router fully.  Then the Arc then the Sub then the Ones.  Then go into the Arc Settings and ‘add surrounds’.

No guarantee this will work, but sometimes the router reboot in particular seems to help in this situation.

Userlevel 7

Having the Ones in a stereo pair is likely why you’re receiving the message “can’t find two compatible Sonos speakers”

Go into tvroom2 and Remove Stereo Pair

Then go to Arc(+Sub) and ‘add surrounds’. This should then bond them with your Arc and Sub in a Home Theatre setup.

You shouldn’t have to power off/reboot router and speakers to get them added.

@Mr. T .You may be correct, but on past occasions I have added surrounds from a stereo paired state, and I have seen other threads where separating the pair before trying to add made no difference.

I have also seen examples where my suggestion has and hasn't worked. So all these things can be worth trying.

Userlevel 7

@John B - Recently I have rebooted my router and Sonos devices so often that I’ve lost count (issue playing Sonos Radio HD but fixed with the addition of a Boost). Was sure I had added surrounds when they were already a pair, hence my initial suggestion. But this morning, I removed my surrounds, then set them as a stereo pair. Went to add surrounds and received the error message ‘can’t find two compatible Sonos speakers’ (only one unpaired Play3 appeared). Removed the stereo pair that I created, went back to add surrounds which then gave me 3 room options to pick from and I successfully added the 2 applicable speakers back as surrounds in HT

But agree, if that also fails, then a reboot of router and speakers is worth a shot.

@John B @Mr. T  I managed to get it done. I did what Mr t said. But didn't work at first so I paired them again. Then reset my router and arc. After I set those up again nothing much changed. Then I removed the stereo of the Sonos one, and they ended up in separate rooms like Mr T said. After that I could use the set up surround.

 

Thanks a lot guys! Funny such high end music hardware has such trouble in an app.

Userlevel 7

@Dirk telt Good to know you got there in the end with the combination of measures.

Happy listening in surround!

@Dirk telt Good to know you got there in the end with the combination of measures.

Happy listening in surround!

I second that!