ARC not witching inputs

  • 24 June 2024
  • 5 replies
  • 37 views

My ARC was working fine on my Sony TV, when i turned on the TV it found the ARC input on the TV and switched to the proper input after that. Now it doesnt switch to the proper HDMI input for TV.  I have to manually switch the TV input for Video.  What can I do to correct this?  


5 replies

Userlevel 7
Badge +13

Turn off the TV and Arc at the wall.

Unplug the HDMI cable from the TV and Arc, and reverse it (then plug it back in). Ensure you’re connected to the right HDMI input (and that it is the HDMI eARC or HDMI ARC one).

Turn the TV back on at the wall. Turn the Arc back on at the wall.

Try it all again to see if that has helped.

Also, in the app, go to Settings / [room with Arc], and scroll down to ensure that TV autoplay is toggled on. 

I can unplug the HDMI on both, I’ll try that.  Autoplay is already on, and I toggled it on and off but still the same.  To reverse the HDMI is going to be a problem being its pulled in the wall, and extremely hard to get too.

Userlevel 7

This may not be an Arc issue but a setting within the Sony menu for the default HDMI.

Userlevel 7
Badge +13

 

I can unplug the HDMI on both, I’ll try that.  Autoplay is already on, and I toggled it on and off but still the same.  To reverse the HDMI is going to be a problem being its pulled in the wall, and extremely hard to get too.

Yes, certainly unplug both ends of the HDMI cable, and also turn things off at the wall to start them off again. 

Also, HDMI Control (or whatever Sony calls it) might no longer be on for some reason for that HDMI port on the TV’s settings...

There are no settings for o turning on and off inputs every input is off now except for the TV input. If I could actually get on the phone with someone from Sonos customer support I'm sure they can walk me through it but I can never get through

Reply