Answered

ARC not connecting to TV sound

  • 3 June 2021
  • 4 replies
  • 24283 views

I have an arc, sub, and two Ones connected to my tv. For a couple of years I had a beam in this configuration and last summer when the arc came out, I switched the configuration above. I had to connect my arc to Ethernet to set up and it is still functioning that way. My arc is connected to the Arc HDMI port and never had an issue. I also have a Philips Hue light system connected to another HDMI port with my Roku and PS4 connected to that. This configuration happened around the beginning of January. Now, mid May, all of a sudden when we turn the television on with our Roku remote, the tv sound doesn’t automatically connect to the Arc system, stating that “the HDMI ARC is not connected”. We then disconnect, wait, and reconnect. We have tried changing the HDMI cable (x3) to no avail. We also purchased two Lindy CEC-less adapters from Amazon but both still had pin 13 intact, making them completely useless. Sometimes, this reconnection process is as simple as disconnecting once and replugging the hdmi cord, but other times it can take up to an hour. Then, other times it may decide to activate the external sound system when I turn it on (like normal) and just work. What do we think is the issue? What do I need to do next? 

icon

Best answer by GuitarSuperstar 3 June 2021, 16:16

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 7

One of your other devices could be causing interference. Disconnect all of your devices from the TV including the Arc. Unplug the TV and Arc from power for a couple of minutes. Plug the TV and Arc back in but keep everything else disconnected. Be sure CEC is enabled on your TV. Then run the TV Setup process in the Sonos app. Connect the Arc to the TV when the app instructs you to. When the Arc is connected and working as it should, reconnect your other devices to the TV.

If this problem happens again, try setting up everything without the Phillips Hue system connected or connect the PS4 and Roku directly to the TV with the process above.

So, I’m having this issue all of a sudden. I have the hue sync box connected to the same tv as my arc, and the arc won’t connect to my tv. I tried disconnecting my hue sync box, and then my arc reconnected to the tv. When I reconnected the sync box, the Sonos arc disconnected my entire Sonos system in this room (arc, subwoofer, ones from the tv. This is totally unacceptable!! I don’t want to set up my inputs directly to the tv because I bought the hue box to have lights in sync with what I’m watching. Is there any other way to fix this??!?

The specs. that I’ve found for the sync box do not indicate that it supports HDMI-ARC.

You can insert ARCANA between the sync box and ARC.

The sync box was connected to hdmi port 1. Sonos arc was connected to the hdmi arc port on my tv, which was 3. I spoke with a customer service rep who recommended switching the hue sync box to hdmi port 4, and that seems to work right now. They said the tv was prioritizing hdmi 1. Let’s hope I don’t have any further problems. I’m a little worried since the original setup worked for a bit too before the arc started disconnecting. I will update this post if I have the issue again.