Trying to get my cable tv remote (Spectrum) to control my Sonos volume.

  • 15 April 2017
  • 7 replies
  • 7131 views

Just switched from Direct TV to Spectrum (formerly Time Warner Cable) yesterday. Technician was unable to figure out how to sync the Spectrum remote with our Sonos system so that we can control the volume via the remote instead of using our smart device(s) to do so. Spectrum Customer Service suggested that I call Sonos to see if they have a code(s) that are compatible with the remote, but they're closed today (Sat). Our Direct TV remote was compatible with Sonos, so it can be done. No...we are not going back to Direct TV. Any other suggestions?

7 replies

Did you ask PLAYBAR to learn the new remote?
https://sonos.custhelp.com/app/answers/detail/a_id/4033

PLAYBAR will usually recognise the code set from a single Vol+ press. If not you can simply teach it all three codes.

If that doesn't work at all, then the remote could be using RF rather than infra-red.
I have this exact same prob now and that link above no longer works....any ideas guys? Sorry for the old bump
Try this link:

https://support.sonos.com/s/article/3402

About 6 months ago, Sonos reorganized their FAQ labels, so any links from before then won't work.
Unfortunately that didn’t work either. Do others have the volume working for their Sonos with spectrum tv?
You may want to contact Sonos to discuss it.

Twitter and Facebook are 24/7, the phone lines and support here in the forum is M-F
Try this solution;
Click “more” - click “settings” - click “room settings” - click on the room you have the sound bar in - then click on “remote” under TV remote- then remote control setup - then replace current remote then continue. It’ll ask you to hit some buttons on your remote EG the volume up or down. It found my remote instantly.

Hope that helps.
Thank you Roseylv! I was finally able to fix my remote issue! I really appreciate the advice!

Reply