Answered

sony x900f, series x, only getting pcm 5.1 not atmos HELP please.

  • 21 December 2022
  • 4 replies
  • 831 views

hi everyone,  

just got my new sonos set up, went full in.  arc, sub, 2 1’s for rear (along with a couple others for house).

so far I am loving it, however I cannot seem to figure out how to get atmos (always showing pcm 5.1)

I have an 85 inch Sony x900f which has an e-arc input.  what am I doing wrong? 

Netflix & Prime shows audio as only 5.1 when browsing any title.  

Xbox audio settings say “dolby atmos for home theatre (hdmi only)”

This might help explain better…..

Peaky Blinders on the Netflix app built into tv shows 5.1

Peaky blinders on the Netflix xbox app shows atmos ……….

 

why? and how can I fix this? I would prefer not to have to run Netflix thru xbox to get atmos sound when available.  

thank you to anyone who replies!  hope everyone has a wonderful holiday!  

icon

Best answer by GuitarSuperstar 21 December 2022, 18:13

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 7
Badge +20

I don’t have your TV but a quick search suggests the two following settings within your TV set-up: Check the Sound settings in your TV set-up to change the Sound mode to Atmos?  Also, set the eARC Mode to ‘Auto’ in the Audio Output section of your TV set-up?

Hi and merry Christmas right back!

I too have a big Sony and experienced issues playing prime and Netflix on the virgin platform. This included audio lag and dropout after pausing a scene. I realised that I should go to the Sony menu and sign into both the above as apps on the actual tv.

This has completely stopped both issues and whatever audio settings that Netflix and prime show as the sound for that movie etc is exactly what is shown on the app on my phone.

I naively thought all audio would be atmos when I bought all the kit but most is not. Ordinary tv picture and sound is generally rubbish especially when you figure the cost!

Anyway that might help without having to pull out cables etc!

 

Userlevel 7

Set your TV to these settings:

eARC: Auto (if available)

Digital Audio Out: Auto 1

Dolby Digital Plus Output: Dolby Digital Plus

Pass Through Mode: Auto

With these settings, you should get “Dolby Digital Plus 5.1” audio from 5.1 sources and “Dolby Atmos” audio from Atmos sources using the TV’s Netflix app. And be sure you have a Netflix Premium subscription. This is required to get Dolby Atmos audio.

Test the film Don’t Look Up. It has an Atmos audio track.

I don’t believe Peaky Blinders has a Dolby Atmos audio track. The only reason why you are seeing the Dolby Atmos logo is because the Xbox is up-mixing the audio to a fake “Dolby Atmos”. When playing the show through the TV’s Netflix app, you want to see “Dolby Digital Plus” displayed in the Sonos app.

On the Xbox, only use the “Dolby Atmos for home theater” setting when playing actual Dolby Atmos content. With all other 5.1 content, use the “5.1 uncompressed” setting which will result in “Multichannel PCM 5.1” audio.

Rashi,  what an explanation!  Thank you!  I will try later when home.  Appreciate your thoroughness!