Question

SONY BRAVIA KDL-40XBR3 (2007 MODEL) PLAYBAR INCOMPATIBLE?

  • 9 January 2017
  • 3 replies
  • 816 views

Hello,
I recently purchased a Sonos Playbar and I am unable to get sound from my SONY BRAVIA KDL-40XBR3 (2007 MODEL.) This television features a digital output and I have disabled the speakers but there is still no sound. As a test, I connected the Playbar to a newer Sony TV and it worked perfectly.



Any advice would be greatly appreciated!

Thank you.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

There's a couple of potentials here. I used to have a couple of Sony's, and they both worked fine with my Playbars.

1) Make sure the input to the TV is restricted to Dolby Digital. No DTS, no DD Plus, just plain old Dolby Digital, or stereo. You'll likely have to go in to the audio settings on each device that you have connected to the TV via HDMI to set each of them.

2) Make sure that you go in to the audio settings on the TV to ensure that it's only passing out Dolby Digital, and not something else.

3) Check the optical cable at both ends (the TV and the Playbar) to ensure that it's fully seated.
Thank you. I will give these ideas a shot and report back.
One more thing. Looking at the support page at Sony Electronics, it looks like there might be a firmware update. You may (and I'm not really sure, but worth looking in to) want to check to see which version of the firmware you have. I don't recall anyone reporting issues with their implementation of the Dolby Digital codec through the optical port, but it wouldn't hurt to be current. As I recall on my older Sonys, it actually required me to put the files on a USB drive and then connect them to the TV while chanting some arcane phrase and sticking a thumb in my ear. My memory may be faulty on that, though.