Sony Bravia Android TV Apps are not playing sound through Sonos 5.1 System


Badge
I have a Sony Bravia Android TV, a Sonos Playbase 5.1 System with Sub & 2 Play 1's connected via a Flexson HDMI Switch. The optical cable is connected to the Flexson and into the Playbase. I have a single HDMI cable connected to the Flexson HDMI out into HDMI 1 on my Sony TV. A BT Set Top Box is connected to HDMI input 1 on the Flexson and TV is set tp use Audio System in the settings, This gives 5.1 Dolby Digital from the Sonos fine. I have an Xbox one connected to the Flexson HDMI input 2, that also works fine through the Sonos, What does not work is Android Apps installed on the TV such as Netflix, Amazon Video etc...

I have connected an HDMI Arc cable into the HDMI 4/Arc port on the TV and into the Flexson HDMI input 3, there is an ARC button so when I press that and choose HDMI switch 3, a message appears on the TV saying that an Audio System has been connected. If there is no sound then make sure you connect HDMI 4/Arc, there is no sound and the message will not disappear. If I turn off the Arc button on the Flexson, I just get TV Speaker sound only.

I am fairly Tech savy, so followed logic with regards to connectivity, previously I just had a soundbar that was connected to my HDMI 4/Arc on my TV and it just worked. Not sure where I am going wrong or if anyone else has had a similar issue.

Thanks

Mark

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Did you ever get this working? I tried the same as you with the same result, the TV detected ARC was enabled but no sound was output. I’m wondering now if the arc HDMI cable should go from the Flexson output to the tv rather than from a Flexson input to the tv?
Badge
Hi Dave_nt, My issue was resolved in a fashion, what I had to do was connect the Flexson HDMI out to the HDMI Arc in port on my TV, then connect my devices such as Xbox one, BT DVR and Nvidia Shield Android TV to the 3 HDMI inputs on the Flexson. I am now able to get sound by connecting the optical out from the Flexson to the Sonos playbase optical in, however its only stereo not 5.1. My TV is set to external audio and 5.1 PCM, my Xbox the same and my Nvidia also set to 5.1. When I play a 5.1 stream from Amazon on the Nvidia, my Sonos system is only seeing it as Stereo.... very frustrating considering I have a full sonos 5.1 system costing almost £2k that only gives m stereo simulated 5.1.
Thanks for your reply, I had mine setup wrong then. I will give it another go when I get chance. I’m surprised the Nvidia is only stereo, are the other inputs still 5.1?
Badge
No Dave, all the inputs still show as stereo in even though they are all configured for 5.1 or PCM. The only thing I can think of, is that the HDMI Arc cable or port to/from my TV cant passthrough 5.1 or PCM to 5.1... cant see the optical cable being the problem either as I would expect it to either work or not work. The Flexson is set to ARC and 5.1 for the sound, I have tried passthrough on the Flexson also, still coming in as stereo. 😞
Badge
No Dave, all the inputs still show as stereo in even though they are all configured for 5.1 or PCM. The only thing I can think of, is that the HDMI Arc cable or port to/from my TV cant passthrough 5.1 or PCM to 5.1... cant see the optical cable being the problem either as I would expect it to either work or not work. The Flexson is set to ARC and 5.1 for the sound, I have tried passthrough on the Flexson also, still coming in as stereo. :-( Additionally however, there is an option in my TV sound settings for 5.1 PCM, so no idea...
To get my Bravia Android TV to output 5.1 on Netflix and Amazon Prime Video I had to change Digital audio out to Auto 2
in the sound settings. My setup is a little simpler than yours insofar that I don't have an HDMI switch, but the TV definitely outputs 5.1 over optical or HDMI ARC with that setting and when using Netflix or Amazon.
Try opening Sonos app go to ‘More’ then ‘settings’ then ‘room settings’ then ‘TV’ And make sure ‘TV Autoplay’ is enabled. This fixed the problem for me.