Sonos Amp constantly looses configuration of TV remote

  • 9 January 2021
  • 3 replies

Badge +1
  • Avid Contributor II
  • 6 replies


I have an Amp connected via optical adapter that I use for HT purposes with a pair of Ones as surrounds and a pair of passive speakers. Content comes from an Apple TV 4K.

The problem is that frequently (several times per evening) the remote (I use the Apple TV remote) stops being able to change volume. The only way I could come up with to restore this function, is to repeat the TV setup in the Sonos app. This quite time consuming of course and not a good user experience.

Is this a common issue, does anyone know how to avoid this, maybe an easier way to fix or to reestablish the remote functionality?




Best answer by Simon B 10 January 2021, 00:57

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 6
Badge +16

Hi @jgf3, Thanks for reaching out, and welcome to the community. Sorry to know about this issue with your remote. I’d like to ask if have you tried another remote if it’s the same issue? or changing the remote batteries? You may check this article about TV remote not detected by Sonos for some troubleshooting steps that you may try to see if it will work. Let us know if it’s still not working so we can further assist you. 

Let me know your thoughts on the advice above.

Badge +1


RTFM helps of course. It seems it’s recommended to connect the TV remote rather than the AppleTV one.

After fixing this issues the problems stoped, also the AppleTV remote works anyway.

Userlevel 6
Badge +16

Hi @jgf3, thanks for the update. If you have any questions or run into any other issues, please do not hesitate to contact us. We are always happy to assist you. Thanks.