Playbase and Roku 3 not working


I have my playbase hooked up to my TV, but I am not getting sound when watching my Roku 3.

Playbase is optically hooked up to my TV and the Roku 3 is hooked up through the ARC HDMI input on my TV. TV setting is on external speakers and on the app it is not hearing sound during the setup.

Hardware below:
Roku 3
Samsung UN46H7150 46-Inch 1080p 240Hz 3D Smart LED TV (2014 Model)
Playbase, just arrived today.

5 replies

What settings are you using in the audio menu on the roku? I tried a Roku stick with my 2013 F series Samsung and if I set audio to Dolby on Roku and TV just get silence. Will only output sound if I set to stereo. In my case its due to TVs inability to passthrough dolby from hdmi sources.
I have tried almost all configurations and no go so far.
Have you reviewed

https://support.roku.com/article/208754498-how-do-i-set-up-my-roku-streaming-player-for-surround-sound-

You may need to make sure that your Roku is outputting only Dolby Digital, anything else will give you silence.
I have tried all rook settings on every HDMI port on my TV and it still will not work. I am using the optical cable provided by Sonos, so unless something is defective I don't know what else to do. I appreciate the ideas and responses so far.
After many tests, I concluded my optical outlet on my TV was faulty. So I purchased "avedio links HDMI to HDMI + Optical Toslink SPDIF + 3.5mm AUX Stereo Audio Out, HDMI Audio Extractor Splitter Converter Adapter Support 4K@30Hz 1080P Full HD 3D" on Amazon. So far it is working perfectly with my new Playbase. No delay, static, or sound distortion.

https://www.amazon.com/gp/product/B07H94D77V/ref=ppx_yo_dt_b_asin_title_o00__o00_s00?ie=UTF8&psc=1

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings