Answered

Playbar Switching Between TV and Music

  • 8 October 2017
  • 22 replies
  • 26184 views

I just purchased a Sonos Playbar. Everything works perfectly. I can go to the app and play music while I’m watching TV but how do I switch back to the TV audio without turning the TV off and on?
icon

Best answer by Airgetlam 8 October 2017, 20:16

Going in to the app and changing the selection the same way you changed to music, just select line in. Or, turn off the TV and turn it back on, and the "autoplay" function will kick in.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

22 replies

Going in to the app and changing the selection the same way you changed to music, just select line in. Or, turn off the TV and turn it back on, and the "autoplay" function will kick in.
Ok got it. I didn’t notice the TV option listed with Music Library, Spotify, etc. in the Browse menu. Thanks.
No problem 🙂
Badge +4
This was driving me crazy when I updated to the new app as I couldn't find the TV option anywhere. Looks like you need to have the playbar selected as the room and then browse to see TV. I'm sure this was available on the main menu previously?
I'll admit that it's not something I'd have looked at before, but it seems unlikely that it would be anywhere other than in the room menu for where the PLAYBAR exists.
I can confirm that @Airgetlam is correct. This has not changed at all in the new app.
Ok got it. I didn’t notice the TV option listed with Music Library, Spotify, etc. in the Browse menu. Thanks.

I got hung up with the same issue. I won't say the interface is counter-intuitive but I will say I didn't expect 'TV' to be under 'Browse'. I'll also say I was a bit surprised the TV didn't start playing after I ended the music session as it was playing right before I started the music session...
Having a similar issue. When using apps on my Samsung tv like Netflix or YouTube or listening to music the sound does not switch back to tv like it did prior to a few months ago. And yes I havecthe latest update and yes I select tv in the browse section. This is getting really annoying and definitely playing a role in whether I purchase Sonos again or recommend it
That's interesting. Would you be willing to submit a system diagnostic, and post the number here, for the folks at Sonos to look at? It might be able to give them some information in order to figure out what is causing the issue.
We have the same or similar issue, except our 2 year old Sony Bravia TV will play it’s apps through sonos after switching back from music, but now our cable won’t.

This did not use to be an issue, but the past couple months we have had to reset our sonos everytime we accidentally play music on our PLAYBAR.
Ive read through this thread and am still unable to find any way to switch back to television audio. As far as I can tell, I’ve navigated every possible option in the application.. Once I select a music service, there is no option anywhere in the app (at least that i can find) to switch it back to television audio.
Only way I can switch back to television audio once I select a music service is to stop the music service and then power off and on my tv.
Where are you using the app (what device)?

While I have the room "living room" selected, which is where my PLAYBAR is, I then select the "browse" button, and one of the inputs listed is "TV". This is on an iOS device, using 8.3
Thanks Airgetlam!! If I select the room and then click “browse” I am able to select tv audio..

While I did try the “browse” button before, it was only showing me my Pandora stations.. The “browse” button is apparently multi functional and context sensitive...meaning it browses different things depending on where in the app you are.. once I backed up to the top level menu, (up from the pandora music stations), I saw the tv audio.
Yes, it depends on which "room" you have selected.
Userlevel 5
Badge +12
If you've already browsed to radio stations etc you have to go back a few pages in the "browse" menu to show TV..
You can also just tap Browse twice to ensure you’re at the top menu. Just like the iPhone home button takes you to the most recent home screen page on first press, then on second press takes you to the first screen. A common UI pattern on iOS.
---
This seems like a similar but different issue. My Playbar+two Play: Ones work great when I turn on my TV and when I play a music source from the app or say from Spotify. When I play something on the TV the balance is heavier on the Playbar working like a surround system. The trouble I have is if I just play music from Spotify (TV off) the sound comes from the three speakers but it's still in a surround sound mode where the Play Ones are very low volume. I thought maybe I could set up a separate room for playing music but that doesn't seem to be the right way to go about fixing this. I appreciate any help and apologies if this was covered somewhere I missed.
No, during music playback (which is a different input on the device), there's some extra settings you should be looking at.

Open up the controller app, go to more, then settings, and then room settings. Click on the room name that has your PLAYBAR in it. Then click on Advanced Audio, and Surround Settings.This page is where you can set the volume of the surrounds when it's in TV mode, or Music mode Note the Music Playback switch, and I'd recommend that you flip that to Full, rather than ambient, it will make the surround speakers a full pair fo stereo speakers, rather than "support" speakers for the PLAYBAR.
[quote=Airgetlam]No, during music playback (which is a different input on the device), there's some extra settings you should be looking at.
Open up the controller app, go to more, then settings, and then room settings. Click on the room name that has your PLAYBAR in it. Then click on Advanced Audio, and Surround Settings.

Thank you!
Under Advanced Audio I only have one option, "TV Dialog Settings" and under that is "Audio Delay (lip sync)". No Surround settings there.
Ah, then you've already removed them from being surround speakers? Or perhaps never added them as such?