Answered

Optical output

  • 2 October 2017
  • 5 replies
  • 912 views

I just bought a new Samsung Tv 65Q7F. Connected everything through the one connect box. As the
sonos play bar is below the TV and all the stuff including the one connect is in cupboard few feet away concealed away. So I connected the optical cable from the one connect to the Sonos hub and chose the option of optical output from the tv and sky, but there seems to be no sound coming. The seems fine if I select tv speaker output. Please help.
icon

Best answer by John B 3 October 2017, 08:21

@gsmgkm. No amount of diagnostics will help here, because you have wired this in a way that cannot possibly work. The Sonos Connect is not a 'hub' in any sense, it is a device for turning a legacy hifi into a Sonos streamer. The optical connection on the Sonos Connect is an output, not an input. The optical has to go to the Sonos Playbar not to the Connect.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

What is a "one connect"? Is that a piece of hardware that Samsung supplies, or is it a Sonos CONNECT?

What is a "Sonos hub"? Do you mean the PLAYBAR? Or is it some other Sonos device?

Unplug the optical cable, is there a red light coming out of it?

Which version of the software are you running? There are many Samsung users that have had trouble with 7.4, and needed to be update to 7.4.1, which you can do by running a diagnostic and posting the resulting number in this thread:https://en.community.sonos.com/troubleshooting-228999/no-sound-on-certain-channels-after-system-update-today-6789926

Also, have you checked the audio controls on both the Samsung TV as well as the Sky Q box, to be sure that they're both locked down to Dolby Digital, rather than something else?

I'm a Yank, so I'm not familiar with Sky Q, but do they have any channels that are in SD, rather than HD? What happens when you attempt to play an SD source?

If you have a DVD player attached to the TV, have you tried playing a DVD ?
Hi

Submitted the diagnostic

Your confirmation number is: 7907361

Connect one is a box hats supplied with the TV, it’s replaces all the connections from the rear of the Tv to this box which can then be placed separately in order to remove the clutter from behind the Tv.

So I then connected the optical cable from this box, reperesenting the Tv to Sonos Connect (hub). It was working fine before when I had connected the cable directly from the the earlier TV’s connect box to Playbar, but now that I have moved everything away from the Tv and the Playbar I connected it through Connect and it won’t work.

There is a red light coming from the cable.

I have selected optical on night Sky box and the TV.

I haven’t updated it to 7.4.1.

I have connected Apple TV and getting the same issue
Yea, I think you should be posting that diagnostic number in the thread i linked to, not here.
@gsmgkm. No amount of diagnostics will help here, because you have wired this in a way that cannot possibly work. The Sonos Connect is not a 'hub' in any sense, it is a device for turning a legacy hifi into a Sonos streamer. The optical connection on the Sonos Connect is an output, not an input. The optical has to go to the Sonos Playbar not to the Connect.
Oh, I thought it was another input .

I’ll have to run another cable from the Sonos Playbar to the One Connect, it’s shame , I was trying to hide all the cables. Oh well.

Well that should resolve the issue.

Thanks for the help