Lip sync issues with playbar

  • 12 July 2021
  • 5 replies
  • 73 views

Am I right I understanding that there is a long standing problem with LG TVs and the Playbar when it comes to lip sync? 
 

The last time I checked on this there was no fix and LG were unlikely to do anything about it. 
 

Does anyone had any recommendations on TVs that you are using that have good lip sync? 


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

I have two LG TV’s, an old (2015) 48MT28S with a Sonos Beam/Surrounds/Sub and the slightly newer (2019) LG OLED C9 with a Sonos Arc/Surrounds/Sub and both work fine.

In my case I have set the TV ports to pass-through all audio in the web-OS settings. I think some users may not realise the setting is there, or perhaps don’t have it on their much older LG models (possibly), but the LG TV’s have been just fine here for lip-sync, personally speaking.

I’ve not tried the Beam on it, as I have the Playbar. 
 

I have it set to pass through but it is often way out of sync on various forms of media. 
 

Like I said last time I heard it was an LG thing so am looking to replace really. 

I’ve not tried the Beam on it, as I have the Playbar. 
 

I have it set to pass through but it is often way out of sync on various forms of media. 
 

Like I said last time I heard it was an LG thing so am looking to replace really. 

And the LG lip-sync slider bar doesn’t work for you either, if you switch off pass-through?... It’s unusual that the LG pass-through option doesn’t work, as that should allow the DD 5.1 audio from connected peripherals (like Fire-Stick 4K, Apple TV, Nvidia Shield TV etc.) to not be processed by the TV at all?
 

Anyhow, I assume you want to try something else instead, so just to add, I hope you have more luck with your next TV (whatever one you eventually choose to go with).👍

Yeh the slider bar does change it but I can never get it bang on. It’s either one way or the other which just bugs the hell out of me. I have a broadcasting background so sadly a keen eye for this stuff! 

Userlevel 7
Badge +22

This is not a general LG problem (my LG works great with the Playbar without issue, once I used the service menu to enable DD 5.1 for HDMI inputs), but is a problem with some TVs from multiple manufacturers. It more commonly affects HDMI-ARC connections (on Beam/Arcs), not optical though.