Question

LG Smart tv

  • 4 July 2016
  • 9 replies
  • 5404 views

LG Smart TVs: How do I add my speakers to this tv????!!!!
So frustrated! I've plugged in my playbar, but it does NOT play thru the playbar or sub or play5 at all,
Pls help! How can I do this?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

So which LG model TV is it exactly and what things have you done/tried so far and in what order?

Did you begin by setting up your Sonos audio wifi system first, using a Sonos controller? ..It's really not clear from your post what instructions you have followed so far and what problems you have then encountered. Is your Sonos Playbar (and speakers) already setup and working with your music library for example?

I think people here need a bit more information from you, before they can really begin to offer some good advice.
Yes - Ken is spot on. From what you have posted so far it sounds like a case of "if all else fails, read the instructions". Here are some instructions:

http://www.sonos.com/documents/productguides/en/PlaybarGuide_EN.pdf
I’m having a really tough time with my LG TV too... no matter what optical audio setting I select I can get my Connect to recognize the line in. I’ve re-set it, cycled power and replaced the optical audio cable. Please help!!


Diagnostics confirmation number is: 8380693.
The CONNECT doesn't have an optical in. It only has an optical out.
Userlevel 5
Badge +13
If you've got a current LG TV, one that only has optical digital out, and a Sonos Connect, the only way you're getting audio into the connect is with a Digital to Analog Converter (D/A converter, DAC). When I was playing around and needed to get this working for a temporary setup. I got a cheapie at Best Buy:https://www.bestbuy.com/site/insignia-optical-coaxial-digital-to-analog-converter-black/4226000.p?skuId=4226000

You'll use the optical cable out of the TV into the DAC, then RCA interconnects to the inputs on the Connect. Make sure you're connecting to the inputs, not the outputs. Then you'll use the outputs on the Connect to connect to the rest of the audio chain (amp+speakers, powered speakers, etc.)
Thank you all! So I’ve got the RCA’s connected and the line in audio looks like it’s coming through (the little sound equalizer bars are moving) but I can’t hear any audio over my Sonos speakers.... could I have a bad cable?? How do I fix this??
On which room / device are the bars moving? The Connect? If so that is no use to you as it doesn't have any speakers. Tap the Rooms button on the tab bar and select a speaker. Then tap Browse and select line in.
Also, in the settings for the line in choose one ,of your Play speakers (or stereo pair, or whatever) as the Autoplay room, not the Connect.
@airforceteacher I went with your advice and bought the optical to RCA converter. I finally have sound via my connect on my two Play 1’s in my living room! My problem now is that I have this intermittent weird lag or quick skip in the audio during movies (doesn’t happen through the tv speakers, only when playing through line in on the connect). Does anyone have any advice on how to eliminate the audio lag??