Issues with getting SURROUND SOUND TO PLAY DOLBY ATMOS. I keeping getting PCM 2.0

  • 10 January 2022
  • 32 replies
  • 1391 views

Badge

I currently have a surround set up with the Sonos Arc and two SL ones and gen. 3 subwoofer. When I’m playing a movie with Dolby Atmos it is not showing in the sonos app that its  coming through as Dolby Atmos. Instead it is showing pcm 2.0.. I have my system playing through a Samsung QLED Tv model Q80 . This is driving me nuts!!! Any suggestions would ge appreciated! 


32 replies

Userlevel 7

I use my apps through Roku system not the apps directly on the TV. 

Well this is useful information. Which specific model Roku device are you using? Have you changed the audio settings on the Roku to play Dolby Digital Plus audio?

Badge

My HDMI set up is. 

HDMI 1 open

HDMI 2 Roku 

HDMI 3 eArc Sonos ARC 

HDMI 4 Xbox Series X  

Badge

The Roku I’m using is Roku Streaming Stick 4K +. I have not changed any audio settings with the Roku. 

Userlevel 7

The Roku I’m using is Roku Streaming Stick 4K +. I have not changed any audio settings with the Roku. 

This is probably the problem. Change the audio settings on the Roku to Dolby Digital Plus.

NOTE: There is a chance that Dolby Atmos is not supported on Netflix on the Roku Streaming Stick+. Use the TV’s native Netflix app or the Netflix app on the Xbox instead. And you need a premium Netflix subscription.

Badge

That’s actually a good idea!  I’ll have to double check my audio settings on the Roku. 

Badge

I currently have the premium ultra HD plan with Netflix. I’ll try the native Netflix app on TV and Xbox. 

Badge

Guitar superstar!! It worked!! Changed the audio settings on the Roku and its finally working!!!! Thank you everyone for your input !!! I can finally rest my brain. For now! Lol  I’m sure its something else that will drive me crazy with electronics!!! But i love it when it all works!! Appreciate it everyone!

Reply