Hulu live surround on Apple tv cuts on switching channels

  • 10 November 2022
  • 4 replies
  • 93 views

Userlevel 4
Badge +2

On my Apple TV 4k (previous version) when watching Hulu live tv (History channel) the surrounds are outputting sound (LCPM stereo I think according to Sonos App) - when I switch to Motortrend channel they’re outputting Dolby 5.1.

All is well, not every channel has surround, but at least there is sound outputting on the History channel.

But if I then switch back to History channel from Motortrend, surrounds cut out - subs and Arc still have sound. Switch back to Motortrend channel, surround’s are still outputting as before, 5.1. Back to History again, no sound on surrounds. Sonos app still says LCPM stereo.

Only way to get surround on History back is to quick out of Hulu (or just goto Apple home screen) and force quit Hulu app and restart. I can reproduce this all the time.

On my TCL Roku tv this never happens in Hulu live.

Haven’t tested more Hulu channels… Gotta be the Apple Hulu app I think. All gear and apps are up to date on everything.

Wondering if anyone else can reproduce this?


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 7

What is the Change Format and Audio Format settings on the Apple TV currently set to? If you change these settings, does it make a difference?

I was watching a ‘recorded’ Late Night With Stephen Colbert earlier on Apple TV using the Hulu app, sound dropped in the middle of a discussion with Bono. I was able to reproduce it, and identify it as a Hulu issue, as when I backed out to the Apple OS, I could here the navigation sound. After fast forwarding about 10 minutes in the recording, the sound returned. I am guessing an issue with Hulu itself.

Userlevel 4
Badge +2

I don’t have change format on - set to auto - Apple TV 4K should play Atmos when available and does (Disney +, etc.).

Deleted Hulu and data and logged in again. Same thing with those two channels. Roku TV reports Dolby Digital Plus 5.1 on Sonos app when playing those channels. Apple TV 4K reports Dolby Digital 5.1 now, but switching still results in no surround on History channel, Motortrend is always fine when switching back.

Did notice too that when watching Atmos movie (Thor Love & Thunder) on Disney +, rewinding would sometimes result in complete loss in audio until backing out of movie and starting up again from where it was left off. Have a 500 mbps connection and no problems on Roku when rewinding same movie.

Really think something is out of whack with Hulu stuff on Apple. Tried to “chat” with their support - ended up with them asking me for all of my info multiple times and switching chat reps whose names I can’t pronounce - even though I was logged in. Didn’t feel comfortable with them asking me for info so many times (Didn’t give them anything btw - you really need my DOB??? lol - noper - how about my retirement account login???).

Guess I’ll just use the Roku for now. Or switch again. Streaming providers really stink these days… 

Userlevel 4
Badge +2

Oh, and Audio Format on Apple TV is set to 4K Dolby vision (60 whatever). I never changed that or messed with - default.