Full Audio Needed Through Surrounds

  • 25 June 2022
  • 6 replies
  • 99 views

I'm trying to watch Glastonbury on my TV but the Sonos tries to play this stereo output as 5.1 which means 95% comes through the center (Beam) and none through the rear (One SL) speakers. I know yiu can disconnect the surrounds and set it up differntly but this should just be an option in the app to switch. This is easily done for music, so it should be possible for video content too. I k ow you was looking into it with the developers years ago but nothing has changed. Are we any further with this please


6 replies

One possibility would be to set the TV sound for stereo while watching Glastonbury.

One possibility would be to set the TV sound for stereo while watching Glastonbury.

It still doesn't play through the surrounds at the same volume when you do that. You just get the crowd noise

Userlevel 7
Badge +15

I asked for "Full TV" 5 years ago along with others and it didn't get any where.

You could group your SL's as another room but you'd get horrendous echo.

One possibility would be to set the TV sound for stereo while watching Glastonbury.

It still doesn't play through the surrounds at the same volume when you do that. You just get the crowd noise

The TV is not supplying a two channel signal if this is the case.                                                                   

Go to Settings → System → About My System and check Audio In for BEAM.                                                                    

Userlevel 7
Badge +18

Why not increase the level to the surrounds in Settings? 

I asked for "Full TV" 5 years ago along with others and it didn't get any where.

You could group your SL's as another room but you'd get horrendous echo.

I have tried this and I added a delay to stop the echo. It's a good enough fix for now but this should have been something added to the Sonos app by now so you can easily switch.

 

 

Reply