Question

Dolby Atmos on a Sony XH95 with a Sonos Arc isn't working with Disney Plus

  • 21 February 2021
  • 2 replies
  • 61 views

  • Contributor I
  • 1 reply

I’ve been scratching my head for some time now. Let me explain.

I got my Arc and Sub g3 earlier this week, paired them with my two One SL’s. No issues at all. Everything smooth and it sounds really great.

The arc is connected to my Sony XH95 with the Hdmi cable that came with the arc. And, this is the interesting thing, both Amazon Prime and Apple TV+ is working perfect and i get amazing Dolby Atmos sound with the built in apps in my Sony tv.

But the built in Disney+ app is only showing Dolby digital 5.1. I have checked that everything is up and running with the latest downloads/firmware and whatnot, i have searched the worlds widest web for answers and tried some different things like resetting the tv, uninstalled Disney+, pulled all the cables out and put them back in again.

Amazon Prime and Appletv+ is still giving me Dolby Atmos. But Disney+ is not.

I am sort out of ideas here. Anyone else here with the same issue that have any tips or tricks down their sleeve? Any help would be much appreciated. 


2 replies

I’ve been scratching my head for some time now. Let me explain.

I got my Arc and Sub g3 earlier this week, paired them with my two One SL’s. No issues at all. Everything smooth and it sounds really great.

The arc is connected to my Sony XH95 with the Hdmi cable that came with the arc. And, this is the interesting thing, both Amazon Prime and Apple TV+ is working perfect and i get amazing Dolby Atmos sound with the built in apps in my Sony tv.

But the built in Disney+ app is only showing Dolby digital 5.1. I have checked that everything is up and running with the latest downloads/firmware and whatnot, i have searched the worlds widest web for answers and tried some different things like resetting the tv, uninstalled Disney+, pulled all the cables out and put them back in again.

Amazon Prime and Appletv+ is still giving me Dolby Atmos. But Disney+ is not.

I am sort out of ideas here. Anyone else here with the same issue that have any tips or tricks down their sleeve? Any help would be much appreciated. 

Perhaps the updated Disney+ App hasn’t been rolled out to your region yet. I would be more concerned if the App stated the programmes had atmos audio and you were only getting Dolby 5.1.

My TV’s Disney+ App has atmos, but my Apple TV doesn’t - so it’s swings and roundabouts.

I would wait for the next Disney+ App update and see if that fixes it… the Movies like ‘Mulan’ etc; will show next to their title that the audio encoding includes Atmos.

I’ve been scratching my head for some time now. Let me explain.

I got my Arc and Sub g3 earlier this week, paired them with my two One SL’s. No issues at all. Everything smooth and it sounds really great.

The arc is connected to my Sony XH95 with the Hdmi cable that came with the arc. And, this is the interesting thing, both Amazon Prime and Apple TV+ is working perfect and i get amazing Dolby Atmos sound with the built in apps in my Sony tv.

But the built in Disney+ app is only showing Dolby digital 5.1. I have checked that everything is up and running with the latest downloads/firmware and whatnot, i have searched the worlds widest web for answers and tried some different things like resetting the tv, uninstalled Disney+, pulled all the cables out and put them back in again.

Amazon Prime and Appletv+ is still giving me Dolby Atmos. But Disney+ is not.

I am sort out of ideas here. Anyone else here with the same issue that have any tips or tricks down their sleeve? Any help would be much appreciated. 

Perhaps the updated Disney+ App hasn’t been rolled out to your region yet. I would be more concerned if the App stated the programmes had atmos audio and you were only getting Dolby 5.1.

My TV’s Disney+ App has atmos, but my Apple TV doesn’t - so it’s swings and roundabouts.

I would wait for the next Disney+ App update and see if that fixes it… the Movies like ‘Mulan’ etc; will show next to their title that the audio encoding includes Atmos.

 

Thanks Ken, I wasn´t aware of this update, but it seems to be dealing with that issue. I talked to a person at Disneyplus help center just now and they told me that there is an update on its way. Hopefully that will help with my Dolby Atmos issue as well. We´ll see how long it takes for it to go live, i live in Sweden and i guess we are not the biggest market but nevertheless we are a part of Europe and i guess Disneyplus has a few customers here. :)

Reply