Answered

Beam gen 2, LG C9 OLED and Xiaomi Mi box

  • 8 July 2022
  • 7 replies
  • 126 views

Hi,

Everything works fine until I connect Mibox streamer to one of other HDMI ports. 

When I turn off and on the TV, after a few seconds, tv switches to internal speakers. 

I need to change the output to HDMI manualy or disconnect the Mibox. 

 

Beam connected to HDMI 2

HDMI-eARC enabled 

Pass through

CEC enabled

Tried to switch Quick start + on and off. Didn't help.

 

Any suggestions? 

Thank you 

icon

Best answer by 106rallye 9 July 2022, 11:50

View original

7 replies

I can see there are CEC issues reported in relation to the Mibox from some quick online searches, if able. have you tried switching off CEC on that device? Also check for any firmware updates too.

Yes, switched off CEC on Mibox. Didn't help.

When I turn on the TV, the sound switches to internal speakers. But if I also turn on Mibox, the sound will switch to Beam.... Weird

All the devices updated.

 

With CEC switched ‘off’ in the Mibox settings, maybe try toggling Simplink ‘OFF/ON’ in the TV settings and just go through the ‘TV setup’ again in the Sonos App ‘Settings/System/[Beam Room Name]’ also toggle OFF/ON ‘TV Autoplay’ and see if that solves it.

Thanks Ken. 

Tried it, issue remains... 

Frustrating

 

Userlevel 7
Badge +17

A CEC killer between de Mii box and the TV would be the next option. They are not expensive: https://www.amazon.com/Lindy-HDMI-Adapter-Female-41232/dp/B00DL48KVI

I am considering upgrade to Nvidia Shield TV. Hope it will work better. 

I am considering upgrade to Nvidia Shield TV. Hope it will work better. 

FWIW: I use the Shield with two Sonos HT setups here (Arc & Beam2) and the Shield works great - my main TV is the older LG C9. 

Reply