Answered

Beam gen 2 and Sky Q audio sync

  • 5 December 2021
  • 6 replies
  • 357 views

Yes, I'm afraid it's the old chestnut again.

I've just upgraded from 1st gen. I had no problems as I was taking the audio out from sky Q into a toslink switcher via the optical adapter .

I upgraded mainly for Atmos, so don't want to involve optical any more, so I'm taking HDMI from the Samsung Tv's eArc output to the Beam .

As usual TV apps are no problem, but now I seem to have introduced the audio lag for Sky Q, which no end of adjustment will alleviate. 

Is it still a case of putting up with "normal" sound setting from Sky these days? I'm starting to think I shouldn't have bothered with the upgrade..

icon

Best answer by Blues1905 23 January 2022, 16:16

View original

6 replies

Badge +17

Hi @Blues1905,

 

I’m afraid I’m not totally sure of what the solution here is, but I’ve seen some community members mention a “passthrough” setting inside the TVs ARC settings. Could you have a look there and check whether your TV is set to passthrough?

If that doesn’t help, another community member should hopefully chime in here with another suggestion.

Hi, did you find a solution for this?

I’m having the same issues. 

Audio lag when watching sky q with audio output (HDMI) set to Dolby Digital instead of normal.

TV apps work fine. 

 

Yes I did. My solution was that I found a buried menu setting on my Samsung TV, to allow pass thru of the sound.

So it definitely the TV processing causing the delay in my case. 

Yes I did. My solution was that I found a buried menu setting on my Samsung TV, to allow pass thru of the sound.

So it definitely the TV processing causing the delay in my case. 

I have a 2019 Samsung QLED 4K tv and cannot locate this setting, what is the exact name?  I too am having the lip sync issues with SkyQ and am about to return the Beam 2 !

Cheers.

Userlevel 7
Badge +20

I had this issue on a 2018 Samsung on both Optical and HDMI.  There was no setting to allow pass through on my model.

I solved it by using a switch to divert optical from each source to the Playbase.  I tried HDMI on the Beam and again the delay an using a switch was not an option in that case.  Although I think there may be a solution involving the Arcane Fury, if thats the name!

All delays for me solved when I moved to a Panasonic TV.

The Arcana HDFury is indeed a possible solution. There is a similar device made by Feintech (which I think is a bit cheaper. 

Reply