Answered

audio problems with vizio tv and beam

  • 14 April 2021
  • 5 replies
  • 54 views

Hello out there,

I have an sonos beam with two play1 and sub for about a year now. I just noticed recently that system is not playing in  dolby 5.1, but instead in pcm,/ surround.

My tv is a vizio 652ui-b2 and my cable/satellite service is direct tv. I looked at my audio tv settings and it was set on PCM. So I switched it to bitstream. And my sonos beam started playing in dolby. So I thought I fixed the problem.

But when I tried to use my remote the sound cut off.  I then switched the tv back to PCM, and everything worked ok. But I'm not getting dolby sound from my sonos.

This kind of defeats the purpose of having a sonos system.

If anyone out there had this issue?  let me know please thanks

 

icon

Best answer by Corry P 15 April 2021, 10:36

HI @Oldguy59 

Welcome to the Sonos Community!

You’ll certainly want to have the TV on Auto or Bitstream - PCM is stereo only.

Is your Beam connected to your TV via HDMI or Optical? If Optical, then you can try reprogramming the remote.

If the Beam has an HDMI connection, however, there may be something else at work. First, I recommend you remove power from your TV (standby just won’t do the same job) for about 30 seconds.

Plug the TV in again and wait for it to start up. Once it does, please try using the TV’s remote to control the volume - does it do the same thing again?

If so, please unplug the TV again, remove other HDMI devices from the TV, plug the TV back in and try once more. If that works normally, plug the other devices back into the TV and test with each one added. If you find that one particular device causes the problem, see if you can disable CEC in it’s settings.

If the volume control mutes the sound regardless of other devices, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system.

View original

5 replies

Userlevel 6
Badge +16

HI @Oldguy59 

Welcome to the Sonos Community!

You’ll certainly want to have the TV on Auto or Bitstream - PCM is stereo only.

Is your Beam connected to your TV via HDMI or Optical? If Optical, then you can try reprogramming the remote.

If the Beam has an HDMI connection, however, there may be something else at work. First, I recommend you remove power from your TV (standby just won’t do the same job) for about 30 seconds.

Plug the TV in again and wait for it to start up. Once it does, please try using the TV’s remote to control the volume - does it do the same thing again?

If so, please unplug the TV again, remove other HDMI devices from the TV, plug the TV back in and try once more. If that works normally, plug the other devices back into the TV and test with each one added. If you find that one particular device causes the problem, see if you can disable CEC in it’s settings.

If the volume control mutes the sound regardless of other devices, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system.

Thanks  Corey for replying to me so quickly. I probably didn't give you enough information on my sound problem.

I use a direct tv genie sat box for my television. I think there is an  interference issue with the direct tv remote ( I don't use the vizio tv remote). because I disconnected the sonos from the tv using the tv speakers, and everything seemed to work ok. But when I reconnected the sonos into tv Arc system, and tried using the  genie remote features the volume went mute again.( I'm  actually getting dolby sound if I don't use the remote).

I have tried to reprogram the genie remote with sonos several times, with the same results.

I'm going to try maybe using optical instead of Arc. I don't know what's going on. But I will try doing your instructions and then let you know if it works.

Thanks again

 

Userlevel 6
Badge +16

Hi @Oldguy59 

There are two ways your Genie remote can control your Beam volume.

Currently - when it works - the remote sends the signal to your Satellite TV box, the box realises it shouldn’t do this itself so sends the command through the HDMI cable via a CEC command. The TV gets the volume command and also realises it’s not the one to do the job and so sends the signal, also via HDMI and CEC, to the Beam, which then alters it’s volume. The TV Box, the TV and the Beam all have to be cooperating for this to work, and a TV reboot generally does the trick to fix issues - if there aren’t any devices causing CEC problems (unfortunately, this isn’t uncommon). If rebooting the TV doesn’t help, I recommend you reboot the Genie box too (unplug - again, standby won’t suffice). 

If you connect the Beam to the TV with the Songle Optical Adaptor, then there is no longer a path for the CEC command to take to reach the Beam, so you would then have to program the Beam to accept the Genie’s IR remote commands via the Sonos app as outlined on our reprogramming the remote page, for the remote to work with the Beam.

There will be no loss in audio quality when changing the connection to Optical, but you will lose the ability to turn the TV off or on via Voice Commands (unless the TV has this feature independently). You may also have to manually disable the TV’s internal speakers.

Hi Corry,

Once again  thanks for your help.

I've tried unplugging and rebooting all devices with unfortunately the same problem.

I've tried deleting the remote on SONOS app, but there's nothing in the app about deleting remote..just if want to set up a remote.

I noticed if I go to CEC on the tv. It lists: Enabled, Disabled, or Arc only. No sure what they all mean?

I'm not able use to optical yet. Still waiting on ordering a cord and adapter to arrive.

I'm not sure what else to try..maybe use a different remote??. 

If you have any more suggestions I would appreciate it. I know you've given me a lot at this point

Thanks

Userlevel 6
Badge +16

Hi@Oldguy59 

I've tried deleting the remote on SONOS app, but there's nothing in the app about deleting remote..just if want to set up a remote.

Apologies - I was mistaken. I’ll edit my post above to remove that advice. You cannot remove programmed remotes from Sonos - only replace them.

I noticed if I go to CEC on the tv. It lists: Enabled, Disabled, or Arc only. No sure what they all mean?

For your Genie remote to work, via CEC, this will need to be Enabled. If you were to set it to ARC only, the TV remote would send volume controls to your Beam, but the Genie box would not (unless Beam has been programmed to use the remote’s IR codes).

I'm not able use to optical yet. Still waiting on ordering a cord and adapter to arrive.

The Songle adaptor comes with the Beam - you should have one already, and you do not need an optical cable to go with it, just the HDMI cable you’re already using.

I'm not sure what else to try..maybe use a different remote??. 

This is certainly something worth trying, though obviously it’s easier to have that one remote doing channel swapping too.

If you have any more suggestions I would appreciate it. I know you've given me a lot at this point

At this point, if it’s still not working for you, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system.

Reply