Arc with LG B7 - no Atmos



Show first post

47 replies

Badge

I did uncheck that for HDMI2. 

Userlevel 2
Badge +3

Here are my settings:

 

SOUND:

Dolby Atmos ON

Smart Sound Mode OFF

Sound Out Audio Out (Optical/HDMI ARC) You have to click in here and turn Digital Sound Out = Auto and SIMPLINK (HDMI-CEC) On

 

Magic Sound Tuning OFF

DTV Audio Setting AUTO

AV Sync Adjustment OFF

Did you set the Arc up with Simplink in the Sonos App?

Badge

Yep - I got my Arc yesterday and it works on my B7. 

 

Have you double checked that you’ve unchecked the ‘HDMI Deep Colour’ setting on the HDMI channel the Arc is connected to? You need to set the TV to HDMI 2 to do this, and go to Setting - General - HDMI Deep Colour if I recall correctly.

 

Just to check with your B7V - did you get sound immediately on plugging in the HDMI2  as well or have to fiddle with settings?  No sound at all for me as yet!  On the plus side the more people it seems to be working easily with the better case I have to say to LG that they need to fix my TV for me I guess!

Badge

Thanks for the respons , I will check and report back. 

Userlevel 2
Badge +3

I had to do the setup in the Sonos app and it told me I didn’t have Simplink turned on, after that it was fine. Checked I was getting Atmos with Roma on Netflix. All good. Sounds fantastic!

Badge

Checked everything and still no Atmos.  Not sure if the surround speakers are having an effect or that I had a Playbase connected before.  Just grasping at straws at this point.

Userlevel 2
Badge +3

What source are you using to send atmos?

Badge

I have tried Netflix (internal app), Disney+ on 4k Firestick and through Xbox - 4k discs.  I have tried a different HDMI cables for the Arc.  I just tried removing the surround speakers as well.  Still no luck.  I can get Atmos to play through the TV speakers, but that kind of defeats the purpose.

Userlevel 2
Badge +3

Did the Sonos app say that the arc was working when you set it up?

Badge

I don't recall, but I  would assume so.  It sounds great, but would love to hear how much better it sounds with Atmos.

Badge

Ok, I figured out the issue.  I was actually expecting the TV to display Dolby Atmos on the screen when content starts playing.  If you are using the internal speakers, it will do that.  I checked via the app and it says it is playing Atmos.  Although it sounds really good, I was actually expecting more height effects.  I also tried the opening scenes in John Wick 3 (4k Blu Ray) with the rain falling and again a little disappointed but obviously much better sounding than the Playbase.  I do also notice slight audio hiccups while playing John Wick 3 that I don’t hear with streaming apps.

Userlevel 2
Badge +3

haha!

Userlevel 1
Badge +7

Very frustrating.  All settings seem to be correct, but neither native apps nor apps on 4k firestick will play atmos.  TV firmware is up to date.  I am using the hdmi cable that came with the sound bar which I assume supports ARC but will try another cable.

me too with your same problem
  

 

 

Badge

I had to do the setup in the Sonos app and it told me I didn’t have Simplink turned on, after that it was fine. Checked I was getting Atmos with Roma on Netflix. All good. Sounds fantastic!

What did you change to get it to recognise simplink was turned on?

Userlevel 3
Badge +4

I had to do the setup in the Sonos app and it told me I didn’t have Simplink turned on, after that it was fine. Checked I was getting Atmos with Roma on Netflix. All good. Sounds fantastic!

What did you change to get it to recognise simplink was turned on?

my guess from @Andrewnoob’s description is the “TV Setup” in the Sonos app:

Settings>System>(choose room with Arc)>(scroll down to Home Theater section) click on TV Setup and follow the directions.

Userlevel 2
Badge +3

Exactly. It will check the TV and Soundbar are communicating correctly,

Badge

LG have finally got back to me and apparently they think its a faulty motherboard which they will replace at £399! 

Fortunately I bought the TV from Richer Sounds who will collect tomorrow to repair for free!

 

Hi.    I fixed the issue by  

Go to General options and switch off Simplink 

then go to sound and switch back on hdmi arc and then the Sonos app showed atmos

Tv LG B8 STB

Badge

That may well work for some... In my case it was a new motherboard (thankfully richer sounds did 5 years warranty!)

Checked everything and still no Atmos.  Not sure if the surround speakers are having an effect or that I had a Playbase connected before.  Just grasping at straws at this point.

When you say no Atmos..Is there no sound coming from Arc when you choose Sound out - HDMI ARC ?

Hi. Just got my arc and set it up with a lg b7v. One thing I noticed is that netflix native app only shows atmos with original english sound track. If i switch to my native tongue i get dd+. I don’t know if that explains some of the observations made in this thread.

Userlevel 2
Badge +4

I read on the Tidal support page that it must be eARC for music Atmos.   I also have a 2017 Oled and a Sonos Arc.   Netflix and Prime Atmos works, however.

 

Reply