Arc / PS5 / LGCX sound issue

  • 17 March 2021
  • 1 reply
  • 486 views

Hi there

Equipment

  • LG55CX + PS5 + Arc home theater setup (arc + sub + 2 x One SL)
  • PS5 is connected direct to TV via HDMI 2.1
  • Arc connected to TV via eARC connection using HDMI supplied in box
  • Other devices connected direct to TV via 2.0 HDMI splitter

Issue

When watching normal TV (SkyQ) or using another product, such as a Nintendo Switch, the connection between the devices and the sound output is absolutely fine. No issues. Likewise, there is no issue with Netlifx, NOWTV or Prime services via the TV apps. 

When you switch the input to PS5, I would say there is a 50/50 chance that the TV/Arc will not handshake properly and there will be no sound output.

If you switch back to another HDMI input sound returns immediately. When you switch back to PS5 there is still no sound.

If you turn off eARC on TV settings the sound returns, but that is not a fix in my opinion.

I am satisfied that the TV/PS5 is setup correctly to pass through bitstream following the recent updates, albeit the app still shows speaker output as 7.1 which I understand may or may not be fixed in the future.

The only real fix I have found is to either;

  1. Turn the TV off and on. This only works if the TV has been on for a while and the TV then engages the pixel refresher when switched off. If there is no pop noise from the TV when switched off then the issue continues. 
  2. Unplug both the TV and the Arc, wait a few seconds, then power the devices back up again.

Having to fix this issue is becoming tiresome. Is there any real fix for what appears to be a handshake issue?

Both Sonos and LG products are on latest firmware.

Thanks

 

 


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 6
Badge +15

Hi @Milano, welcome to the Sonos Community!

Given that the issue stops when you disable eARC on the TV, it certainly seems that the issue is on the TV’s end - possibly another device interfering with communication.

Would it be possible to test if this occurs with only the PS5 and Arc connected to the TV via HDMI? Do you still lose audio switching between internal apps on the TV and the PS5?

If there are no issues in this setup, it may be worth reconnecting your other devices one at a time and checking if any of them cause this behaviour :)