Answered

5.1 Setup but Sonos receiving in "Stereo"

  • 4 January 2019
  • 2 replies
  • 442 views

Userlevel 1
Badge +2
  • Avid Contributor II
  • 15 replies
Hi,

I have recently added an Apple TV4K and 2 One's to my living room setup which now has a Playbar, Sub and the 2 new One's.

My Television is a pretty dated Panasonic Plasma P50U30A.

If I set my ATV4K to Dolby Digital I am not getting any audio and in Sonos > About the Audio is showing as "Silence". If I switch my ATV4K back to Best Available I get Audio and Sonos > About shows the Audio as Stereo and not Dolby Digital . Pretty certain the Netflix content I am testing with is DD content.

Any ideas how I can get Dolby Digital output on my 5.1 setup or is the limitation due to my TV not being able to pass through the signal?
icon

Best answer by Flare 8 January 2019, 21:51

It turns out Panasonic even new models has lack of support for pass through on the Digital Cable :(

Change the TV to a Sony 4K, DD works perfectly now and sounds truly amazing.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

It sounds like the TV is the problem. I suggest you get an HDMI audio extractor and insert it between the ATV and the TV. This would output audio over optical. You'd then presumably need an IR-controlled optical switch to select between the TV and the ATV's audio.
Userlevel 1
Badge +2
It turns out Panasonic even new models has lack of support for pass through on the Digital Cable :(

Change the TV to a Sony 4K, DD works perfectly now and sounds truly amazing.