Skip to main content
Contributor I
April 29, 2017

Samba Connectivity | Terribly Disappointed

  • April 29, 2017
  • 15 replies
  • 10746 views
The Sonos Controller is unable to connect to the Music Library if the Samba Server is on Linux
    This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

    15 replies

    wpw3Author
    Contributor I
    July 20, 2017
    sprataw, you did not receive your just accolades for this succinct and useful answer. Such insight does not happen often on community sites. I wanted to write to say 'well done' and thank you.
    Contributor I
    July 25, 2017
    you *must* have "ntlm auth=yes" in the global section of your smb.conf file in order for SONOS to connect. They are still using an older version of the protocol that newer linux systems have disabled by default.

    Fantastic. Have just upgraded my music server from Debian Jessie to Stretch (aka Debian 9) - Samba was clearly working (from Windows & OSX) but the Sonos system would not authenticate - gave the unable to connect / check username / password error, setting this in my smb.conf file fixed things... many thanks!
    Trending Lyricist I
    September 30, 2017
    Put me on the list of grateful Linux users for the "ntlm auth=yes" configuration change. For me it was a necessary add on my CentOS server when upgrading from samba 4.4 to 4.5.

    Many thanks,
    Ted
    Lyricist II
    January 2, 2018
    I just migrated from an Ubuntu 12.04 file server to a raspberry pi running raspbian 9. Samba sharing was working fine on the old server, so I used it's samba config as a basis for the raspberry pi, but no love. Spent several hours over a couple days trying to debug it (my Macbook could connect easily). Wasn't 'til I came across this post and sprataw's advice that I got it working. There oughta be a SONOS samba help file with this info somewhere in the controller for when you have difficulty connecting.
    Lyricist I
    August 21, 2018
    you *must* have "ntlm auth=yes" in the global section of your smb.conf file in order for SONOS to connect. They are still using an older version of the protocol that newer linux systems have disabled by default.

    Thanks for this tip. For years, sonos connected to my ubuntu samba shares, but stopped last week. I went in circles until I understood this and needed to update my smb.conf file. However, SONOS, GET UP TO SPEED ON SECURITY! Sheesh!