Answered

Alexa and BBC

  • 17 October 2019
  • 8 replies
  • 192 views

Until recently Alexa would play BBC Radio 4 and 6 music on request.  Now when I ask for radio 4, it plays an American station.  When I ask for Radio 6 Music, it selects various BBC stations, but not the one I want.  I’ve tried many permutations for the request.  I see some comments online about Alexa not working with BBC sounds and no longer working with TuneIn, but my Alexa does play BBC radio stations, just not the ones I request!

 

Many thanks in advance,

Andy

icon

Best answer by UKMedia 18 October 2019, 11:47

No probs, you just need to create a new Trigger via the wizard rather than select an Applet already created. :)

1/ Log in to IFTTT and then click on your profile picture and select ‘Create’;

2/ Click on the ‘+’ symbol in the phrase, select ‘Amazon Alexa’ and then select ‘Say a specific phrase’;

3/ Type in your preferred phrase for Alexa to respond to. e.g. ‘play radio 4’;

4/ Click on the newly located ‘+’ symbol and select ‘Sonos’

5/ Select ‘Play Favorite’ and then complete the action fields for the station and the rooms that you want the Audio to output on, followed by ‘Create Action.

6/ Alexa will then respond to ‘Alexa Trigger Play Radio 4’

Just repeat these steps for any other combination of stations and rooms.

View original

8 replies

Userlevel 7
Badge +20

Hi Andy

 

The BBC has decided to remove all BBC radio stations from Tunein via Alexa.  It’s possible to use the App or use IFFFT. Just carry out these actions:

 

1/ Open the Sonos App and search for BBC Radio 2 under the Stations tab;

2/ Select the three verticle dots and add to ‘My Radio Stations’;

3/ Open a web browser and search for IFFFT;

4/ Create an account or log in and search for Sonos;

5/ Add the Trigger ‘Play a favorite with Amazon Alexa’

6/ Follow the instructions and link to your Sonos Account and select Radio Two with the Phrase that you think is memorable - e.g. ‘Radio 2’;

7/ Save this and then ask ‘Alexa, Trigger Radio 2’

Many thanks for the advise, that works, but: I can only add one trigger.  I cannot find a way to have a trigger for radio 4 and another for radio 6.  I can’t believe this is correct, but I’ve looked and looked, but cannot see an option to add a second trigger.  Is this correct?

No it is wrong! You need a separate applet for every station. And for every speaker-ststion combination if you have seversl speakers you want to play through.

Userlevel 7
Badge +20

Let us know if you want step by step instructions on how to do a second trigger.

Thanks for the offer for the instructions, please do send them.  I try to add the “ Play a favorite with Amazon Alexa “ trigger a second time and this takes me to my first trigger, which I can edit, but I cannot see any way to add a second one.

 

Many thanks

Userlevel 7
Badge +20

No probs, you just need to create a new Trigger via the wizard rather than select an Applet already created. :)

1/ Log in to IFTTT and then click on your profile picture and select ‘Create’;

2/ Click on the ‘+’ symbol in the phrase, select ‘Amazon Alexa’ and then select ‘Say a specific phrase’;

3/ Type in your preferred phrase for Alexa to respond to. e.g. ‘play radio 4’;

4/ Click on the newly located ‘+’ symbol and select ‘Sonos’

5/ Select ‘Play Favorite’ and then complete the action fields for the station and the rooms that you want the Audio to output on, followed by ‘Create Action.

6/ Alexa will then respond to ‘Alexa Trigger Play Radio 4’

Just repeat these steps for any other combination of stations and rooms.

Great, that did it. 

 

Many thanks

Andy

Thanks for this. Just searched for how to do this in IFTTT after the BBC TuneIn change stopped my Echo using a Sonos as a default speaker. All working :thumbsup_tone1:

Reply