Sonos / Mixcloud / VPN

  • 28 January 2022
  • 4 replies
  • 61 views

Userlevel 1
Badge +1

Everything used to work fine since years but recently I can't connect to Mixcloud with Windscribe VPN activated through Sonos. It works only if I disable the VPN. Same problem on iOS or macOS. 

Mixcloud native application works well with the VPN activated, and also when using Airplay2 as a workaround,  but not through Sonos.

This problem is only related to Mixcloud. No issue with Apple Music and YTM. 

 

 iOS Sonos 14.0 

iOS 15.3 / macOS 12.3

iOS Mixcloud 32.4.2


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 7
Badge +22

Is your VPN configured in your router, or on your iOS or Mac device? Needs to be the former, as the speakers are the devices that connect to the music services for playback.

Userlevel 1
Badge +1

 

Is your VPN configured in your router, or on your iOS or Mac device? Needs to be the former, as the speakers are the devices that connect to the music services for playback.

Nope. I use Windscribe application on each device and LAN option is checked. 

Sorry I clicked on the wrong button. Your response isn't the answer to my problem. 

Userlevel 7
Badge +22

You can’t run Windscribe on the speakers, so the VPN isn’t used for music playback. You need a VPN in your router, like I said.

Userlevel 1
Badge +1

I don't know what you are talking about, running WS on the speakers? 

I am not asking how to set up a VPN. 

I am saying when the VPN is activated on my iPad, iPhone or MacBook Pro I cannot access Mixcloud through Sonos application. 

Because it works well when using Airplay the conclusion is obvious. Sonos seems to prevent the access to Mixcloud when using a VPN.