Question

Sonos Device keeps dropping off the Network, and insufficient network speed to maintain playback.

  • 10 September 2019
  • 2 replies
  • 61 views

We have Sonos in our workplace. We have 4 connects wired to an amp feeding multiple speakers.
We have 6 Play:1's, and 3 boosts.

We have taken all devices off the wired network and only have the Boosts wired with everything on Sonosnet.

The noise level is terrible but we have gotten things stabilized minus a connect which is 3 feet away from a boost. It keeps dropping off completely, or saying list connection to Apple or spotify or whatever. Or it will state there is insufficient network speed to maintain playback. We have a 200 MB DIA circuit. The boosts are plugged into cisco switches with the Guard turned off on the 3 ports.
This is becoming a job to maintain music playing at our workplace and a constant area of irritation.

The device with the most problems is below.




code:
contents of /proc/ath_rincon/status
Debug info for INFRA mode at 81332

Mode: INFRA (sonosnet)
Operating on channel 2437
Home channel is 2437
RF Chains: RX:3 TX:3
RF Chainmask: RX:0x07 TX:0x07
Max Spatial Streams: RX:2 TX:2
Noise Floor: -89 dBm (chain 0 ctl)
Noise Floor: -91 dBm (chain 1 ctl)
Noise Floor: -86 dBm (chain 2 ctl)
PHY errors since last reading/reset: 4547978
OFDM Weak signal level: 7
ANI Updates: S:1 F:0
ANI Reg: DSIZE:0x6c28b0de AGC_CTL1:0x313a5d5e F_SIG:0x7ec08d2e TIMING5:0xd0058a19
Ch11 Spur Immunity Level: 0
HAL Reset Failures: cnt: 0 last: 0
Region: 1

Node 00:0E:58:A5:85:43 - FROM 00 : TO 00 : STP 00 : MODEL 16.5: KEY 13
00

Node 00:0E:58:A4:F3:3F - FROM 15 : TO 00 : STP 00 : MODEL 16.5: KEY 12
15

Node 00:0E:58:A5:76:A7 - FROM 13 : TO 00 : STP 00 : MODEL 16.5: KEY 11
13

Node 34:7E:5C:10:FD:1D - FROM 19 : TO 00 : STP 00 : MODEL 20.1: KEY 10
19

Node 5C:AA:FD:79:49:EB - FROM 28 : TO 20 : STP 04 : MODEL 8.3: KEY 9
28

Node 78:28:CA:72:53:05 - FROM 73 : TO 72 : STP 03 : MODEL 12.1: KEY 8
73

Node 00:0E:58:C4:17:0F - FROM 28 : TO 24 : STP 04 : MODEL 8.3: KEY 7
28

Node 78:28:CA:71:D9:E3 - FROM 20 : TO 16 : STP 00 : MODEL 12.1: KEY 6
20

Node 78:28:CA:E1:A4:01 - FROM 28 : TO 31 : STP 04 : MODEL 26.1: KEY 5
28




submitted diagnostics
Your confirmation number is: 864011658

Since everything is running on Sonosnet and getting signal from the boosts, why can the sonos network mesh not handle basic streaming or group play.


Just dropped off completely.
diag is 1459958056

2 replies

Userlevel 7
Badge +20
Thanks for sending in the report. There's quite a bit of wireless interference from nearby networks. This is likely the cause of the wireless communication errors showing between your Sonos components. I'd recommend changing the wireless channel your Sonos system is using to 11, which seems a bit less crowded. Also, Make take a look around your speakers and Boosts to see if any third party electronics are nearby that can be moved away.
Thanks you for the response and going to try that out today. There is tons of noise, other wifi networks, wireless printers, headsets, mobile devices, etc.

Again Thank You and will follow up with results.

Reply