Sonos Beam + Amp ethernet with Sub on Wi-Fi - Not Working

  • 28 November 2023
  • 13 replies
  • 176 views

I have a Beam and Amp (for rear surrounds) connected to the network via ethernet. I also have a Sub connected via Wi-Fi. Everything was showing connected and linked fine in the Sonos app, but there was no audio from the subwoofer. While trying to fix this, I disconnected the Beam from ethernet and switched it to connect via Wi-Fi (like the Sub). Now there is audio coming from the Sub, but no audio from the rear surrounds powered by the Amp anymore.

 

Why does it seem like all devices linked in the same room need to all be on ethernet, or all be on Wi-Fi for things to work? There is also no indication that there is a problem in the app, just no audio coming from the speakers.

 

The Amp is in an A/V rack on the other side of the house, so I can’t enable Wi-Fi on the Amp, it needs to stay on ethernet. I would also prefer to keep the Beam connected via ethernet as well. Just the Sub needs to be connected via Wi-Fi.

 

How can I make this work?


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

13 replies

Did you disable the “WiFi” on the Beam when it was wired? That would have killed the 5GHz wireless connection for the Sub.

Yes, I did disable Wi-Fi on the Beam when it was wired. But I connected the Sub to the Wi-Fi network directly. Why can’t the Sub communicate with the Beam over the Wi-Fi network?

 

The problem I usually have is that Sonosnet causes massive network loops, so I always disable Wi-Fi on any Sonos device that’s connected to ethernet. If I had two rooms with this same setup (a wireless Sub) on separate ends of the home, and wired both Beams and enabled Wi-Fi, this would cause a massive network loop that takes the network down. Why can’t the Sub use the home’s Wi-Fi network to communicate with the Beam that’s connected to ethernet?

Userlevel 7
Badge +18

You still need wifi enabled on the Beam. It uses a dedicated 5Ghz connection to sub and surrounds. 

So is it supported for the Beam to use dedicated 5GHz to the Sub and ethernet to the Amp for surrounds?

Userlevel 7
Badge +17

Looks like it works in your case. Normal procedure is to also connect the surrounds (Amp or speakers) using the dedicated 5Ghz link.

I can’t connect the Amp via Wi-Fi because it is at the other end of the house and the 5GHz signal won’t reach. What is the proper way to connect this setup?

If I have a living room and family room with the same setup, Sonosnet will cause a network loop (two devices connected to ethernet with Wi-Fi enabled) - what’s the proper way to avoid this?

Userlevel 7
Badge +18

I can’t connect the Amp via Wi-Fi because it is at the other end of the house and the 5GHz signal won’t reach. What is the proper way to connect this setup?

If I have a living room and family room with the same setup, Sonosnet will cause a network loop (two devices connected to ethernet with Wi-Fi enabled) - what’s the proper way to avoid this?

I’m a bit confused. The Sub will be bonded to the Beam, but the combined Beam-and-Sub is then a single room - eg Living Room. You can have Family Room also consisting of a Beam and a Sub. The same “setup” in multiple rooms is not an issue - that’s why “rooms” exist. Whether both Beams are wired or wireless, or one wired and one wireless, should be irrelevant. 

I can’t connect the Amp via Wi-Fi because it is at the other end of the house and the 5GHz signal won’t reach. What is the proper way to connect this setup?

If I have a living room and family room with the same setup, Sonosnet will cause a network loop (two devices connected to ethernet with Wi-Fi enabled) - what’s the proper way to avoid this?

I’m a bit confused. The Sub will be bonded to the Beam, but the combined Beam-and-Sub is then a single room - eg Living Room. You can have Family Room also consisting of a Beam and a Sub. The same “setup” in multiple rooms is not an issue - that’s why “rooms” exist. Whether both Beams are wired or wireless, or one wired and one wireless, should be irrelevant. 

The problem is, when I connect more than one Sonos device to the network via Ethernet, and also have Wi-Fi enabled on the same Sonos device (which would be the case if I were to have two rooms with the exact same setup described above using a wireless Sub), it causes a network loop which takes the entire network down.

The problem is, when I connect more than one Sonos device to the network via Ethernet, and also have Wi-Fi enabled on the same Sonos device (which would be the case if I were to have two rooms with the exact same setup described above using a wireless Sub), it causes a network loop which takes the entire network down.

I would first try wiring the Beam & Amp. Leave the Beam’s WiFi enabled, as the Wireless ‘bonded’ Sub will not use your routers WiFi signal, as it (mainly) communicates direct with the Beam over a 5Ghz ad-hoc wireless connection. If these things do still cause you a network ‘storm’ issue however, then it maybe best to wire everything to the LAN subnet, preferably wire all directly back to the router, or the same switch (if practical).

I can’t connect the Amp via Wi-Fi because it is at the other end of the house and the 5GHz signal won’t reach. What is the proper way to connect this setup?

If I have a living room and family room with the same setup, Sonosnet will cause a network loop (two devices connected to ethernet with Wi-Fi enabled) - what’s the proper way to avoid this?

Fix your network. It’s blocking STP packets somewhere along the wired path between the living room and family room master players. Managed switches usually need STP to be explicitly enabled. Some routers block STP traffic and can’t be fixed; the workaround is not to wire Sonos to multiple LAN ports.  

Userlevel 7
Badge +22

Grabbing an inexpensive DUMB Ethernet switch, hooking one port to your router and all your Sonos to the other ports will likely stop the loops. Do check the Sonos incompatible hardware list before shopping.

https://support.sonos.com/en-us/article/incompatible-network-hardware

I can’t connect the Amp via Wi-Fi because it is at the other end of the house and the 5GHz signal won’t reach. What is the proper way to connect this setup?

If I have a living room and family room with the same setup, Sonosnet will cause a network loop (two devices connected to ethernet with Wi-Fi enabled) - what’s the proper way to avoid this?

Fix your network. It’s blocking STP packets somewhere along the wired path between the living room and family room master players. Managed switches usually need STP to be explicitly enabled. Some routers block STP traffic and can’t be fixed; the workaround is not to wire Sonos to multiple LAN ports.  

I’m using Ubiquiti UniFi switches, and STP is enabled for all of the ports:

 

I’m using Ubiquiti UniFi switches, and STP is enabled for all of the ports.

Maybe see if this link will perhaps assist you and your local network setup…

https://github.com/IngmarStein/unifi-sonos-doc