Answered

Multiple ethernet connections

  • 12 December 2022
  • 5 replies
  • 1132 views

We have 8 Sonos speakers in various part of our house with an ethernet cable connected to our sub which is part of a surround setup.  Is it productive to connect other speakers in the house to ethernet or is one enough?  Thanks!

icon

Best answer by jgatie 12 December 2022, 02:03

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

It is not recommended to have a Sub or surround as the only wired unit.  Try wiring something else, or purchasing a Boost.

Userlevel 7

It is not recommended to have a Sub (or a surround) as the only wired product.

Are your other speakers even using SonosNet?

Within the app, under About My System, when using SonosNet, the device will show WM:0; WM:1 means it is using WiFi. (Roam and Move will always be WM:1), WM:2 will show for surrounds on WiFi.

If possible, I would switch the wired connection to the soundbar and go from there.

One is enough in many situations, but I prefer to wire as many players as is practical. Wired is always faster and more robust than wireless. Wireless can work very well in many situations. Local interference, dense walls in the home, or simple distance can compromise wireless performance.

If your system is working reliably, there is no burning need to change anything.

Wireless connections are dynamic. For example, neighbors might introduce something that causes wireless interference -- upsetting a formerly well functioning system. Another very awkward surprise might occur during a party. Humans are mostly bags of water and water absorbs WiFi energy. The extra load of water bags during a party may compromise wireless connections on an otherwise solidly functioning system.

Thanks for responses. 
 

We have 9 speakers in total with a Play 5 and sub connected (sub closest to Ethernet port), these are at opposite ends of our house. All show up as Ethernet connected on our router. All show as WM:0 on system though. 
 

Working well! Cheers 


 All show up as Ethernet connected on our router. All show as WM:0 on system though. 
 

WM: 0 is expected because the SONOS units have joined the private mesh network (SonosNet). ROAM and MOVE will always be WM: 1 (WiFi) because they do not join SonosNet. The router will show all of the SONOS units because they have used the router’s DHCP server. If the router is also a WiFi access point, the SonosNet units will not show a WiFi connection to the router’s access point.