Answered

Connecting LG OLED TV to Sonos Amp via HDMI Arc

  • 16 January 2023
  • 6 replies
  • 74 views

I am trying to connect my LG OLED television to the Sonos Amp via the HDMI Arc.  I can’t get the Sonos to recognize the TV audio out via the HDMI.  I’ve been on with support from both Sonos and LG. I’ve also used the optical out adapter to HDMI without success.  Sonos sent me a new Amp with same issue so it’s not an Amp issue.  I’ve used different HDMI cables.  My Tv and Amp are about 15 feet apart.  Today the LG support told me the HDMI cable can’t be longer than 3 feet.  This seems like bunk to me but I have not had a chance to try a different device using a short cable.  Anyone know if this is an accurate statement?  If it is, is there a workaround?

icon

Best answer by buzz 17 January 2023, 04:46

View original

6 replies

Three feet is a very conservative limit. Depending on cable quality three feet could be the limit if you were running 8K video over the cable. 15 feet is reasonable (with a quality cable) when sending HDMI-ARC audio.

Likely, this is a TV setup issue. Which model TV are you using?

Is HDMI-CEC enabled? I think LG call this '"Simplink".

It is a brand new LG OLED 48” C2 series.  If I recall, the CEC is enabled but not recognized.  It’s hidden deep in the menus.

 

What source are you playing?  Internal app\?  Blu-ray?

Trying to push TV audio to the amp.  I use streaming on the television, Hulu, Youtube etc.

I have solved the issue.  I found that it was an HDMI cable issue.  It took some time because I had two cable issues.  Cable from television to a wall mount HDMI receptacle was either bad or incompatible.  Additionally, the ultra high speed HDMI I tried to bypass it was either too long (30 ft) or incompatible.  I purchased another high quality 15’ 8k ultra HDMI from Monoprice.  When I bypassed the other HDMI components with this cable everything was recognized and worked properly.  So, 15’ of HDMI ARC will work.  I then replaced the HDMI from the TV to the HDMI receptacle and the HDMI from the other wall receptacle to the amp.  Vola!  All working.  Thanks for the input.  I hope this may help someone else in the future.

Reply