Answered

Sonos Setup Not Working


Userlevel 2

Here‘s what happening:

  1. I choose setup new speaker
  2. I choose the Roam SL
  3. It says „There was a problem setting your Sonos Roam SL…Let‘s try something else“
  4. Click Continue
  5. To continue, let‘s connect your movable device to the temporary network…
  6. I click Join
  7. Next your Sonos will play a chime…
  8. I click continue 
  9.  It plays a sound
  10. Says finalizing connection…
  11. “We‘re having trouble finalizing the connection to your Sonos Roam SL
  12. I click Try Again
  13. it fails again „We couldn‘t verify the audio passcode“6
  14. I try then the PIN number
  15. This also fails „There was a problem during setup“

 

I‘ve tried restarting my device, I‘ve tried on both my iPad and my iPhone.

 

Is this speaker just broken?  What else can I try?

icon

Best answer by LindaaaAaa 11 May 2024, 21:25

View original

120 replies

Userlevel 2
Badge

What do you mean revert wifi to old name? My wifi name has never changed. I tried seperating the 2.5 and 5ghz, that didn’t work. So they are merged again and still nothing. Also don’t have access to an android phone. 

Userlevel 3

What do you mean revert wifi to old name? My wifi name has never changed. I tried seperating the 2.5 and 5ghz, that didn’t work. So they are merged again and still nothing. Also don’t have access to an android phone. 

I was referring to an earlier reply by @MBLA2024 saying they were having issues with their other products after they had split their wifi and presumably given each band a new name. If they merged the bands under the same original ssid, their other products would likely reconnect- if the password was also kept the same. 

Userlevel 1

Same issue here. I already uninstalled the app and reinstalled it on my iPhone. I got a little bit further in the setup process. But when it asked me to press Play/Pause button on top of the Roam I got the message; Finalizing Connection. And then it got stuck and told me it couldn’t finish the setup process.

Great job Sonos!

Add me to the list of same issue. And add that the seller said he has 3 of these and had no issue in place of providing a solution or replacement.

for now feeling like I have been mugged for some cheap speaker.

Userlevel 2
Badge

@Sgoel85 I think we all feel mugged over here but it helps to see that its a bigger problem. Sonos support was a shocking eye opener for me,  no phone support Sat and Sunday and seems like the narrative is to always get you off the phone and blame your internet provider. I have hopes for their future app upgrade but i am not sure how long it will take.. Are they monitoring these discussions? Are they finally accepting its them and not everyones internet provider? Usually the saying you get what you pay for is true but in this case this was the opposite...

Userlevel 2
Badge

Just spoke to Sonos online chat and apparently mine is a special case and they’ve never come across my issue before. He also said it has nothing to do with the new app…it’s my internet. No matter what I try, when I click add new device it says ‘ getting Sonos five ready ‘ then keeps saying connection was lost or there was an error. They try to put me on some kind of temp network that fails. 
 

The only advice I got from online chat was that I need to call support tomorrow. I’m on the verge of taking it back for a refund and looking for an alternative speaker. 

I have the exact same problem. So, from what I gather, I need to buy and android phone and install older software to get them working? 

Userlevel 2
Badge

I’ve tried an android on the older app but it just kept saying I need to update the app to add new device. Only android I have is an Amazon fire 

Having the same issues. Cannot setup Roams SL with latest version of the app. Tried from Android and iOS on multiple 2.4ghz networks.

Userlevel 1

I have the exact same problem to connect the newly purchased Roam. I was in IT for 30 years and tried every possible way to resolve the issue, but all failed.

Chatted with Sonos support as well, but they don’t even know what they are talking about, so utterly useless.

I am currently practicing a law in Australia and if I don’t see any resolution from Sonos sooner or later, I am ready to file the formal complaints regarding their negligence in duty of care to the responsible authorities.

Very disappointed.

Userlevel 1

Have same issue chat bot kept repeating same sequence which wasn’t helpful. Live agent after 4 hour wait blames internet. Have a brand new modem and a brand new MOVE none of my other devices have problem with new modem only new Sonos. BTW Sonos I AM the owner of the account. App has major bugs

Userlevel 2
Badge

I’ve just spent over 3 hours on the phone to Sonos support. They still couldn’t fix it, this is my first ever Sonos product and I’ve had the speaker a week and can’t use it. Laughable really. No matter what I do, when I go into the Sonos app, find the device and click add, it just says getting Sonos five ready and then fails. I think I’m just going to send it back and wash my hands with Sonos. 

Got a new Roam SL today, same issue. Setup fails with “there was a problem during setup” and “having trouble finalizing connection” messages. Tried to restart mobile device, update app, restart router, restart speaker. Looks like the app was updated 2d ago but the issue still exists.

Userlevel 2
Badge

I’ve just realised that on my iPhone if I go to wifi in settings, my Sonos five shows up and gives me the option to connect it to my wifi and does successfully!? However it then says you need the correct app to set up the speaker. As soon as I go into the Sonos app the set up is still stuck on ‘ getting your Sonos five ready’… So does this show it’s an app fault? 

Userlevel 1

Trying to set up a brand new port and also experiencing the same exact issues. Went through the same 15 steps. 
 

Also tried both WiFi and Ethernet. Even tried a different account and setting it up as a brand new system. 
 

Not even worth a call to Sonos support as I have an enterprise grade UniFi network set up that is rock solid for everything else I run. I’ve worked in IT for 10 years and this is abysmal. 

I am experiencing the same issue in Korea. I purchased the IKEA SYMFONISK series but am unable to connect it using any method.

I have tried using the audio PIN, the PIN on the back, and even connecting via an Ethernet cable, but nothing works. Suspecting an issue with the speakers themselves, I attempted to connect three different SYMFONISK speakers, but none worked.

I also considered that the issue might be with the switches, so I tried two different Korean switches, but they too failed to connect.

Thinking it might be an issue with my mobile devices, I tried connecting with two Android phones, two iPhones, and an iPad, but none were successful. It seems to be an app issue;

the older version of the app doesn’t even allow connection without an update. I’ve heard news about a new app update, but it seems the problem occurred after updating the app.

Even after spending several hours on the phone with customer service, I didn’t receive much help. They have stated that they will escalate my inquiry.

This is my first time using a SONOS product, and it has provided the worst experience. Thank you, SONOS, for this experience. I wish you the best of luck in your future endeavors!

Userlevel 2
Badge +1

Same issue here with a brand new Sonos One.

I wish Sonos could just acknowledge the issue and give us some kind feedback that they are working on fixing the app.

Userlevel 2

Wish I had found this thread BEFORE wasting my hours trying to connect our new Sonos Roam SL. Definitely sounds like an app issue and frustrating that Sonos isn’t responding better. Imagine the HOURS customers would save if Sonos posted an announcement or at least updated their customer support teams about the issue so they could save everyone the frustration and not sending them in circles. I’m sure it’s futile, but the support page has an “email the ceo” address. So I sent a link to this thread along with some words of frustration. My guess is the interns who filter those messages will be just about as concerned about the issue as the customer support teams. Now to decide to return this speaker (more wasted time) or hope for a fix soon. Although now I’m just mad I’m invested in this system and want AAAALLLLL my money back. 

I have the same issue. Trying to add the ikea symfonisk to my other three Sonos products. Is there a way to change the WiFi that my new speaker is trying to connect to ( as it has linked to my guest WiFi account and my phone is on my main WiFi account) .Currently on hold with Sonos support. But sounds like I know why it has been 35 minutes and counting..

Userlevel 2

I have the same issue. Trying to add the ikea symfonisk to my other three Sonos products. Is there a way to change the WiFi that my new speaker is trying to connect to ( as it has linked to my guest WiFi account and my phone is on my main WiFi account) .Currently on hold with Sonos support. But sounds like I know why it has been 35 minutes and counting..

I was on hold for almost 30 mins. Got a chat agent. Exchanged pleasantries and my issue and sat and waited and waited….guess I was ghosted. 10 mins and no reply. I disconnected. My feeling, and my hope, is that they fix the app and all the other problems that went along with this update… Sooner than later

Userlevel 2
Badge

Well I am at a crossroads at the minute. I’ve purchased my speaker on finance and have a 30 day return period. I don’t know if I should wait a week or so to see if the app is fixed? Or just send the speaker back and be done with it. 

I have nothing useful to add to this discussion, but I am also having this exact problem with a new Roam SL.  The device on which I’m running the app and trying to do the setup is a Samsung Android phone.  It seems like the sequence of steps it prompts me to do is slightly different if the Roam is plugged in vs. unplugged.

Userlevel 2

Well I am at a crossroads at the minute. I’ve purchased my speaker on finance and have a 30 day return period. I don’t know if I should wait a week or so to see if the app is fixed? Or just send the speaker back and be done with it. 

Same dilemma. I didn’t finance but I think the return window is the same. I have my box ready and waiting. But will call customer service for a prepaid label. I’m not paying for return shipping because they can’t deliver on their product. 

Userlevel 2
Badge

I think its time we all email  ceo@sonos.com in addition to posting here, not sure who monitors that email but they need to know its not our ‘internet providers’ that are at fault

You should email investor relations if you want a reply. Probably ir@sonos.com

Reply