If you're experiencing audio delay issues, read this



Show first post

487 replies

Badge +2

I just installed my 5.1/Playbar on my LG OLED 65” and first thing I noticed was a lip sync issues with my cable box stations - especially live news.   In the past - I have also tested Martin Logan soundbars and also a wired Marantz receiver with a passive soundbar on the same TV.   I had no issues with the receiver except when I used optical (I briefly used optical to get the LG smartTV apps like Netflix) .  I tried to resolve and fiddled with the lip sync adjustments in the TV but could never get it right.

I don’t remember any sync issues with the Martin Logan Vision (optical input only) but it definitely had an audio dropout problem - the first two or three seconds was lost on new stations or music files.

I also don’t have any sync issues now when my source is other than the cable box.   Like Apple TV for instance.   I was going to test the optical from the cable box directly to the Playbar.

I also have a Sonos Beam on a bedroom LG LCD set and it is OK.

I have same issue with my Sony ~ it suddenly start few month ago (I belive) and it happens in the middle of seeing a movie or TV - it not right from the start. I then have restart TV and then it will be fine again …. is there a solution for this? 

Is this whilst you are playing a movie from the internal TV tuner, a built-in TV app, or is it from another source like a connected cable TV box etc? Without knowing the exact detail of what you are referring to, it’s rather difficult for anyone here to suggest a solution. If restarting the TV usually solves the matter, then it sounds like it might be your TV that is at fault here… I would perhaps just check with the manufacturers website and ensure the TV is using their latest software/firmware update.

I have same issue with my Sony ~ it suddenly start few month ago (I belive) and it happens in the middle of seeing a movie or TV - it not right from the start. I then have restart TV and then it will be fine again …. is there a solution for this? 

Voice sync delay issue  Sonos Playbar, Sun, 2 Play:1s, Sony Bravia TV and Xfinity cable  

I am having the same problem with a Playbar, Sub and 2 Play1s as many others. For months, A temporary fix for me has been to change the channel and then immediately come back to the channel I was watching. And it’s fixed for a little while. Then the delay returns. Thinking it was the cable box I called Xfinity and got a replacement cable box. That didn’t fix it. Then I played with the delay options in the Sonos settings. That didn’t work. So I disconnected the optical cable and went back to TV audio. Guess what?  No sync issues Sonos!  So I’m guessing that it’s the optical interface that’s the problem. I am really angry about this because a lot of people are experiencing it, not just me or us. I am referencing your case # 171023-002526 and will post my own on this  

Sonos, please help us. 

 

vinman61855,

To perhaps help confirm, (or maybe refute?), that it’s possibly your PlayBar at fault here, have you tested to see if there are any audio-delay/lip-sync issues, when you bypass the Sony TV completely and use an audio extractor/splitter instead? It would be well worth exploring that option, I think, particularly, as I suspect the Sony Bravia TV may not support audio ‘pass-through’ on its HDMI/optical ports, like you see nowadays on some of the recent LG TV’s.

Here are three ‘randomly’ chosen examples of splitter/extractors that other users have posted in the community here in the past, which some have used to test with their TV and found that such a device has 'often' resolved their lip-sync issues with a Sonos HT product, where it proved to be their TV’s processors ability at fault and unable to 'process' the surround audio signal quickly enough through the TV’s HDMI/Optical port’s:

  1. https://www.amazon.com/NewBEP-Switcher-Selector-Extractor-Splitter/dp/B07438WJ8G/ref=sr_1_7
  2. https://www.amazon.com/AV-Access-Extractor-Splitter-Amplifier/dp/B07D9BNVM1/ref=sr_1_21_sspa
  3. https://www.amazon.com/Extractor-Koopman-Optical-Converter-Supports/dp/B082KW5MXS/ref=asc_df_B082KW5MXS

….and just to add that playing PCM audio to the stereo 'only' internal TV speakers is a different thing entirely to asking the TV to process surround sound audio and pass it out through its optical port to a ‘5.1 audio Receiver'. That’s a bit like comparing Apples to Pears.

 

Userlevel 1

Voice sync delay issue  Sonos Playbar, Sub, 2 Play:1s, Sony Bravia TV and Xfinity cable  

I am having the same problem with a Playbar, Sub and 2 Play1s as many others. For months, A temporary fix for me has been to change the channel and then immediately come back to the channel I was watching. And it’s fixed for a little while. Then the delay returns. Thinking it was the cable box I called Xfinity and got a replacement cable box. That didn’t fix it. Then I played with the delay options in the Sonos settings. That didn’t work. So I disconnected the optical cable and went back to TV audio. Guess what?  No sync issues Sonos!  So I’m guessing that it’s the optical interface that’s the problem. I am really angry about this because a lot of people are experiencing it, not just me or us. I am referencing your case # 171023-002526 and will post my own on this  

Sonos, please help us. 
 

 

Thank you so much for all of your help. I have a switch here at home I am going to try first prior to making a purchase to see if that helps solve the problem. Thank you all that responded and answered my questions. Stay safe out there! 

Ok so I connected everything to the hdmi switch. Ran the optical cable from the switch to the play at and one hdmi to the television since the switch has all other cables running into it and I still have a bit of a delay. Do I need to turn off any audio processing on the tv or is that now pointless? 

It is rare to still have lip-sync delays when using a switch/extractor, I’m wondering if it’s one of the interconnecting cables that is causing the issue here and if you are able to perhaps swap them for another?.. most unusual. 🤔

Do you have another source you can test with other than the firestick? I don’t have much experience with one, and would prefer a more traditional device such as a DVD player.

Have you checked the audio settings on the Firestick? For instance, a quick google search brought up this:

To make sure the audio settings on your FireTV stick are correct, go to the Home Screen (Pressing the Home button on the Remote), enter into Settings, select the Dolby Digital Output option and make sure that Dolby Digital Plus is set to off.

Having Dolby Digital Plus turned off would be important. 

Badge

That would be pointless, the sound is not being processed by the TV, it is being extracted by the switch and sent to the PLAYBAR before it reaches the TV.

You’re the first person who has reported that there is still a delay in this setup, can I ask what source you’re watching? Not what program, specifically, but what device is generating the signal  being sent to the switch? Can you supply a link to which switch you’re using? Can you also confirm that the audio settings on this device, actually every device you have connected to the switch, is set to Dolby Digital only, and not any other codec?

I am using a firestick. The switch I’m using was purchased on monoprice. 
 

https://www.monoprice.com/product?p_id=15375

That would be pointless, the sound is not being processed by the TV, it is being extracted by the switch and sent to the PLAYBAR before it reaches the TV.

You’re the first person who has reported that there is still a delay in this setup, can I ask what source you’re watching? Not what program, specifically, but what device is generating the signal  being sent to the switch? Can you supply a link to which switch you’re using? Can you also confirm that the audio settings on this device, actually every device you have connected to the switch, is set to Dolby Digital only, and not any other codec?

Badge

No, sorry, I don’t have any personal experience with them. My Vizio doesn’t mess with the pass through signal. Just search on Amazon, there are dozens, you can choose based on which features you want, and once you know which brand/model you want, you can get it anywhere that has it. Amazon is a great place to do research, but sometimes not necessarily the place to purchase.

Which connection on the TV would depend on whether you’re using apps on the TV, and a switch that accepts an ARC signal to send out through the optical signal. But if you’re not, the an HDMI video signal is the same across all inputs. 

Thank you so much for all of your help. I have a switch here at home I am going to try first prior to making a purchase to see if that helps solve the problem. Thank you all that responded and answered my questions. Stay safe out there! 

Ok so I connected everything to the hdmi switch. Ran the optical cable from the switch to the play at and one hdmi to the television since the switch has all other cables running into it and I still have a bit of a delay. Do I need to turn off any audio processing on the tv or is that now pointless? 

Badge

No, sorry, I don’t have any personal experience with them. My Vizio doesn’t mess with the pass through signal. Just search on Amazon, there are dozens, you can choose based on which features you want, and once you know which brand/model you want, you can get it anywhere that has it. Amazon is a great place to do research, but sometimes not necessarily the place to purchase.

Which connection on the TV would depend on whether you’re using apps on the TV, and a switch that accepts an ARC signal to send out through the optical signal. But if you’re not, the an HDMI video signal is the same across all inputs. 

Thank you so much for all of your help. I have a switch here at home I am going to try first prior to making a purchase to see if that helps solve the problem. Thank you all that responded and answered my questions. Stay safe out there! 

No, sorry, I don’t have any personal experience with them. My Vizio doesn’t mess with the pass through signal. Just search on Amazon, there are dozens, you can choose based on which features you want, and once you know which brand/model you want, you can get it anywhere that has it. Amazon is a great place to do research, but sometimes not necessarily the place to purchase.

Which connection on the TV would depend on whether you’re using apps on the TV, and a switch that accepts an ARC signal to send out through the optical signal. But if you’re not, the an HDMI video signal is the same across all inputs. 

Badge

A switch, with an optical output, certainly would remove the delay that is being caused by the TV’s internal electronics. 

Also, when connecting the siwtch is it best to connect it to the EARC HDMI input?

Badge

A switch, with an optical output, certainly would remove the delay that is being caused by the TV’s internal electronics. 

Is there any you could recommend? I contacted monoprice but they dont have one that supports 4k signals. 

A switch, with an optical output, certainly would remove the delay that is being caused by the TV’s internal electronics. 

Badge

Yeah I’m using the Playbar via optical and I’ve tried everything. I don’t want to downgrade the audio to pcm because it nullifies spending this much money to have only stereo output. So maybe a switch with optical as well? 

In that case, assuming your Firestick is outputting DD 5.1 and not DD+ try to discover if your TV has ‘pass-through’ on its ports .. so that the Sony TV does not check, or try to transcode, the audio steam from your Firestick Apps. I use the Firestick 4K too with the LG C9 OLED TV and I can say that device is working okay here, albeit I’m using the Sonos Beam over HDMI-ARC, and the TV ports are set to pass-through. 

You may find a pass-through option in your TV Settings too, or by speaking to Sony Support, but if they don’t support that feature on your TV and it’s in-built processor is not quick enough to handle the Firestick surround audio, then you may have to look at by-passing the Sony TV altogether, with an audio splitter/extractor, like the examples shown in the links below…

Badge

I am having a nightmare of time trying to get this issue straightened out. I recently purchased a new Sony Master Series XBR TV and I used it for the first time last night attempting to watch Frozen 2 with my daughter. The audio delay was atrocious. Mind you, I have multiple Playbars set up around my home and this has never been an issue so I was quite surprised when I had this happened to me last night. Any help any of you could provide to get this straightened out would be greatly appreciated. 

The Sonos HT device and its surrounds will only play the audio asap, when the TV has sent it to that receiver… so my suggestion would be to look at perhaps why the TV might be delaying the audio output through its port.

Perhaps switch off any TV audio enhancement features, check the interconnecting cable and ensure the TV firmware is running on the latest version. I’m assuming you are using a Sony TV in-built App for movie playback, rather than a connected peripheral, like a cable box or entertainment device, (Apple TV, Roku or Firestick etc.) If you cannot solve the matter it may pay to speak to Sony Support to see if they can suggest a way to deliver the audio output in a more timely manner.

Hope that assists.

I am not using the built in Apps as I have a lot of programming on my firestick.

I am having a nightmare of time trying to get this issue straightened out. I recently purchased a new Sony Master Series XBR TV and I used it for the first time last night attempting to watch Frozen 2 with my daughter. The audio delay was atrocious. Mind you, I have multiple Playbars set up around my home and this has never been an issue so I was quite surprised when I had this happened to me last night. Any help any of you could provide to get this straightened out would be greatly appreciated. 

The Sonos HT device and its surrounds will only play the audio asap, when the TV has sent it to that receiver… so my suggestion would be to look at perhaps why the TV might be delaying the audio output through its port.

Perhaps switch off any TV audio enhancement features, check the interconnecting cable and ensure the TV firmware is running on the latest version. I’m assuming you are using a Sony TV in-built App for movie playback, rather than a connected peripheral, like a cable box or entertainment device, (Apple TV, Roku or Firestick etc.) If you cannot solve the matter it may pay to speak to Sony Support to see if they can suggest a way to deliver the audio output in a more timely manner.

Hope that assists.

Badge

While I agree with your irritation, this isn’t something that Sonos can be involved in. As has been repeatedly shown by people who “spend extra money”, as you’ve accurately put it, the Sonos works properly. The issue is in the ability for LG (and Samsung) to not delay the signal as it goes through the TV.

I replaced a TV recently, and looked at both LG and Samsung as potentials. I ended up with another Vizio, because I was confident it could pass through a Dolby Digital signal without delaying it. And I was correct, my Sonos continues to work perfectly, as it had on my previous Vizio. 

I see that you a prolific poster here with this specific issue and I wanted to reach out to directly to see if you had any input in regards to my situation. 

 

I am having a nightmare of time trying to get this issue straightened out. I recently purchased a new Sony Master Series XBR TV and I used it for the first time last night attempting to watch Frozen 2 with my daughter. The audio delay was atrocious. Mind you, I have multiple Playbars set up around my home and this has never been an issue so I was quite surprised when I had this happened to me last night. Any help you could provide to get this straightened out would be greatly appreciated. 

Badge

I am having a nightmare of time trying to get this issue straightened out. I recently purchased a new Sony Master Series XBR TV and I used it for the first time last night attempting to watch Frozen 2 with my daughter. The audio delay was atrocious. Mind you, I have multiple Playbars set up around my home and this has never been an issue so I was quite surprised when I had this happened to me last night. Any help any of you could provide to get this straightened out would be greatly appreciated. 

I have a Sonos beam and two play 1s connected to 75" sony Bravia x950g via HDMI arc. I found that the tv video was ahead of the sound when playing through Sonos system if I was watching TV with a charter spectrum box. I had the sound delay sensibly set to zero on the Sonos app. However, when I streamed content through the tv via the Netflix or Amazon video apps, the sound synced up just fine. 

I just now seemingly fixed the sound lag when watching cable TV by setting the 'A/V sync' to ON under the TV's audio output settings. When I had the A/V sync set to AUTO, it seemed to sync up sometimes. When I had it OFF, the sound lagged quite a bit. I hope this fixes the cable tv sound lag permanently and doesn't lag again for whatever reason.

Maybe this is a new setting on the Sony TV to fix this issue. I don't think I really changed any of the other sound settings when I first set up the tv months ago. It would be nice to get some guidance on the other Sony TV sound settings to optimize the Sonos experience. There are only a handful of settings that most folks are probably curious about regardless the brand of TV.

For what it’s worth - I was very nervous about purchasing a new LG OLED display since I own a Sonos Playbar system (based on the problems some of you are experiencing) - but I did go ahead with the purchase - and I have no audio delay issues with my LG C9 at all. It’s perfectly in sync (and I am a professional film editor - I cannot stand even the slightest sync delay).

This is my (admittedly) very simple and straight-forward setup - as I only use the LG C9 as a (stunningly brilliant) monitor for my Apple TV 4K. I do not use any of its internal smart features. No cable TV box or other external connections.

LG C9 55” (2019) - I was told it has the fasted internal processor (maybe that plays a role since the LG needs to pass on the audio to the Sonos universe), latest Apple TV 4K. PLAYBAR, SUB, BOOST, 2 Play:3’s (surround).

The Apple TV 4K is connected to the LG using its DOLBY VISION option, which also seems to automatically (and magically) configure some settings of the LG through the port it’s connected to. The Playbar is connected via optical audio cable to the C9.

When I set up my new system, I got all new cables (including a new high-end Optical audio cable).

I don’t know what did the trick here, but I was ready to use a (4K capable) external HDMI/optical audio switcher to fix any audio delay problems. Luckily I didn’t have to, as this is a much more elegant and simple solution (when it works).

Just came to put my own hat in the ring, 2018 LG TV with PS4 pro and Sonos surround system, exact same issue. I won’t be reading the entire 17 page thread but if they’re not going to properly fix the issue I’d even appreciate finer tuned audio delay settings...

Your rather lucky, if your talking about lip-sync issues here, I think LG TV’s can easily resolve such issues with this lip-sync feature available on their newer TV’s…

https://www.lg.com/ca_en/support/product-help/CT20098005-1412236386115-audio-out-of-sync

 

Some of their models also support HDMI/Optical port pass-through too in the TV Settings

…. and that’s without waiting for Sonos to fix anything at all here.👍

 

Badge

Just came to put my own hat in the ring, 2018 LG TV with PS4 pro and Sonos surround system, exact same issue. I won’t be reading the entire 17 page thread but if they’re not going to properly fix the issue I’d even appreciate finer tuned audio delay settings...

Reply