Answered

Beam: Keeps switching back to Arc from Bluetooth - how to stop?



Show first post

150 replies

@RBM1505 
As Danny mentions, whatever system you go with next, ensure it doesn’t use HDMI-ARC/eARC with CEC as you’ll certainly just end up with the same issue.

I also agree that powering off the Arc is not the answer - but I would certainly get in touch with the TV Support desk to make them aware that CEC is auto-enabling itself on the TV as ‘that’ is clearly a TV fault with the TV firmware.

I use an LG C9 TV and to switch from the HDMI-ARC/eARC output  to use Bluetooth output, I just toggle off ‘CEC’ (calked ‘Simplink’ on an LG TV) and it automatically disables auto-power-sync (used to power devices on/off) and clearly in the case of your TV that is not working as it should be. I would certainly make the TV manufacturer aware that has caused you an issue here and that it may arise in the future too if you have other CEC enable devices connected to the TV that ‘may’ go onto occasionally steal the output port focus when listening to the audio over a Bluetooth connected headset.

If you disable CEC on the TV - it should stay disabled.

Do you have eARC enabled? 

I have an LG C1. I can get CEC to remain off, I just have to turn off eARC in audio settings first. 

From looking around this doesn’t seem to be an issue with the q950a for example, nor the Bose systems. I will find out soon enough once this return is processed. 

@RBM1505 
As Danny mentions, whatever system you go with next, ensure it doesn’t use HDMI-ARC/eARC with CEC as you’ll certainly just end up with the same issue.

I also agree that powering off the Arc is not the answer - but I would certainly get in touch with the TV Support desk to make them aware that CEC is auto-enabling itself on the TV as ‘that’ is clearly a TV fault with the TV firmware.

I use an LG C9 TV and to switch from the HDMI-ARC/eARC output  to use Bluetooth output, I just toggle off ‘CEC’ (calked ‘Simplink’ on an LG TV) and it automatically disables auto-power-sync (used to power devices on/off) and clearly in the case of your TV that is not working as it should be. I would certainly make the TV manufacturer aware that has caused you an issue here and that it may arise in the future too if you have other CEC enable devices connected to the TV that ‘may’ go onto occasionally steal the output port focus when listening to the audio over a Bluetooth connected headset.

If you disable CEC on the TV - it should stay disabled.

Just bought an arc/sub/ones as a full surround setup for over 2k. 

I use Bluetooth headphones at night when my other half has gone to bed. My other half uses the headphones when I work nights. I cannot just simply turn off CEC as it auto-enables. I would need to change multiple settings, every night & teach my other half to do the same. It also increases the chances of the sound coming out of the wrong device which would accidently wake the other person up. I cannot run through optical as I lose Atmos. This is a non-negotiable use case. I went with Sonos because it’s just supposed to work. 

Attitude from Sonos CS on this issue is very poor. They’re being returned, fortunately within 100 days so the only person losing money is them. There is a lot of competition in the wireless surround market and I will just go with a competitor. The sound is great but nothing special at this price point, what appealed is they were just supposed to work. Janky work arounds like setting up a smart plug are not acceptable on this system. 

 

Make sure that whatever system you go with, you aren’t utilizing HDMI-ARC/eARC technology (which will include CEC).  It needs to be something where your sources connect to the audio system first, and your audio system connects to the TV.

And I agree that setting up a smart plug, while might be ok for some, it’s really an ideal solution.  For one thing, Sonos products are designed to be always on.  While the occasional reboot is fine, it’s not good for the life of the speaker. You don’t really want to cut power and reboot every time you switch between headphones and speakers.

Just bought an arc/sub/ones as a full surround setup for over 2k. 

I use Bluetooth headphones at night when my other half has gone to bed. My other half uses the headphones when I work nights. I cannot just simply turn off CEC as it auto-enables. I would need to change multiple settings, every night & teach my other half to do the same. It also increases the chances of the sound coming out of the wrong device which would accidentally wake the other person. I cannot run through optical as I lose Atmos. This is a non-negotiable use case. I went with Sonos because it’s just supposed to work. 

Attitude from Sonos CS on this issue is very poor - advice to use optical shows fundamentally poor understanding of their products & end users. They’re being returned, fortunately within 100 days so the only person losing money is them. There is a lot of competition in the wireless surround market and I will just go with a competitor. The sound is great but nothing special at this price point, what appealed is they were just supposed to work. Janky work arounds like setting up a smart plug are not acceptable on this system. 

Badge +1

Thanks for all the replies. 

Seems like CEC needs to an update to read what audio output the TV is set to. Something LG / Sonos and whoever oversees the CEC protocol need to work together on. It’s supposed to be a “smart” solution, so its understandable why users don’t like the way it works in its current form.

Before EArc/ Soundbars / Sonos etc, most enthusiasts had their home theatre systems running through AV receivers, which although bulky allowed the user to easily switch inputs to pick and choose what goes through the speakers. Intuitively, it seems like the newer systems should work in a familiar way.

Anyway - solved the problem by plugging the Sonos beam into one of these -
https://www.bunnings.com.au/arlec-white-grid-connect-smart-plug-in-socket-with-energy-meter_p0273367

We just use Google home to cut the power to the Sonos Beam if we want to force it to use the TV speakers or the TVs bluetooth audio output.

The CEC protocol, last time I reviewed it, allowed a single speaker ‘sink’ associated with it. This is why turning off CEC allows you to switch to different speakers.

For those not familiar, CEC is a common standard used across the industry. I don’t know, offhand, if Sonos was part of the consortium of companies that designed and agreed on the standard. Sonos just implements it as designed on their Home Theater devices. 

Yeah I got this. Strange that it's been going on for so many years, and even stranger that some soundbars don't suffer from it. I wonder how other companies do it…

What bothers me much more is the loss of sound when switching source on my Samsung tv. My sister wants to remove the beam cause every time she wants to watch Netflix there's no sound unless she plays around with the settings and gets lucky...

Are you referring to Soundbars that do not use the HDMI-CEC protocol standard for controlling the volume using the TV’s native remote, whether that remote works over RF/Infrared/Bluetooth? Only I’ve not yet come across an audio receiver with those features that do not have this same issue.

I would rather use the native TV ‘remote’ for volume control rather than a separate ‘remote’ for controlling the Soundbar audio. It would be difficult to do that, If your ‘remote’ did not use infrared, without having CEC control enabled on the TV.

I have the LG C9 OLED - all you need do there is switch off Simplink in the TV settings. I assume the same with Samsung, just switch off AnyNet+.

I believe these things are for the TV manufacturers to resolve as HDMI-CEC will stop the "output switching" once any ARC/eARC Receiver is connected. I don’t believe this is a Sonos issue.

Will switching Simplink off prevent me from using the soundbar until simplink is re-enabled? If so then it isn't a solution, and this is what the other posters here describe, from what I manage to gather.

Yes, but this is something that the TV manufacturers need to resolve with the CEC protocol - the solution by the TV manufacturers at the moment is for you to use the TV optical port instead for the audio out, rather than the HDMI audio return channel.. If Sonos fixed this, you would likely see a solution that means toggling off/on CEC control by having to go into the Sonos App settings - so you may aswell just toggle off Simplink/AnyNet+ instead, as that option is easier and it already exists, so it’s best to leave things as they are, or get the TV manufacturers to sort this... easiest thing would be to toggle off CEC with a button press on the TV remote, perhaps🤔?

Yeah I got this. Strange that it's been going on for so many years, and even stranger that some soundbars don't suffer from it. I wonder how other companies do it…

What bothers me much more is the loss of sound when switching source on my Samsung tv. My sister wants to remove the beam cause every time she wants to watch Netflix there's no sound unless she plays around with the settings and gets lucky...

I have the LG C9 OLED - all you need do there is switch off Simplink in the TV settings. I assume the same with Samsung, just switch off AnyNet+.

I believe these things are for the TV manufacturers to resolve as HDMI-CEC will stop the "output switching" once any ARC/eARC Receiver is connected. I don’t believe this is a Sonos issue.

Will switching Simplink off prevent me from using the soundbar until simplink is re-enabled? If so then it isn't a solution, and this is what the other posters here describe, from what I manage to gather.

Yes, but this is something that the TV manufacturers need to resolve with the CEC protocol - the solution by the TV manufacturers at the moment is for you to use the TV optical port instead for the audio out, rather than the HDMI audio return channel.. If Sonos fixed this, you would likely see a solution that means toggling off/on CEC control by having to go into the Sonos App settings - so you may aswell just toggle off Simplink/AnyNet+ instead, as that option is easier and it already exists, so it’s best to leave things as they are, or get the TV manufacturers to sort this... easiest thing would be to toggle off CEC with a button press on the TV remote, perhaps🤔?

Same issue with the LG C9 and a Samsung QLED.

With the Samsung it's even worse since very often when switching source (from cable TV to PS4 to some TV app like Netflix) the sound is completely lost, and I either have to change output to TV speakers (which jumps back immediately to the beam gen 2 and sometimes fixes it), or completely turn off and on the TV and sometimes this also works.

Extremely random and very disappointing for such a premium product.

It's unacceptable that I have to play around with the output settings every time I switch source because the Sonos beam goes silent on certain sources randomly.

I have the LG C9 OLED - all you need do there is switch off Simplink in the TV settings. I assume the same with Samsung, just switch off AnyNet+.

I believe these things are for the TV manufacturers to resolve as HDMI-CEC will stop the "output switching" once any ARC/eARC Receiver is connected. I don’t believe this is a Sonos issue.

Will switching Simplink off prevent me from using the soundbar until simplink is re-enabled? If so then it isn't a solution, and this is what the other posters here describe, from what I manage to gather.

Because people have reported not experiencing the same issues with non-Sonos products, i.e. Bose soundbars.

 

So what?  People have reported it working fine with other brands of TV's too.  That tells us nothing.

What do you mean by “so what”? If other brands work fine with the same TV then clearly this product has a problem working with this TV. And since we're talking about a very wide range of problematic TVs (LG and Samsung being popular as they are) then this is clearly an issue that needs to be resolved. And the fact that other manufacturers have solved it shows that it CAN be solved by the soundbar manufacturer, or else none would function properly...

Because people have reported not experiencing the same issues with non-Sonos products, i.e. Bose soundbars.

 

So what?  People have reported it working fine with other brands of TV's too.  That tells us nothing.

Same issue with the LG C9 and a Samsung QLED.

With the Samsung it's even worse since very often when switching source (from cable TV to PS4 to some TV app like Netflix) the sound is completely lost, and I either have to change output to TV speakers (which jumps back immediately to the beam gen 2 and sometimes fixes it), or completely turn off and on the TV and sometimes this also works.

Extremely random and very disappointing for such a premium product.

It's unacceptable that I have to play around with the output settings every time I switch source because the Sonos beam goes silent on certain sources randomly.

I have the LG C9 OLED - all you need do there is switch off Simplink in the TV settings. I assume the same with Samsung, just switch off AnyNet+.

I believe these things are for the TV manufacturers to resolve as HDMI-CEC will stop the "output switching" once any ARC/eARC Receiver is connected. I don’t believe this is a Sonos issue.

Same issue - brand new Sonos Beam gen2 with 2 play:1 surrounds plugged into eArc on a 55” LG C1. Can’t seem to watch TV using the internal TV speaker, as it switches back to eArc audio after 2 seconds or so. 

Guess we keep bugging Sonos for a fix… 

 

Every poster in this thread has listed the TV settings menu as being the source of the problem.  What in the wide world of sports makes you think the settings in the TV menu are something Sonos can fix? 

Because people have reported not experiencing the same issues with non-Sonos products, i.e. Bose soundbars.

Same issue with the LG C9 and a Samsung QLED.

With the Samsung it's even worse since very often when switching source (from cable TV to PS4 to some TV app like Netflix) the sound is completely lost, and I either have to change output to TV speakers (which jumps back immediately to the beam gen 2 and sometimes fixes it), or completely turn off and on the TV and sometimes this also works.

Extremely random and very disappointing for such a premium product.

It's unacceptable that I have to play around with the output settings every time I switch source because the Sonos beam goes silent on certain sources randomly.

Same issue - brand new Sonos Beam gen2 with 2 play:1 surrounds plugged into eArc on a 55” LG C1. Can’t seem to watch TV using the internal TV speaker, as it switches back to eArc audio after 2 seconds or so. 

Guess we keep bugging Sonos for a fix… 

 

Every poster in this thread has listed the TV settings menu as being the source of the problem.  What in the wide world of sports makes you think the settings in the TV menu are something Sonos can fix? 

Badge +1

Same issue - brand new Sonos Beam gen2 with 2 play:1 surrounds plugged into eArc on a 55” LG C1. Can’t seem to watch TV using the internal TV speaker, as it switches back to eArc audio after 2 seconds or so. 

Guess we keep bugging Sonos for a fix… 

Amazed this is still an issue! 

 

Does anyone know if beam v2 is the same, if so I won't even bother looking at upgrading. 

Hi all, 

I bought a pair of Sony xm4 headphones yesterday and suffered the same issue, which had me thinking overnight. 

I think I have sussed out a work around to stop whichever Sonos sound bar cutting in, after a couple of seconds of Bluetooth headphone sound. Forgive me if this is elsewhere on the forum and I am repeating something that has long since been known. I just haven't read all of the stuff that's been posted but clearly from what I have read, it has remained an issue for some, as until this morning it was for me. 

Firstly, I own a ‘18 LG 65 wallpaper TV with which I found that switching off the Simplink hdmi cec toggle in All settings/general, then selecting Bluetooth device in the usual way the headset should connect and remain so. To revert to the soundbar turn Simplink back on. 

However and secondly, this did not work with my ‘21 LG 77 C1 set. I remembered from the initial TV set up, that there was a eArc toggle buried in settings and this turned out to be the key. 

Therefore;

All settings (3 vertical dots)/General/devices/hdmi setting, then toggle Simplink HDMI CEC to off. Then still in All Settings go to Sound/Advanced, scroll down to eArc and toggle off. 

Come out of ‘all settings’ then change sound source to Bluetooth and connect device in normal way. When you want to revert, first turn Simplink back on  and then toggle eArc to 'on’ (it won't work the other way around because eArc is greyed out. 
 

This is far from ideal and still requires some fannying about with settings but at least it's better than physically disconnecting power or hdmi cables which in my case and no doubt many, can be very awkward and in any case, I understand that  hdmi is not supposed to be routinely plugged in and out.
 

I haven't lived with doing this yet and it maybe that Simplink turns itself back on when the TV is turned on and off (the eArc will not btw) but hope this helps someone out. 

 

 

 

Following, same issue with LG C1 and Sonos ARC.  Wish I had known before the Sonos purchase. I would like some money back. We have some hearing issues here. I would like Atmos most of the time and would like my wife to be able to use bluetooth headphones when needed. 

 

I find even with eARC off and Simplink off if I accidentally touch the HDMI (ARC) sound out setting with the cursor it resets Bluetooth Device (Headphones) to ARC turning Simplink back on and hijacking the sound out to ARC. I can hardly scroll through the sound out settings, without Simplink and ARC turning back on. Anyways I just scroll carefully in the direction that avoids HDMI (ARC).  Pretty klugey. 

 

Kinda lazy of Sonos not to fix this, they sure worked hard enough on the rest of it.  If they were clever they’d launch their own bluetooth headphones that would integrate with their products and work, a line extension if you will to make a buck. 

Wow, just found this thread. I have the same issue with a sonos arc and an LG E9.

Very disappointed that Sonos didn’t fix the issue years after, that’s very poor for supposedly high end product.

You could just toggle ‘off’ ‘Simplink’ on the TV in your case - at least that’s all I have to do on my older C9. Then toggle it ‘on’ to restore connection to the HT on the HDMI-2 Arc/eARC port.

Wow, just found this thread. I have the same issue with a sonos arc and an LG E9.

Very disappointed that Sonos didn’t fix the issue years after, that’s very poor for supposedly high end product.

Seriously Sonos?  Are you guys STILL ***** the bed on this topic?  I mean you have THOUSANDS of people stating the same problem FOR YEARS! and you still haven’t fixed the issue?

 

Give us a freaking answer instead of telling us to unplug our equipment!  That is NOT a solution!

 

*Moderator Note: Modified in accordance with the Community Code of Conduct.*

Ok this is a weird twist for you guys:

I’ve been enjoying my LG GX + Sonos surround (arc sub ones) during the day and just connect my Bose QC35 at night with no problem. For. Months. 

 

Well, until tonight.

I'm glad I found this thread but I’m sad there’s no answer! Again, it’s been working fine, no cec thing stealing and no disabling that on the tv options…

 

All I know is that tonight, I tried connecting my BT headphones while my show was already playing. It was a Netflix show in Dolby atmos.

 

oh gosh I’m sad and tired. I love the Sonos surround, but jeez.


edit: ok so turning eARC on and off made the problem disappear :) I’m back enjoying sound in my Bose and the Sonos surround is on. hope it helps someone!

Badge

Think I understand the issue now. I was disabling HDMI Simplink, but I still had eARC enabled in the sound settings - it evidently re-activates it if eARC support is enabled.

With eARC disabled, Simplink stays off. 

 

Indeed this is right👍

Reply