Answered

Beam: Keeps switching back to ARC from Bluetooth - how to stop?


Userlevel 3
Badge +3
Hi. I have an LG C8 OLED TV and a Beam, connected Via HDMI Arc. I also have some Sony Bluetooth headphones. Whenever I try and play the TV audio via Bluetooth after 2 seconds it switches back to Arc. Is there anyway to prevent this? I have to pull the HDMI lead out of the Beam, but can it be disabled via the app or some other way? Thanks.
icon

Best answer by chucky999 12 August 2019, 04:10

View original

164 replies

Userlevel 1
I have the same problem as Badgercop. It seems that this is pretty common as shown by these similar threads in the sidebar to this thread. The best, though not optimal, solution seems to be to turn off the HDMI-CEC connection on your TV. It would be nice of SONOS would fix the APP to handle this situation. The problem is not solely with LG systems - both Samsung and Sony are referenced in the other threads.
Userlevel 1

Hi folks, thanks for reaching out with the Sonos Community! I understand that we all want to keep the Sonos Arc/Beam and headphones connected to our TV at the same time and that kind of behavior is based on your TV on how the HDMI connections work because you are connecting two output devices to your TV. As others suggested this is more and can be handled appropriately by the TV manufacturers. You can try optical for better options but it will still up to you on how to proceed. Just let us know if you need anything. We and the community are always here to help.

 

Hi, going through the post you can read that many folks have the problem only with Sonos Beam or Sonos Arc solutions. (This is the case for me as well, LG C9 + Sonos Arc). It works well with other HDMI-ARC connected audio devices (as mentioned in the posts several times).

 

So this clearly seems to be a problem in the Sonos system. Please do not throw the ball to the TV manufactures. I strongly doubt that Samsung, LG, Sony and others are to blame here.

 

Btw. this does have nothing todo with Bluetooth, it does not matter which output you choose on your TV (at least for me), the Sonos (HDMI connected) Soundbar will always take over after a second or so.

Userlevel 1

Note that this “bug” is the way that the HDMI-CEC spec, which includes HDMI-ARC, is written. Sonos doesn’t have the option of changing it. 

Completely disagree, every surround sound and other HDMI-CEC device people own manages to do what the OP is asking just fine.

People are experiencing this on lots of different manufacturers’ TVs across different models and are just trying to get the same functionality that they had before - It is 100% a Sonos issue.

Userlevel 1

Hi folks, thanks for reaching out with the Sonos Community! I understand that we all want to keep the Sonos Arc/Beam and headphones connected to our TV at the same time and that kind of behavior is based on your TV on how the HDMI connections work because you are connecting two output devices to your TV. As others suggested this is more and can be handled appropriately by the TV manufacturers. You can try optical for better options but it will still up to you on how to proceed. Just let us know if you need anything. We and the community are always here to help.

 

Hi, going through the post you can read that many folks have the problem only with Sonos Beam or Sonos Arc solutions. (This is the case for me as well, LG C9 + Sonos Arc). It works well with other HDMI-ARC connected audio devices (as mentioned in the posts several times).

 

So this clearly seems to be a problem in the Sonos system. Please do not throw the ball to the TV manufactures. I strongly doubt that Samsung, LG, Sony and others are to blame here.

 

Btw. this does have nothing todo with Bluetooth, it does not matter which output you choose on your TV (at least for me), the Sonos (HDMI connected) Soundbar will always take over after a second or so.

This is exactly what I wanted to write. HDMI ARC connection in my LG TV worked well with a JBL bar and Sony headphones in my case. 
Really Sonos? Is blaming the others the right way to solve the problems in your understanding? Disappointing...

Userlevel 1

It is unfortunate to see this hasn’t been corrected even in new products. I purchased a Sonos Arc to go with LG CX. Due to COVID my wife is currently working from home, in order not to disturb her, I was trying to use Bluetooth headphones, then tried wired headphones, arc keeps overriding my choice after a few seconds. May send it back, as while I can do the “fix” mentioned above, a current device shouldn’t be forcing me to turn off features of the tv just to work properly, especially since this an over a year old issue.

 

Edit: This isn’t an LG issue, I hooked up my older Bose sound bar and sound output selections work properly.

Userlevel 1

Same behavior. I can't use any other audio options other than the internal speakers. With Bluetooth I get a second of sound, then the ARC takes back the output. On my LG OLED I can't even turn off hdmi-cec as it turns it back on when I switch to the sound bar. 

 

All I want is to be able to use Bluetooth headphones at night.…

 

Sigh....

Userlevel 1

I just purchased a new Samsung TV today and a Sonos beam+sub and now have this issue when connecting my Bose Bluetooth headset. The HDMI-CEC workaround is not good/nice, so I really hope that Sonos can fix this issue somehow.

One other potential solution is to use an HD Fury Arcana, as that would bypass using the TVs eARC and CEC.  Arcana isn’t cheap though, and you would need an external source like a Shield.  So  I would understand if you just want to go with the Q950A for budget reason. 

It clearly sounds like an LG issue, but LG has little motivation to fix audio related issues on their TVs.  And your return period does matter.

It must surely be an LG issue, because it all works fine on their C9 OLED TV and it works on an older 2015 LG TV we have in our Home too. We just disable Simplink to use the other TV outputs, like Bluetooth.

There is one other solution I can think of …and that is to purchase a Sonos Port/Connect (gen2), add a Bluetooth transmitter to its line-out and group it with the HT room - I have the Port and can confirm it works okay too and is fine (for me) for lip-sync purposes (unless I just happen to be lucky in that regard)… I just quickly tested it with this cheap transmitter: 

https://www.amazon.co.uk/dp/B07J58KY3X

Userlevel 2

I did consider the Arcana but with the shield it would be nearly 25% of the system cost again for slight convenience. If there were no alternatives, I would settle for disabling eARC, CEC, using headphones & then changing it all back again rather than cover that additional cost. I just have a get out of jail free card given Sonos’ excellent returns period. I was happy to accept enabling/disabling CEC from the quick menu but any more than that is asking too much.

I’m not sure adding a port & grouping it would be an effective solution. It’s the same headset I use with my PC and it’s not unusual my other half is watching TV & I’ll be using my headphones through the PC. I’m not 100% sure but I imagine it will involve more messing about to swap to and fro.

For what it’s worth I’ve emailed LG support today to ask about it. I’ll update with their response. 

Realise this thread is a bit old but came across it when I was searching for an answer to the same issue I am having and can confirm that the brand new Sonos Arc also has the exact same problem. Using Sonos Arc with LG C9 connected via eARC with CEC enabled and am now not able to use any other audio outputs. After selecting any of them, it jumps back to ARC after a couple of seconds.
Hope its a bug that gets resolved as currently the implementation of CEC on this flagship Sonos soundbar is quite disappointing.

Userlevel 1

I have the same problem as Badgercop. It seems that this is pretty common as shown by these similar threads in the sidebar to this thread. The best, though not optimal, solution seems to be to turn off the HDMI-CEC connection on your TV. It would be nice of SONOS would fix the APP to handle this situation. The problem is not solely with LG systems - both Samsung and Sony are referenced in the other threads.

thank you!!  Found this through a Google search. I have an LG OLED B8 with the Beam and have the same problem! This is unfortunately a temporary and annoying work around.  My Bose 700 bluetooth headphones cost more than the Beam, can't Sonos step up to allow us to switch between them quickly?? I use them at night so i don't bother the wifey while enjoying some late night TV in our condo.

Can't Sonos fIx such a simple issue? I'm sure thousands of others have this issue.

Hi folks, thanks for reaching out with the Sonos Community! I understand that we all want to keep the Sonos Arc/Beam and headphones connected to our TV at the same time and that kind of behavior is based on your TV on how the HDMI connections work because you are connecting two output devices to your TV. As others suggested this is more and can be handled appropriately by the TV manufacturers. You can try optical for better options but it will still up to you on how to proceed. Just let us know if you need anything. We and the community are always here to help.


What an asinine and disrespectful reply from Sonos.

Yeah, just buy our soundbar/sub/surrounds then connect with optical "for better options" and lose Atmos capabilities.

Sure, great advice!

Same here. Sonos AMP hooked up with HDMI to Sony 9305. It is ridiculous Sonos not prioritizing this issue.

I have the same problem as Badgercop. It seems that this is pretty common as shown by these similar threads in the sidebar to this thread. The best, though not optimal, solution seems to be to turn off the HDMI-CEC connection on your TV. It would be nice of SONOS would fix the APP to handle this situation. The problem is not solely with LG systems - both Samsung and Sony are referenced in the other threads.

chucky999

You’re the man! This is in fact the fix for my LG65C8PUA. Annoying that I have to do this, but much better than unplugging the HDMI ARC as Badgercop was doing. Thanks for sharing - you’ve clearly researched the issue. 

 

Now me ☹️

Sonos Arc and LG OLED.

Userlevel 3
Badge +3
Well first... it's not switching from Bluetooth. The Beam is not a Bluetooth speaker, but I digress.



Chances are your TV or Cable box is still playing and the Beam is set to auto-play. So turn them off when listening to other audio, or check the Beam's room settings and disable auto-play.




Sorry you didn’t understand what I wrote.



I know the Beam isn’t a Bluetooth device, I didn’t say it was. I said I’m trying to play my TV audio via Bluetooth to my Bluetooth headphones. I can’t turn the TV off, because I’m using it with my Bluetooth headphones.



Perhaps I should just start again...



My TV is connected to the Beam via Arc. I’m trying to use my Bluetooth headphone with the TV (late at night, so I don’t disturb the household). When I go into the the TV’s menu and chose Bluetooth as the audio output it plays audio via the headphones for 2 seconds before it automatically switches back to the Beam. This is because the Beam is ‘always on’ (unlike other amps I have used).



What I am asking is - is there any other solution other then pulling the power or HDMI cable out of the Beam? (I know one solution is to change to optical, but I want to stick with Arc is possible).

Same issue here (some 2+ YEARS later) with Sonos Arc on Samsung Q80R’s ARC HDMI connection. Change sound output to Bluetooth device and the Sonos Arc steals the sound back in a few seconds, if not immediately. VERY frustrating.

Come on Sonos, you can do better than this. There are lots of your customers who need to listen to their TV audio from more than just the Sonos device connected via HDMI cable. This is a game changer for me and I’m heavily invested in the Sonos ecosystem, yet this gives me pause.

 

It’s not Sonos, it’s Samsung.  I have a Samsung TV which will do this all the time, whereas my Toshiba will stay on Bluetooth as long as I want it to. 

I am struggling to know if this is a Sonos or a TV problem ( I have an LG too which seems to be very common in this thread). 
 

until 3 days ago I could quite happily hear everything through the Sonos from the TV. I then noticed the tv switching from hdmi arc to internal speakers….. I would then flip it back to hdmi arc only to get no sound. I have had no sound on Hdmi arc now for a few days but unless I unplug the beam the tv auto selects arc and I get no sound. 
 

beam works fine for all normal streaming - question is whether what’s tripping the arc to auto flip is coming from the beam or the tv - and with no way to tell which it is how can you get support in this mixed environment.

 

fwiw I will factory reset my tv and my beam later today and not run any updates on either…see how it goes.. but this is busting my nut

My initial thoughts are that the ‘flipping/tripping’ is being caused neither by the Beam, nor the TV, but more likely by another HDMI device connected to the TV that has HDMI-CEC enabled and is attempting to ‘steal’ away the focus from your Beam.

To try to find the ‘culprit’, if you have more than one device connected with HDMI-CEC enabled, is  to disconnect these ‘other’ devices and first ensure the ‘flipping’ stops altogether. Next, add the devices back one at a time and see which one causes the issue. If that’s established, then disable CEC on that one device, or alternatively insert a cec-less adapter into its connection as shown in the link below. All being well, these things should solve your issue.

https://www.lindy.co.uk/cables-adapters-c1/audio-video-c107/hdmi-cec-less-adapter-female-to-male-p7299

I am amaized that 3+ years and sonos could not connect their own product to a tv and try to replicate this, to see the issue themselves? I had my same experience and i imagine others will continue to have it! All smart tv pwners will see how bad sonos products are due to this 1 bug! Unless they dont set up another audio output.

 

It’s not a Sonos bug, it’s a TV bug.  My Toshiba Fire TV works just fine switching from Sonos to headphones and back.  My Samsung requires me to turn off CEC, and other people report they can’t switch back and forth at all for other brands of TVs.  So if it works 3 different ways with 3 different TV’s, it isn’t Sonos causing the problem. 

I have noticed the same issue with an LG C9 and Sonos ARC. I have an old pair of Sony rf wireless headphones connected to the headphone jack. When I switch to the headphone option they work fine, but when I try to connect my new Bluetooth headphones the tv switches back to eARC after a couple of seconds. Really frustrating. Seems strange its just the Bluetooth connection that is is affected, but looks like I will be sticking with the old headphones. Its a shame Sonos cannot fix this as I never had the same issue with my old soundbar. 

Note that this “bug” is the way that the HDMI-CEC spec, which includes HDMI-ARC, is written. Sonos doesn’t have the option of changing it. 

Me too. Sonos needs to fix this.

Never had a problem CHOOSING the audio output that I wanted to use during a particular TV session (night=Airpods Pro; day=internal speaker) UNTIL I connected Sonos Arc via HDMI Arc port on LG OLED65C9. Now, when I CHOOSE AirPods Pro (connect via Bluetooth), the sound output switches to AirPods Pro for about two seconds, and then reverts to Sonos Arc via HDMI Arc port.  The same happens when I CHOOSE the LG’s internal speaker: the sound output switches to the LG’s internal speaker for about two seconds, and then reverts to Sonos Arc via HDMI Arc port.

Sonos Arc appears to be overriding my sound output selection. The wife is very aggravated (that I’m not using my AirPods Pro! The workaround (unplug the Sonos Arc or its HDMI cable) aggravates me!

Please fix!

Same issue - brand new Sonos Beam gen2 with 2 play:1 surrounds plugged into eArc on a 55” LG C1. Can’t seem to watch TV using the internal TV speaker, as it switches back to eArc audio after 2 seconds or so. 

Guess we keep bugging Sonos for a fix… 

 

Every poster in this thread has listed the TV settings menu as being the source of the problem.  What in the wide world of sports makes you think the settings in the TV menu are something Sonos can fix? 

My C1 will not allow me to manually switch off HDMI CEC so this does not work for me. If i unplug the Arc power lead, i need to reinstall it in the app when reconnected. However, unplugging the HDMI lead from the back of my Arc (which is eay to access in front of my tv) allows me to use ear buds, which auto connect as soon as i open the case. When movie time is over, i simply  plug the HDMI back in and the arc becomes the default sound output again. Annoying problem , simple workaround

@106rallye There’s no way/no setting that I can find (and I’ve looked VERY hard) to turn off SimpLink (a.k.a., HDMI-CEC) on the most recent firmware from LG (which is 05.00.03). 

In the WebOS/LG TV firmware 5.00.03 you need to goto ‘Settings/Connection/HDMI Device Settings” - Simplink ON/OFF is the second option in the list.

IMHO the issue here is with WebOS/LG I think, as it should prompt to switch off ‘simplink’ whenever a user selects ‘another’ audio-out option.

Reply