Sonos Connect can no longer play music after Synology SMB update

Userlevel 3
Badge +1

My Sonos Connect can no longer play any music following an update to the SMB package on my Synology drive.


I’ve followed the guides about setting up the appropriate SMB1 access allowing NTLM access, but when I try and connect, I just get “access denied” even though my S2 products are pointed at the same share.


The NAS logs show the S1 product connecting but the Sonos app is throwing the error.


Has anyone else experienced this and does anyone have a solution?


Best answer by DuncanF 30 April 2023, 10:59

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

96 replies

Badge +4

Not sure atm, but try this instead?

THANK YOU @sjw! This solution worked for me and enables use of latest SMB package. Yay!

Userlevel 2
Badge +1

@DuncanF, I noticed a typo in your fix.

It should be sudo -i (a space after sudo).  Could you edit original post?

Hope this helps others.

If someone can tell me how to edit a post I’ll happily update it! I must be missing the obvious …

I just noted that @sjw has a fix that will allow you to sitck with the most recent SMB pacakge, by tweaking `smb.conf`. If I can edit my post I’ll add a link to that, as that solution avoids the need to keep the SMB package on an older version.

Edit to add: so this seems to be an edit time window thing. I can edit this post, but not the ones I posted some days ago.

Userlevel 7
Badge +18

Hi @DuncanF 

Edit to add: so this seems to be an edit time window thing. I can edit this post, but not the ones I posted some days ago.

Correct - you get one hour to edit.

I have added the space for you.

Userlevel 3
Badge +1

Not sure atm, but try this instead?

Thanks, this works for me!

Hello Forum

The solution posted by DuncanF works fine, but it is unclear which version of "4.10.18-0548 dated 22-Dec-2022" should be used. 
I have tried the whole list, but keep getting the message that it is not suitable for this system.
Can anyone help me with this. 

My system is:
DSM 7.1.1-42962 Update 5
INTEL Pentium N3710

Thanks in advance

Userlevel 7
Badge +15

It should be the x86 option from here.

Or just change the smb.conf file and stay on the latest version.

Hello sjw,

Thank you for your quick response.
Indeed it works with the x86 option.

In the near future I will change the Sonos system to a more “flexible” product, without the SMB1 restrictions.

Have a nice day

Userlevel 7
Badge +22

No currently sold Sonos has any need for SMB v1, some of the older gear that has too little internal memory for the new Linux and SMB system still, and likely always will, have that need though.

I found this thread this morning after updating my DS918+ yesterday and not being able to use my Sonos (all S1) Connects. Fortunately I found a solution on Reddit, but I thought I’d paste here for others who have this issue.

The solution is simply to downgrade the Synology SMB package from 4.15.x (Apr-2023) to 4.10.x. I used the final version of 4.10 (4.10.18-0548 dated 22-Dec-2022). You can download individual packages from Synology’s archive here:

  • Login to your NAS using Putty or similar. Stop the SMB service and uninstall it. 
sudo -i
synopkg stop SMBService
synopkg uninstall SMBService
  • Logon to your NAS in a browser. Go to the Package Centre and click “Manual Install”. Select the package you downloaded and install it.
  • Finally go to the Control Panel and re-enable SMB (File Services → SMB). Don’t forget to double check that NTMLv1 is enabled (File Services → SMB → Advanced → Others).

This takes only a few minutes and, for me, it restored my Sonos capability. YMMV. Obviously make sure you have appropriate backups in place.


Moderator edit: added space to “sudo -i”


Great works perfectly, many thanks !

This is the 3rd or 4th time that I have to search a solution to make Synology and Sonos give the service that worked before upgrade, once again the problem is on Synology side, too bad !


i coulnd´t install the x86 file - error - this package isn't supported or compatible!?! any ideas - restarting the disk station doesn't help. DSM 7.1.1-42962 Update 5 

Badge +4


i coulnd´t install the x86 file - error - this package isn't supported or compatible!?! any ideas - restarting the disk station doesn't help. DSM 7.1.1-42962 Update 5 

Use @sjw solution, no need to downgrade SMB software, just a minor change to file. Worked great for me! See post a few up with link. 

Perfect solution, thanks a lot!

YES!!! Everything works! THANK YOU!!!

Userlevel 2

I raised a support ticket with Synology and after several emails with support here is their response to this issue:


After investigating the issue, we have found that the problem is caused by the default server response of Samba v.4.15 to a specific client command (SET_FS_INFO) sent by the Sonos S1 device. Synology has followed the specification from Samba and has not implemented a proprietary solution, meaning that any SMB server that uses open-source Samba version 4.15 may encounter this same issue.

By adding unix extensions=no as a default option in the Samba configuration file would make the NAS less secure and therefore is not a viable solution. We fully understand that updating to SONOS S2 is not financially viable for many users, and we apologise for any inconvenience caused. However, we would like to assure you that we take security very seriously, and therefore cannot sacrifice security for backward compatibility.


So it appears the only solution is either staying or downgrading to a previous version of SMB on Synology or modifying the SMBService config file as described previously.


YES!  You brilliant man, DuncanF!!  THANK YOU!!!

I have the same problem after upgrading the SMB package on my Synology NAS.

I will look at the fix described by DuncanF later (thanks!) , but in the meantime I got the unit playing by the following:

  • queue|play the tracks to a newer Sonos unit (I have the problem on one of the original Play:5 units)
  • then add the failing unit to the group (drop the volume on the original unit if you want)

That gets the music happening again.


Userlevel 3

Thanks for the downgrade hack, it worked. I did have to reboot in between stop and uninstall, could not uninstall without it. Let’s hope this will work with the latest OS update 7.2.

Userlevel 3

Is the SMB downgrade still working with 7.2 or did the latest Sonos app update solve the issue?

Hi Ivo,

this is just my opinion, but I don’t believe that Sonos have any intention of fixing this issue.

They have long claimed that the early Sonos units have insufficient memory to allow upgrade to the more secure version of the s/w component that is causing the connection problem.

I don’t know if this is factual, but anyway they have long since stopped upgrading their S1 controller. My guess is that the latest “upgrade” is just another downgrade, ie. it removes the capability to play local tracks, on an android device, to your Sonos units.

The connection “problem” has been with us for a long time. Previously the Sonos Apologists in this forum have said that it is not a real-world problem, and that it can be readily worked around. In the past I have asked for the recipe for that workaround, but I have not seen any response to that.

What has happened now is that Synology, unlike the Sonos S1 controller, have continued evolving their package. They have zero interest is leaving their units open to exploitation, and they have follow best practice to protect their reputation and their customers’ data.

I don’t to know enough to understand exactly how serious this problem is. You can research it yourself by searching  “smb1 vulnerability”. 

eg “Do NOT use SMBv1. SMB1 lacks encryption, is inefficient, and has been exploited in the wild by ransomware attacks.” from here

The Sonos S1 controller uses SMB1





Userlevel 7
Badge +22

I wouldn’t put my primary NAS at risk by allowing SMB v1 but there are many other fairly simple solutions to providing SMB v1 connections to your music so you can safely use the antique S1 only Sonos units.

An inexpensive SMB v1 NAS, like a Raspberry Pi or the many clones works for many. A bit more interesting is an SMB v1 gateway to your primary NAS music collection.

Sorry you haven’t seen my many posts on the work-around options:  (both a bit dated but should work)

SMB v1 Gateway

SMB v1 NAS for Sonos


There are also many posts here discussing the memory limits with explanations that are simple to follow or with technical data that most aren’t interested in. You can of course do your own research both on the internal Sonos memory and the requirements for the current Linux code and Samba server code.

Hi Stan,

thanks for your workaround recipe. That’s what I was looking for.

I don’t currently have my NAS at risk, because I use the workaround that I posted earlier in this thread, ie. I queue to my older Sonos units by grouping them behind newer model Sonos zones. It works, but it is limiting.

As it happens I do have a Raspberry Pi with Samba etc, that I use to monitor and obtain my Sonos system activities. I am not too Linux literate, but I should be able to work through your posts and get your work around going. If I have difficulty, I will get back you via the comments section over at the platform where you published your blog. Thanks!

I did suspect that something could be done using the Rpi, but I didn’t grasp the mechanics of it.

I would migrate to S2, but enjoyment of my Sonos system is dependant upon my s/w which subscribes to events published by the UPnP backbone in the Sonos controller.  The company don’t support community activities at that level, and they don’t allow for the backing out of any Sonos “update” that disturbs things. So I decided to cut myself adrift until such time that they publish something relevant to my use case. I am still in the world of a large personal music collection, and they left that behind a long time ago, so I am not holding my breath while waiting. 


Userlevel 7
Badge +17

I’d be interested (though maybe not in this topic) in your solution for using a large (more than  65k?) music collection on Sonos?

Userlevel 3

Hi all,

I understand that Synology does’t want to use an old protocol or service that can be exploited, but I also don’t want to spend too much money on upgrading my Sonos system to S2. What will be next year, S3? So I will dig up an old rpi that I can use as a SMB bridge between v1 and 3 and leave that somewhere running in my network. My NAS isn’t exposed to the internet and I keep all incoming port closed on my firewall, so the risk is minimal. Switching to a rpi based NAS and a SSD HD like the Samsung T7 is also to be considered.

I tried out the work around for the 65K max issue using a small program to make m3u4u index files from a separate music volume with less played music. It seems to work, only downside is that you need a good folder structure as there is no search or artist/song etc. listing possible. That’s not a big issue for me as my music catalog has a good file structure.

I find the logic unusual. Sonos operated under one operating system from 2005 until S2 was released in August of 2020. Why would they need to bring out this supposed S3 so soon?

I’d be interested (though maybe not in this topic) in your solution for using a large (more than  65k?) music collection on Sonos?

Hi 106rallye, no, that is not my issue. I have not reached that limit. I have just cracked 50k tracks

My issue is that it is hard to relate to a large collection without some computer assistance.

If I look at my collection, I will always find an album to play while I am still looking just in the A's.
Collecting becomes pointless without smart playlists and browsing indices, that enable shrinking the collection to a smaller scale when the mood requires, eg.
* just albums that I have not heard for a year and a half
* or jazz albums that I brought in the last 2 years, which I have played less than 5 times
* etc

Yeah, and I know that collecting albums is pointless anyway 😉, but it is hard to break the habit and hobby of a lifetime. 

My app:
* detects and identifies everything I play on Sonos, and separates it from tracks played by other household members
* it aggregates these plays, with tracks that it has identified that I have played, away from home, on non-Sonos equipment
* all play data is fed into a MediaMonkey database, from which I can browse, and|or publish album level playlists for use in Sonos and elsewhere, or to sync albums into my mobile devices.

So sorry. 
You could load your collection overflow up to a streaming service, and stream it from there.
eg. Youtube allows you to upload up to 100,000 tracks. You can play your own tracks via their web clients (ad free and also offline), or using Sonos.

I loaded all my tracks up to Google back in the Google Play Music days. At that time it was free to store, and stream from 60k of your own tracks. They auto-transcoded to 320bps mp3 copies. I see that the limit has expanded, and they allow flac files now. All of my tracks got migrated to YouTube, so I think it is still free although I do have a F1 account, so I am not sure.