Sonos Beam and Bose QC headphones in Samsung TV



Show first post

130 replies

+1

Exactly the same problem here with LG OLED C8+Beam+JBL bluethooth headphone, hope the issue will be solved soon
Could someone be so kind as to explain why this is a problem that Sonos is the one to fix? From what I can understand, the issue is with HDMI-CEC, and the fact that a connected device has priority. I am not an engineer, but my understanding of the HDMI-CEC API doesn't have a setup to control two differing audio devices at the same time. And if I'm not understanding it correctly, wouldn't the issue be something that has to be "fixed" on the TV side of things, rather than on Sonos? In this instance, Sonos is only a "client" device, telling the Hub (your TV) what it is, and the hub/TV has to decide where to send the necessary audio signal.

What am I misunderstanding here?
Userlevel 3
Badge +2
A small external Bluetooth transmitter fed from the TV's optical output offers more flexibility, better codec quality, and improved lip-sync. Clunky workaround? It's in fact an upgrade.

Why should we have to do this? Stop pushing this as the answer - it is a hack to make an expensive system work and shouldn’t be required. Not to mention that other users have said this doesn’t work for them.

Just get onboard the ‘Sonos Fix It’ bus.

A small external Bluetooth transmitter fed from the TV's optical output offers more flexibility, better codec quality, and improved lip-sync. Clunky workaround? It's in fact an upgrade.Stop pushing this as the answer

I'll post as I wish, thank you very much, within the board codes of conduct. Some posters on this thread have appreciated the advice.

Just get onboard the ‘Sonos Fix It’ bus.

I wasn't aware I was offboard the 'Fix It bus', whatever that may be, but don't you think that if it was such a simple 'fix' Sonos would have implemented it? Clearly the TV software has a key part to play since the complaints have involved relatively few TV manufacturers.

In the meantime there's an inexpensive, better quality, lower latency, more flexible alternative, using an external BT transmitter which can if necessary be tucked behind the TV and USB-powered from it. Feel free to ignore it. In any case those Bose headphones wouldn't be able to benefit from the "better quality, lower latency" aspect.
Userlevel 3
Badge +2
No I do not think Sonos would have fixed it just because they can. They have a million different things they are working on no doubt, and so the point of this thread is to continue to raise the issue and show it is a problem for a lot of people, in the hope it will have its priority raised. Thanks for asking though
Also onboard the fix it bus, just wondering tho as anyone identified a TV where this works ok with Sonos?
Hi, I just created a profile to allow me to keep track of this issue. Please count me as another customer that finds this hugely annoying. I just purchased a beam last month, and definitely would not have if i knew that it was designed this way. Having to constantly unplug and replug the HDMI is no doubt going to cause problems down the road.
This is an absolutely ridiculous problem to have. Sonos need to investigate and fix.
Creative workarounds by adding parts to my TV or disabling CEC control are simply not acceptable solutions for a premium brand product. Especially when you can buy any number of cheaper alternatives which function properly.

Why is the Sonos beam adopting a completely different behaviour than any other soundbar on the market? Plenty of which have voice assistants and other features such as being able to turn on/off the TV through the soundbar controls.

I'd be interested to know if this is even the same same behaviour on their own product lines of alternative TV speaker systems which also function through ARC? Any complaints from play base/bar?
Playbase and Playbar do not utilize HDMI-ARC and do not have on board Alexa. The Amp does use HDMI-ARC, but also does not have on board Alexa.
Hi – I'm also creating an account to express my frustration and disappointment with this functionality. I do not want the Sonos Beam to continuously grab back priority from other audio sources unless I explicitly switch back to it. I hope that Sonos can provide an update on this issue soon.
I'd hazard a suggestion that you complain to the governing body of HDMI-CEC, who set up the standard that Sonos is complying with?
Have you actually heard an official statement from Sonos' product team or is that conjecture?
Have you actually heard an official statement from Sonos' product team or is that conjecture?
There was official response here and here.
Userlevel 3
Badge +2
Have you actually heard an official statement from Sonos' product team or is that conjecture?

This is what they told me:

“The Beam is designed to always take audio priority when connected to your TV via an HDMI-ARC connection. The workaround of toggling Anynet off and on would likely be the best approach. Alternatively removing the HDMI connection from your Beam while using an alternative audio source should also prevent that behavior.”

It is not an unsolvable issue thrust upon Sonos by HDMI-CEC - plenty of soundbars give up the connection when another device connects
Userlevel 3
Badge +2
Hi everyone, this is still something that's being looked at, but there isn't any news to share on if there will be a resolution at this time. Because it's caused by the way that the Beam establishes CEC control for TVs, it's a side effect of the core functionality of a feature. Currently, the best solution if you use your headphones a lot is to either disable CEC in the TV settings, unplug the Beam while using Bluetooth audio output, or use the Optical Adapter to connect the Beam to your TV instead.

Hi Ryan, is Sonos still reviewing this issue or will we be stuck with unplugging the Beam each team we use Bluetooth headphones?
Same problem LG B7 + Beam + Sony Wh-1000xm3.
Wish we could just activate/deactivate the ARC connection in the app.
Thanks for the thread and the many voices for this concern.
All Sonos has to do is simply add a toggle to turn on or off the TV, HDMI port. If you turn off the port from the App, the TV will disconnect the ARC / HDMI Connection and then you can toggle it back on again in the app.

You essentially, most likely can do this my making the Sonos Beam play from a different source, which turns off the TV's sound, and frees up the TV. When its time to play another source, the Sonos sure can avoid the TV, now cant it?

Anywho, make a source that plays nothing at least.... so it jacks it from the TV...

If i were Sonos, i would fix it, its easy, stop annoying your client base with such a silly thing. Customer is always right, period, end of story, fix it or create a work around using code you already have written.
Because I have exactly the same problem (Samsung TV, Sonos Beam, Bose QC35 headphones) I found this Tread.

However, it is frustrating that this problem became known more than a year ago and no viable solution has yet been found.

In today's era of automation, the headphones should be able to be taken off the charging station (once set up) and turned on. Then the audio output of sonos should move immediately to the headphones. No adjustments must be made in menus.

😫I can not suggest the proposed solution to my wife, who would ban the sonos from the house.
In today's era of automation, the headphones should be able to be taken off the charging station (once set up) and turned on. Then the audio output of sonos should move immediately to the headphones. No adjustments must be made in menus.
Sonos doesn't contain any means of driving headphones, Bluetooth or whatever. The headphones make a connection to the TV, and it's how the TV behaves that's the issue.

😫I can not suggest the proposed solution to my wife, who would ban the sonos from the house.

If you really care about fixing this then, as mentioned a number of times in this thread, just get a little, separate Bluetooth transmitter and hook it to the optical output of your TV. Your wife can then just turn on the headphones and they'd work. Turn down the volume on the Sonos player if it's not required for other viewers. The Bluetooth transmitter can most probably be powered from a USB port on the TV, so no need for another power socket.
My Setup: 2019 Samsung TV w/ smart remote + Sonos Beam + Sennheiser 185 wireless headphones

Problem: I can't quickly turn off the sound to my Sonos Beam so I can listen to the TV privately using wireless headphones so the rest of my family can sleep.

Methods Tried and Passed On:
I tried most of them... optical switch w/ remote, wireless on/off receptacle plug w/remote, Bluetooth transmitter, etc. I was able to get these various methods to work but they were too cumbersome, too many buttons, and/or took too much time.


BEST SOLUTION FOR MY SETUP

To Turn OFF Sonos Beam and Turn ON Wireless Headphones - Follow Two Steps:
Step One: Using your Samsung smart remote, press the microphone button** and say the following exactly: "Settings Any Net Plus". Say it slowly like a robot. Brief pause between "settings" and "any net plus". It will bring up the correct settings menu. Press select (that's the center round button inside the round navigation ring). Done. You have just turned off the HDMI ARC connection with the Sonos Beam.

Step Two: Using your Samsung smart remote, press the microphone button and say the following exactly like a slow robot: "Sound Select Optical". Immediately upon hearing the verbal command the Samsung TV will makes the switch for you. No button to push. You are done! Sound will now go only to your wireless headphones and sound to your TV speakers is turned off.

**Note: To use the Samsung's smart remote verbal commands button you can't be inside Netflix or Amazon Prime or similar apps. So before you do step one and step two above do this: press the home button on the remote (the button that has a house on it!) and then toggle to the left and select the app tile that looks like a white TV with light blue background. When in this app, you can give verbal commands with no problems. This is the fastest way to get out of an app that won't take verbal commands and into an app that allows for verbal commands.


To Turn Back ON the Sonos Beam - Only One Step:
Step One: Using your Samsung smart remote, press the microphone button and say the following exactly: "Settings Any Net Plus". Say it slowly like a robot. It will bring up the correct settings menu. Press select (that's the center round button inside the round navigation ring). Done. That's it. You have just turned on the HDMI ARC connection with the Sonos Beam. Sonos Beam is up and running automatically.

Commentary
With this method you don't have to buy any additional gadgets. For fun I timed how long this method takes. It takes less than 18 seconds to turn Sonos Beam off and your headphones on and less than 10 seconds to turn the Sonos Beam back on. Hopefully this will help those of you looking for a solution with a setup like mine. Headphone Auto Detect it is not. One button press solution it isn't either. That said, this is a fast and user friendly solution that I can do on a regular basis without having to hit my head against a wall and laugh at the irony of paying extra for an intuitive, user friendly tv/sound system that won't support how I use my TV. I have used this method for a few weeks now and I can report that I am happy enough and there is enough distance between my discovery of this lack of functionality and this workable solution that I can get back to enjoying my Sonos Beam purchase without giving it the evil eye and mumbling under my breath.
My Setup: 2019 Samsung TV w/ smart remote + Sonos Beam + Sennheiser 185 wireless headphones

Problem: I can't quickly turn off the sound to my Sonos Beam so I can listen to the TV privately using wireless headphones so the rest of my family can sleep.

Your solution seems amazingly convoluted.

Your RS185 'phones have both optical and analog input. I assume you're using optical, which would receive a signal from the TV at all times. All you need to do therefore is pick up the headphones and turn them on.

As for the Beam, why on earth don't you just mute it. If the 'smart remote' somehow has trouble passing the command through the HDMI-CEC from the TV then simply train the Beam to respond to IR codes and use that. Heck, if even that's a problem you could just long-touch the volume-down button on the Beam to mute it when you walk up to the TV to collect the headphones.
+1 also waiting for a proper solution which doesn’t include me having to get up from the sofa unplugging anything. This missing feature is something I would think that you could toggle, especially since you’ve coded the beam to override whatever else me as an user tries to connect. Should be easy to toggle in the Sonos App!

Happy with the product otherwise, but as of right now it is hijacking my TV and solely claims ALL the rights to be the only soundsource. Just like an overly attached girlfriend. Actually really annoyed by this.

I was actually looking for a way to just turn off the beam, but that’s not possible from the app is it? does anybody know?
I was thinking about recommending this product to my father who needs a soundbar (that supports headphones flawlessly) but sadly, I can't recommend Sonos Beam because of this issue.
I think the solution is for Sonos to allow a bluetooth connection from the Beam. As there is no bluetooth radio in the beam, this is not possible. They could have an off button in the app though. Then you wouldn't have to unplug it.
The issue seems to be an HDMI-CEC issue, and not technically a Sonos issue, as near as I can tell. If you connect your Sonos via optical, I don't think you'd be having this issue. It's just the way that HDMI-CEC was designed to work, with a single set of outputs, not two.

Reply