Won't Update Music Library, Part 2


Userlevel 3
Badge +8

A continuation of this thread.

 

Now, even when I manually update, it won’t play music.

 

The controller shows all albums and songs, and also album art - so clearly it’s pushing/pulling info to and from wherever. But it tells me it’s “Unable to connect” to the server address.

Every device on the network - Windows and Android - can connect to the device where the Library is stored. Sonos says it is able to add the Library at that address (and again, it sees songs and artwork).

I’m so, so tired.


112 replies

Userlevel 3
Badge +8

I just installed a new router.

In the spirit of “your path is too long”, I changed it to \\rjbmusic\g\seamusic

(Well the router changed “sda1” to “g”)

I can access the drive from all Windows devices, in Windows Explorer. But I instantly get the “not connected” message.

I am so, so, so, so tired and dispirited over the many failings of this system and all the money I have spent.

Why can’t I get a straight answer on why this won’t work?

Another suggestion that might (or might not) narrow down the possible causes. Put a few dozen tracks on a USB flash drive, put it in the USB slot on the router and see if Sonos can find and index the music.

I’ve used flash drives mounted in TP-Link, Asus and Netgear devices (as well as BT routers OEM’d from different manufacturers).

The path to the top level folder is always something like //routername/partitionname or //routername/volumename, or more often in my case //routerIP/volumename etc.

Sometimes the router assigns the volume name, e.g. “usb” in the case of a Netgear running stock firmware. Sometimes it uses the device name from the drive itself e.g. “//192.168.2.1/corsair” on that same R7000, but running FreshTomato.

Sonos is currently pointed at 5 different subfolders of “//192.168.2.1/corsair”.

Userlevel 7
Badge +15

Physically, where is the music?  On a USB HDD connected to the router?  What is ‘G’?

If you paste the location into an explorer window does it access the files OK?

The thing I mentioned about the shield, I’m not sure it’s related to Sonos ‘permissions’ because that is shown before you try to access the area.  But yes, if you’re not even going into it then it’s probably irrelevant.

On my NAS I can control access to a connected USB drive.  If you’re connecting to one, are you able to control access to it too?

Have you tried a very basic addition - adding a single folder from another location (eg My Music) with a few songs in to see if access is OK?

@Alonzo Mosley,

I would perhaps consult with the manufacturer of the NAS and/or Router, as clearly there has to be a setting to give users on the LAN permission to access the seamusic folder - it’s not even clear how you would select a version of SMB, or allow certain users read/write access etc.

From the screenshots you have posted so far, it’s difficult to suggest how to go about enabling those things.

You could maybe try to take ownership of the seamusic folder first and then set the read/write permissions via windows explorer perhaps, or to inherit permissions from the rjbmusic/g directories that appear to be hierarchical, but that may cause you other issues with the DLNA/FTP services that I see available via the router interface, or NAS software interface, so I’m reluctant to suggest taking that approach.

You are most probably best to go onto speak to the respective support desks relating to your chosen hardware, or maybe ask relevant questions in their user-forum (if they have one) and see if someone can put you on the right path to solving the issue. 

Link was in post immediately above yours - TP-Link Archer AX73 AX5400 Dual-Band Gigabit Wi-Fi 6.

(Because I learned to type on a typewriter, I still underline things and on this forum underlines look like links….)

 

Not just this forum; the underlining of links is a world wide web standard, which is why underlining for emphasis is frowned upon.  Try bolding or italics.

I am not sure if this is relevant (clearly it’s for a different TP-link model) but I’ll throw it into the mix just in case:

https://www.tp-link.com/fr/support/faq/2039/

 

Userlevel 7
Badge +15

All along I've felt it's that @John B , the files just aren't shared correctly and Sonos is not related to this.

Which was why I asked if they were accessible from a Windows explorer menu.

I

I have had this system for over four years. I don’t think it has behaved correctly for 14 consecutive days.

 

I have had mine for 11 years, and it has scarcely missed a beat - in whatever sense you wish to interpret that expression.  No comfort to you, I realise, but drops are in the vast majority of cases down to some feature of the network or the wireless environment. Whether the problems you are having with the library are related to that, I could not say.

I thought, by definition, any storage device attached to and accessed via network devices (e.g., routers, switches) was a “Network Attached Storage” device, a/k/a NAS. Since the router actively supports and encourages attaching storage devices, what clever parsing of the semantics am I missing?

 

Most people, when they use the term ‘NAS drive’, mean a device with one or more disk drives and an operating system. I would guess that 99% upwards of Sonos users who store their music on a ‘NAS’ have a device that connects by Ethernet, although I would not wish to claim that ‘NAS’ implies an Ethernet connection.  I can give you no reason why what you are doing is not working, but maybe you could consider the sort of device and connection that works for so many of us.

I’ve not been following this thread, and have just attempted to skim read it so my comment may be inappropriate.

I’m curious. Why does “…/g/...” keep featuring in the UNC path after the device name? I don’t see a partition named “g”. 

In one screenshot there was a label “G:” which was presumably the Windows mapping. This means nothing to Sonos.

Any mapping is neither here nor there. It has no meaning outside of Windows, where it’s merely a temporary shortcut to a shared folder.

I’ll get me coat.

Userlevel 7
Badge +15

The issue isn't with USB or ‘data integrity', it seems it's more like its implementation/connectivity with the router.

A NAS will more than likely give other functionality too and better control of users and permissions/access.

For an example of fortitude, endurance and courage in the face of adversity, I commend to you the Shackleton expedition to Antarctica that began in 1914.  I never pass up an excuse, however tenuous, to draw people’s attention to it.  It is the most extraordinary survival story there has ever been, or ever could be.  You can (and should) read about it in Shackleton’s own account, “South”, or Alfred Lansing’s book, “Endurance”.

Userlevel 7
Badge +15

The one I mentioned to get from your links specifically said Network Attached Storage (i.e. NAS) (the black one) but looks like you went with the other one. 

You endorsed the WD that I put the link up for...

Says who?

You linked to two items - one called “WD 8TB My Cloud EX2 Ultra Network Attached Storage - NAS” and one called “WD 4TB My Cloud Home Personal Cloud - WDBVXC0040HWT-NESN, Single Drive, White”.

I said to get the MyCloud NAS, but it seems you ordered one that looked like a NAS.

Not sure why you think what you do but my work here is done… I’m getting me coat too.

I was going to say good luck, hope you get it sorted but to be honest I couldn’t care less 😂

I can already anticipate one issue you may face accessing the tracks but there are others who may advise there.

Oh, the Shackleton opinion is hilarious.

Maybe remove the hyphen from the netbios name (RJB-MEDIADRIVE) or replace it with a (static) IP address and see if that first resolves the issue.

I would also strongly consider removing the spaces and shortening the name of the library folder ‘Seattle Music Folder’ as the path/track total characters may possibly be exceeding the Sonos track/path limit of 100 characters (IIRC🤔?)

Hope that resolves your issue.

Userlevel 3
Badge +8

Of course, that means losing mapping on other things. And I’ll lose all my Playlists if I change the name, right?

 

What stymies me is, that still doesn’t explain how it’s pulling down names and album art, and occasionally plays music… Even as it says it can’t connect. So how does a bad naming convention explain that it can get some information but not other from the files?

If album is shown, the file names are likely correct. I’d suspect some sort of networking issue. SONOS is impatient. If something is slowing down the file fetch, SONOS will simply give up.

How are you storing album art? Is it embedded in the music files or stored as “folder.jpg”? If you PING a few files, are the times reasonable?

Check a few of the ‘bad’ files to see if they break the 100 character limit.

Userlevel 3
Badge +8

The point is it doesn’t update unless I remove and reinstall the whole library. So it’s not just one suspect file, it’s the whole dang thing.

Album art is almost entirely embedded in the files, and almost every album is in its own subdirectory with an folder.jpg or index.jpg. Sometimes hidden, sometimes not.

While not exactly your symptoms, I wasn’t paying enough attention to notice that a NAS was failing. I had odd issue reports. Finally, there was a full failure that captured my attention. Actually, there were warning drive lights, but the drive was out of sight.

Likely, your drive is case sensitive.

Do you perhaps need the routers IP address (or Netbios name) at the start of your path to the shared USB drive/music library? (Assuming you have connected it to the new router?) Perhaps see if this thread might assist you…

 

Userlevel 3
Badge +8

Likely, your drive is case sensitive.

Interesting idea.

On my router, the media/server name is “RJBMUSIC” - All Caps.

When it shows up in Explorer Network, it’s “\\rjbmusic” - all lower.

So I tried both, I renamed the destination folder to all lower, and still, nothing. (Well it spins for a few seconds, then tells me otherwise.)

Do you perhaps need the routers IP address (or Netbios name) at the start of your path

I’ll have to play with that in the morning. I had hoped that FTP’ing could work, but Sonos doesn’t let that go.

Userlevel 3
Badge +8

Do you perhaps need the routers IP address (or Netbios name) at the start of your path

Prior to reading that post (I want to slap the guy who’s in love with his system), I had tried:

//192.168.0.1/g/seamusic

\\192.168.0.1\g\seamusic

Which HAD worked on the previous router, but not this time.

I’ve also tried with my PC plugged directly into the router via CAT-5. I couldn’t imagine it would make a difference, and it didn’t.

Two Other Things

Thing One: Adding the Library from the A: Drive

I have the entire USB drive mapped on my PC as the A: drive. Just for giggles, I tried to add the Library using the middle “Another folder or drive...” option. It spun just long enough to get my hopes up, and then returned:

And, before you can say “Firewall!”:

 

I presume that, even if I get this mounted, it’s only going to work when my PC is up on the network and has that drive actively mapped.

 

Thing Two: Choosing the Network

This may be something.

When I’ve been trying to add the Library through the “Networked device (ex. NAS drive)” option, I have been manually typing the address. (e.g., “\\rjbmusic\g\seamusic”).

Today I’ve been trying to add it by hitting the “Browse” button, and selecting “Network”:

  • When I click the click-to-expand triangle next to “Network”, the triangle disappears. Nothing drops down.
  • When I click on “Network”, it spins for six cycles, then stops spinning. Nothing else. None of my networked devices show up. (In Explorer, all of my Sonos devices, other PCs on the network, my Samsung TV, all show up.)
    • UPDATE: In the ten minutes since I posted this, my own PC showed up in the drop-down under “Network”, but no other devices did.

Could resolving that get us closer to a solution?

 

Oh, please, for the love of all that is holy, please help me solve this.

 

 

Reply