Won't Update Music Library, Part 2

Userlevel 3
Badge +8

A continuation of this thread.


Now, even when I manually update, it won’t play music.


The controller shows all albums and songs, and also album art - so clearly it’s pushing/pulling info to and from wherever. But it tells me it’s “Unable to connect” to the server address.

Every device on the network - Windows and Android - can connect to the device where the Library is stored. Sonos says it is able to add the Library at that address (and again, it sees songs and artwork).

I’m so, so tired.

112 replies

Maybe remove the hyphen from the netbios name (RJB-MEDIADRIVE) or replace it with a (static) IP address and see if that first resolves the issue.

I would also strongly consider removing the spaces and shortening the name of the library folder ‘Seattle Music Folder’ as the path/track total characters may possibly be exceeding the Sonos track/path limit of 100 characters (IIRC🤔?)

Hope that resolves your issue.

Userlevel 3
Badge +8

Of course, that means losing mapping on other things. And I’ll lose all my Playlists if I change the name, right?


What stymies me is, that still doesn’t explain how it’s pulling down names and album art, and occasionally plays music… Even as it says it can’t connect. So how does a bad naming convention explain that it can get some information but not other from the files?

If album is shown, the file names are likely correct. I’d suspect some sort of networking issue. SONOS is impatient. If something is slowing down the file fetch, SONOS will simply give up.

How are you storing album art? Is it embedded in the music files or stored as “folder.jpg”? If you PING a few files, are the times reasonable?

Check a few of the ‘bad’ files to see if they break the 100 character limit.

Userlevel 3
Badge +8

The point is it doesn’t update unless I remove and reinstall the whole library. So it’s not just one suspect file, it’s the whole dang thing.

Album art is almost entirely embedded in the files, and almost every album is in its own subdirectory with an folder.jpg or index.jpg. Sometimes hidden, sometimes not.

While not exactly your symptoms, I wasn’t paying enough attention to notice that a NAS was failing. I had odd issue reports. Finally, there was a full failure that captured my attention. Actually, there were warning drive lights, but the drive was out of sight.

Userlevel 3
Badge +8

I just installed a new router.

In the spirit of “your path is too long”, I changed it to \\rjbmusic\g\seamusic

(Well the router changed “sda1” to “g”)

I can access the drive from all Windows devices, in Windows Explorer. But I instantly get the “not connected” message.

I am so, so, so, so tired and dispirited over the many failings of this system and all the money I have spent.

Why can’t I get a straight answer on why this won’t work?

Likely, your drive is case sensitive.

Do you perhaps need the routers IP address (or Netbios name) at the start of your path to the shared USB drive/music library? (Assuming you have connected it to the new router?) Perhaps see if this thread might assist you…


Userlevel 3
Badge +8

Likely, your drive is case sensitive.

Interesting idea.

On my router, the media/server name is “RJBMUSIC” - All Caps.

When it shows up in Explorer Network, it’s “\\rjbmusic” - all lower.

So I tried both, I renamed the destination folder to all lower, and still, nothing. (Well it spins for a few seconds, then tells me otherwise.)

Do you perhaps need the routers IP address (or Netbios name) at the start of your path

I’ll have to play with that in the morning. I had hoped that FTP’ing could work, but Sonos doesn’t let that go.

Userlevel 3
Badge +8

Do you perhaps need the routers IP address (or Netbios name) at the start of your path

Prior to reading that post (I want to slap the guy who’s in love with his system), I had tried:



Which HAD worked on the previous router, but not this time.

I’ve also tried with my PC plugged directly into the router via CAT-5. I couldn’t imagine it would make a difference, and it didn’t.

Two Other Things

Thing One: Adding the Library from the A: Drive

I have the entire USB drive mapped on my PC as the A: drive. Just for giggles, I tried to add the Library using the middle “Another folder or drive...” option. It spun just long enough to get my hopes up, and then returned:

And, before you can say “Firewall!”:


I presume that, even if I get this mounted, it’s only going to work when my PC is up on the network and has that drive actively mapped.


Thing Two: Choosing the Network

This may be something.

When I’ve been trying to add the Library through the “Networked device (ex. NAS drive)” option, I have been manually typing the address. (e.g., “\\rjbmusic\g\seamusic”).

Today I’ve been trying to add it by hitting the “Browse” button, and selecting “Network”:

  • When I click the click-to-expand triangle next to “Network”, the triangle disappears. Nothing drops down.
  • When I click on “Network”, it spins for six cycles, then stops spinning. Nothing else. None of my networked devices show up. (In Explorer, all of my Sonos devices, other PCs on the network, my Samsung TV, all show up.)
    • UPDATE: In the ten minutes since I posted this, my own PC showed up in the drop-down under “Network”, but no other devices did.

Could resolving that get us closer to a solution?


Oh, please, for the love of all that is holy, please help me solve this.



If your music library is on a USB drive connected to your new router, then the router manual or it’s configuration pages will normally tell you what the ‘path’ is to that shared drive on the network and then onto the end of that ‘path’, you would add the folder structure to where your library is situated - I would ignore the mapping of drives on your computer, as I’m not sure that will help a Sonos speaker on the network find your library that’s connected to your router. So try to discover the actual UNC path.. It’s probably something similar to:

\\\MyUSB\SharedData\Music - or - \\MyNewRouter\MyUSB\SharedData\Music

Note: the above are just ‘mock’ examples - you need to discover the real path.

I would start by looking at what the router manual says about using/sharing a connected USB device.

Userlevel 3
Badge +8

The “\\rjbmusic\g\seamusic\” is the literal path from the router. (Caps doesn’t seem to make a difference).

Router Screenshot

From the Manual:


“Secure Sharing” (i.e., password-protect) is turned OFF, and “Media Sharing” is turned ON.

The “Partition G:” doesn’t seem to be changeable or matter, other than the “g” needs to appear in the address to point any other machine on my network (Android, PC, TV) to that drive. On my former router, it was “sba1”. (If I omit the G and just point Sonos to “rjbmusic\seamusic”, it returns with “There is no shared folder...”)

As far as I can tell, I am doing everything correctly.

Userlevel 3
Badge +8

The drive is listed in Explorer


Trying to edit permissions gives me a “Failed to enumerate objects” error, so I tried to change the owner (currently “S-1-22-1-0”). This gives me an “RPC Server is unavailable” message. But as far as I can tell, all RPC services are running, and “Remote Assistance” is A-OK on firewall.

So does the path \\RJBMUSIC not work for you?

Userlevel 3
Badge +8

That’s what this entire thread is about.

That’s what this entire thread is about.

Ignoring your Windows PC for one moment, have you tried setting up the library from the S2 mobile controller App using that path in the "music library setup"?

Userlevel 3
Badge +8

Yes. I have tried from Android and iOS devices.


JUST “\\rjbmusic\” doesn’t allow me to click Next - it’s just ether.


If I put in “\\rjbmusic\g\”, it actually does load the Library. But here’s the problem: It loads the entire drive. Not just the folder with Sonos music in it. So it loads every mp3, flac, everything that’s on that drive that I don’t want in Sonos - but need from other devices on the network.


I really don’t want to put a hub on the router and have a byzantine hydra of USB drives hanging behind bookcases… But we’re closer.


***************So why can Sonos read the drive, but not the specified folder?

You just need to add to the path, try \\rjbmusic\g\ followed by the folder name where your music files are - is it seamusic?

If so, then it’s \\rjbmusic\g\seamusic

Just browse the drive to see where the files are that you wish to add.

In my own case, the Network NAS is called \\NASPro\ and I have my music library in a folder called ‘Music’ on that device. So my path is easy and straightforward \\NASPro\Music\

If I browse to that folder on the network I see my music folders which are listed by Artist (see attached screenshot).

In each one of the artist folders are their Albums and inside each Album folder are the track files and cover art (folder.jpg)

In the Sonos App the path is just shown as \\NASPro\Music\ and so anything ‘below’ that folder path (ie Artist/Album folders and music files) are added to the Sonos library index.

I have other folders on the NAS here, which also have other music files in them too, such as my ‘FlacFiles’ folder, but they are (deliberately) not currently included in the Sonos library, because they are held in a different folder path on the NAS - example \\NASPro\FlacFiles\

I could add that folder as another separate second library path to my Sonos App, that’s if I wanted to include the music files in that folder too, or as an alternative, I could also move the folder inside the Music folder so it gets included in the original path like this…


All I need in Sonos then though is the same path: \\NASPro\Music\

I hope that info. assists you to get things working in Sonos as you want it to work for you.

Userlevel 3
Badge +8

If so, then it’s \\rjbmusic\g\seamusic

Just browse the drive to see where the files are that you wish to add.

I don’t mean to sound jerky but I have posted several times that it will NOT accept that address.


(But it does know enough that if I try to add a subdirectory that the higher directory is already added, and won’t allow it. (“The folder you are trying to add is a subset of an existing shared folder”).

Userlevel 3
Badge +8

And, it all worked correctly once, several Sonos updates ago. I know what it is supposed to look like and do.

And, it all worked correctly once, several Sonos updates ago. I know what it is supposed to look like and do.

Ah okay, well I’m just trying to help. I’m sorry if some of the things mentioned are obvious to you. I’m not aware of your knowledge/skills with the library setup. Anyhow I hope you get it sorted.

Userlevel 3
Badge +8

 I’m not aware of your knowledge/skills with the library setup.

I’m saying I know what the result is supposed to be - but nothing I attempt gets there.

New wrinkle.

It mapped the “drive” and not the “folder” (\\rjbmusic\g\” but not “\rjbmusic\g\seamusic\”) on Saturday.

I added a folder to the volume on Sunday to test the automatic overnight update - it did not update.

I tried to manually update - it reverted to the original “no longer available” message.

I removed and tried to re-add - from a Windows and from an iOS device - and neither worked.

So back to square one.

Can you perhaps post a screenshot of the folders on the ‘root’ of the USB drive and perhaps another one that shows what folder-structure your chosen music folder is using?