Sonos S2 14.18.2 notification: stopping the service may interrupt playback notifications

  • 8 November 2022
  • 69 replies
  • 15377 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

69 replies

This is a workaround (Set Android to ignore Sonos notifications)… 

 

No workaround, that’s the solution. The notification keeps background services alive that the Android app relies on, the only thing you can do is to hide it away.

So apparently the Sonos Android application has not relied on background services for years, since the superfluous notification only started materializing itself like a month ago?

 

Google changed their background services policy with Android 11.

This is a workaround (Set Android to ignore Sonos notifications)… 

 

No workaround, that’s the solution. The notification keeps background services alive that the Android app relies on, the only thing you can do is to hide it away.

So apparently the Sonos Android application has not relied on background services for years, since the superfluous notification only started materializing itself like a month ago?

Badge +1

This is a workaround (Set Android to ignore Sonos notifications)… 

 

No workaround, that’s the solution. The notification keeps background services alive that the Android app relies on, the only thing you can do is to hide it away.

That's a pity and dare I say, rather slack and sloppy, of Sonos, because this didn't happen with the Sonos S1 app.

This is a workaround (Set Android to ignore Sonos notifications)… 

 

No workaround, that’s the solution. The notification keeps background services alive that the Android app relies on, the only thing you can do is to hide it away.

Userlevel 2
Badge

Hey guys,

 

On the Android device go to ‘Settings → Notifications → Sonos’, there toggle off "Background Services".

 

This is a workaround (Set Android to ignore Sonos notifications)… 

 

If there is a other issue with Sonos Services you will not get that notification because you disabled *all* background services notifications… 

 

Sonos should fix this issue 

 

Hey guys,

 

On the Android device go to ‘Settings → Notifications → Sonos’, there toggle off "Background Services".

Userlevel 2
Badge

And also 14.20.1 did not fix the issue…. 

Sonos does not care about Android users…. 😔

 

And this topic is not answered, only that somebody found a option in Android to kill the Sonos notifications does not mean the problem is solved.

Userlevel 1
Badge +3

 

It wouldn't bother me so much if the notification meant something, and did something when you press it, but it just permanently sits there cluttering up your phone's notifications. Unacceptable.

 

It does mean something. The notification keeps background services alive that the Android app relies on.

Sure it means something, but it’s only important to SONOS technical staff. Repeated notification is completely unecessary for my daily use. Unacceptable.

Userlevel 2
Badge

And still not fixed in version. 14.20

Can we please get this fixed?

 

Somehow it’s now getting worse for me in the sense that I clear it after I open it up and then a few minutes later it just pops back up, whereas before it only seemed to come up when I first opened the App.  Super annoying for an otherwise fantastic product and software.

Same issue here since a couple of weeks on Android

Same here (S22+). What a *** product Sonos has become over the years.

 

*Moderator Note: Modified in accordance with the Community Code of Conduct.*

Userlevel 1
Badge +1

Same problem here.

Seems to serve no useful purpose, started happening fairly recently.

Userlevel 3

I’m getting the same extraneous notification as well.  I have a Google Pixel 3. 

I contacted Customer Support, and they asked me to check other phones (which I did), and then they wanted me to see if it occurred on iOS as well.  I explained that we only have Androids at our house.  They said they couldn’t determine if it only affected Androids or Apples.  (Umm… either way, you’re affecting approximately half the mobile phone market!) 

They eventually agreed to create a case number for me.  I’ll try to post if I get any useful updates. 

So  I registered here to create a post about how this and when I was typing the Subject, it popped up and linked me to this thread where it has already been discussed, so let me just add myself to the list of Sonos users who really wish this would get fixed.

Not sure why we need this notification, not exactly groundbreaking info.  And I don’t want to turn off notifications, just want ability to not have THIS notification.

On a Pixel 7 if that helps at all...

 

Userlevel 1
Badge +1

Hi!

Same here, the Sonos app on Android activates two notifications (one is normal and works well, the other is like a ghost notification, useless).

I’ve tried to reinstall the app but with no effect. Problem is present on multiple devices, with Android 11, 12 and 13.

Double notification icon on Android app | Sonos Community

 
 

 

 

Same experience here: Bug introduced with 14.18.2, 14.19 didn’t solve it, and it’s annoying.

Seen on a Pixel 3 with Android 12 and a Samsung tablet with Android 11.

Cheers

Same thing here on old LG G5 with Android 8.

Agree this is unacceptable. Imagine if all apps did this, your notification area would be cluttered with tens (hundreds?) of useless notifications.

Same problem for me.  Latest Android, Pixel 5a

Userlevel 2
Badge

Hallo, 

I didn't turn off ALL notifications of Sonos only backgroundservices. 

Maybe it works for others.

Yeah that worked for me. Seems like the best fix for this right now 

 

This is not fix, just a workaround to get the notification off

Sonos should explain this notification or resolve the notification as it seems to be wrong…

 

Build 14.19 did not solve the issue.  :(

Userlevel 6
Badge +14

Hallo, 

I didn't turn off ALL notifications of Sonos only backgroundservices. 

Maybe it works for others.

Yeah that worked for me. Seems like the best fix for this right now 

Hallo, 

I didn't turn off ALL notifications of Sonos only backgroundservices. 

Maybe it works for others.

This is terrible consumer / user experience.  There is no reason this notification needs to be present - it cannot be dismissed and it stays on my lock screen and notifications panel (Android) since I have the mini music player present.

 

Sonos - please fix this.  This is sloppy CX and is a useless message.

 

It wouldn't bother me so much if the notification meant something, and did something when you press it, but it just permanently sits there cluttering up your phone's notifications. Unacceptable.

 

It does mean something. The notification keeps background services alive that the Android app relies on.

Same issue here. OnePlus Nord Android 11.

It wouldn't bother me so much if the notification meant something, and did something when you press it, but it just permanently sits there cluttering up your phone's notifications. Unacceptable.

The solution is to go into Settings > Apps and notifications >  Sonos > Notifications

Here, toggle off the "Background notifications" option.

Of course, you shouldn't have to do this, and I don't know if this will prevent other important notifications from displaying.

Please fix this Sonos.