Question

Sonos One Alexa not working correctly

  • 25 October 2017
  • 36 replies
  • 9596 views

Userlevel 1
Set up new Sonos One. Alexa will start playing when requested but when requested to stop or pause, Alexa responds with "I can change playback mode only when music is playing" despite the fact that music is currently playing. Alexa will respond to other questions like "what's the weather?" but then music resumes. Alexa just won't stop, or play music on another speaker once started.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

36 replies

Hello Again

So this problem essentially repeats it self if i ever control the speakers directly from my spotify account and then try do alexa voice commands. This time when is say "Pause" , the light blinks and it does nothing.

I can solve the issue by disabling and renabling the skill but are you guys working on a permanent fix?

Arun
Userlevel 7
Badge +20
Great news 🙂
Hello, i recently started having thing problem randomly. Everything was working fine and then 4 days ago, the pause does not work. To re cap, i can start music by saying "Alexa play Piano Music" or even just "Alexa Play" and then if i say "Alexa Pause" i get a "i am not quiet sure how to help you with that" . I am playing from spotify. how do i fix this?

Arun


Hi

If you say 'Alexa, Stop' does that work - I find this command more reliable than 'Pause' and to Sonos it means the same thing.

If this doesn't work, please disable and then enable the Sonos skill in the Alexa App>Skills>Your Skills>Sonos and retest.



Just read the second part of your message. Did that, solved my problem. Thanks
Userlevel 7
Badge +20
Okay next can you power down for 10 secs your devices in this order letting each boot completely before moving to the next:

- Router
- Any wired network switch
- An Wired Sonos product
- Any other Sonos product
[/quote]

Hi

If you say 'Alexa, Stop' does that work - I find this command more reliable than 'Pause' and to Sonos it means the same thing.

If this doesn't work, please disable and then enable the Sonos skill in the Alexa App>Skills>Your Skills>Sonos and retest.[/quote]


Just Tried it .... it just does nothing and music continues to play
Userlevel 7
Badge +20
Hello, i recently started having thing problem randomly. Everything was working fine and then 4 days ago, the pause does not work. To re cap, i can start music by saying "Alexa play Piano Music" or even just "Alexa Play" and then if i say "Alexa Pause" i get a "i am not quiet sure how to help you with that" . I am playing from spotify. how do i fix this?

Arun


Hi

If you say 'Alexa, Stop' does that work - I find this command more reliable than 'Pause' and to Sonos it means the same thing.

If this doesn't work, please disable and then enable the Sonos skill in the Alexa App>Skills>Your Skills>Sonos and retest.
Hello, i recently started having thing problem randomly. Everything was working fine and then 4 days ago, the pause does not work. To re cap, i can start music by saying "Alexa play Piano Music" or even just "Alexa Play" and then if i say "Alexa Pause" i get a "i am not quiet sure how to help you with that" . I am playing from spotify. how do i fix this?

Arun
Userlevel 7
Badge +26
Hello my problem with new sonos1 I ask Alexa to set timer and a alarm it shows up but the never go of I have set the time right and date but dose not work
Just making sure, have you tried setting the date and time for both of the Sonos One entries within the Alexa website using a computer? alexa.sonos.com for the US.
Hello my problem with new sonos1 I ask Alexa to set timer and a alarm it shows up but the never go of I have set the time right and date but dose not work
Userlevel 7
Badge +26
The issue we were looking into is now resolved, so the direct naming shouldn't be needed for those commands on the Sonos One. Let us know if anything else comes up.
Badge
I only have one Sonons. It is in the kitchen. I started a podcast in the sonos app, then told "Alexa, stop in the kitchen" She replied that there were no cameras attached to the device.

I tried several more times, and now it seems to be working by adding the room. Weird.
Userlevel 7
Badge +26
I recently replied to one of your other threads Jason, but for others not there, we're looking into an issue similar to what some of you are describing.

Currently, if you start music on the Sonos One using the Sonos app, you can't use the "Alexa Stop" command all of the time, it may give you an error. If you use "Alexa, stop in the ____" it should work though. We're working with the team on that right now, but for that specific command, the implicit targeting is having trouble.
Badge
8050756
Userlevel 7
Badge +20
Just tied rebooting. Still having the same issue. I started playing a podcast from within the sonos app, then asked Alexa to stop. Alexa told me she could not adjust playback when no music is playing. I had to use the app to stop playback

I've just tested this again, it was working earlier but I can now replicate your issue consistently. Diagnostic 8050731.

Can you please Submit a diagnostic and post the number here?
Badge
Just tied rebooting. Still having the same issue. I started playing a podcast from within the sonos app, then asked Alexa to stop. Alexa told me she could not adjust playback when no music is playing. I had to use the app to stop playback
Userlevel 7
Badge +20
The reason why the commands are not working is because you probably started playing your music thru the app. I noticed if you do so, voice commands Do Not work. You have to stop music thru app. As long as you start your music thru Alexa all commands for playing, pausing, skipping songs will work. Its really annoying. Hope this helps.

This is the issue but it worked a week ago. I think an update was pushed server side and functionality has since been diminished.


There have been some issues but if you reboot these items in this sequence it appears to resolve the issues associated to the latest Update:

- Router
- Connect or other wired device;
- Sonos Players.
Userlevel 7
Badge +20
The reason why the commands are not working is because you probably started playing your music thru the app. I noticed if you do so, voice commands Do Not work. You have to stop music thru app. As long as you start your music thru Alexa all commands for playing, pausing, skipping songs will work. Its really annoying. Hope this helps.

Starting audio from the app and then controlling via Voice works for me.
Userlevel 7
Badge +20
Can you please try these actions:

- In the Alexa app, select 'Skills' and disable the Sonos Skill;
- In the Alexa app (PC version), select 'Smart Home' then 'Devices';
- Select 'Forget All' at the bottom of the screen;
- In the Sonos app, select 'Settings' and for each of the Sonos 1's remove 'Voice Recognition';
- If you have a Connect, Boost or other wired device, please power down and then switch on and wait for it to boot;
- Power down the Sonos 1's and then switch them back on and wait for them to boot;
- In the Sonos app, Select 'Manage' and then select 'Add a player or sub' and add the two Sonos 1's again. This will complete the set-up process again;
- In the Alexa app, select 'Skills' and ensure the Sonos skill is enabled, if not please 'Enable';
- In the Alexa app (must be PC version), select 'Smart Home' then 'Devices'
- Select 'Discover' at the bottom of the screen. Ensure that your Sonos 1's are displayed correctly and not shown as 'Off Line'. Also ensure that there are no devices with the same name (To ensure my Sonos devices are not duplicated, I've added Sonos to the end of each of my players within the Sonos App. Remember, if you want to do this, rename before selecting 'Discover';

Please retest and let me know the result.
Userlevel 1
Badge
The reason why the commands are not working is because you probably started playing your music thru the app. I noticed if you do so, voice commands Do Not work. You have to stop music thru app. As long as you start your music thru Alexa all commands for playing, pausing, skipping songs will work. Its really annoying. Hope this helps.

This is the issue but it worked a week ago. I think an update was pushed server side and functionality has since been diminished.
Badge
I am having exact problem. When I start something within the Sonos app, Alexa does not "see" it. I get same response: I can change playback mode only when music is playing

Really frustrating. I don't recall this happening when I first got it.
This is my second Sonos one to have problem. First one wouldn’t connect to music services despite Alexa saying it was connecting. This time it’s worked for a week and now doesn’t play again. Very frustrated and feel like I’m training their tech support staff.
I have just developed exactly the same issue with my sonos and Alexa after it had been working perfectly for over a week - have tried all sorts but cannot rectify the problem currently - very frustrating.
The commands used to work when started playing via app as mainly listen to Spotify have to start this way.
Alexa will not start playing music via voice command


Oh I see. I use Amazon Music. Either way, the voice commands should work regardless of where the music is coming from. I feel your frustration.
The commands used to work when started playing via app as mainly listen to Spotify have to start this way.
Alexa will not start playing music via voice command
The reason why the commands are not working is because you probably started playing your music thru the app. I noticed if you do so, voice commands Do Not work. You have to stop music thru app. As long as you start your music thru Alexa all commands for playing, pausing, skipping songs will work. Its really annoying. Hope this helps.