Question

Sonos One Alexa not working correctly

  • 25 October 2017
  • 36 replies
  • 9530 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

36 replies

Can't wait for Sonos/Alexa to sort out this bug - really annoying after having the system working (almost) perfectly albeit awaiting the full Spotify integration. I hope I don't have to wait until 21st December to get this new issue resolved and proper functionality back ?
Same problem here. Got my first Sonos 3 today to fit in with my Alexa controlled home. Big disappointment that it doesn't work correctly with Alexa.
I thought the Play would be the answer to upgrading the sound to my Alexa controlled home but it breaks the Alexa functionality and is more trouble than it is worth. We have used an Echo Dot with an external speaker for a year or more now to control several lights throughout the house and radio mostly through Tunein Radio.

I'm sure the Play is a great speaker but having to control it through the app is no better than a bluetooth speaker and is not universally useful like a bluetooth speaker. Sonos should have waited on this Alexa beta because I now have had a bad first experience with their products.
Same here. It was working fine for about a week and now it does not recognise that something is playing. Commands like pause are met with "I can change playback mode only when music is playing", and asking it "what's playing" gives the response "i'm sorry i cannot tell what is playing".

No naming conflicts and I've tried disabling skills/re-authorising everything/linking the alexa back to the sonos/etc.
I have just developed exactly the same issue with my sonos and Alexa after it had been working perfectly for over a week - have tried all sorts but cannot rectify the problem currently - very frustrating.
I’m having the same issue. No other devices with same name on the system but she still says she can’t stop playback
i have had nothing but problems connecting my Play 1s to my echo DOT with little/no help from Amazon tech support and Sonos tech support needs to increase their hours for tech support. The comments easily done via the webpage is long extinct.
Userlevel 1
If I delete alexa app, and Sonos app can I reset everything? Or once I log on, all information will repopulate with the crosswired links
Userlevel 1
This is part of my device screen in Alexa app. Lisa's office (is where I moved original Echo), Nook had previously been created and linked to my Sonos one (this was deregistered and factory reset, confirmed to be off my device list, and when I set it up again, I named it "kitchen". Showed up as Nook anyway.), Not sure where "office" came from but this is where Alexa believes that she is playing music. I can only deregister the the Nook, there is a serial number under office, but I bet it is one representing Sonos (not Alexa), a different serial number under Nook. And What is this "David's Amazon Apps". This is not a device
Userlevel 1
Pulling my hair out. That may have been the problem, but had changed another device name after set up. So, I have renamed previous device that I moved to a new location, but even after a factory reset of both devices, Alexa still plays music from speaker, but believes it is playing from the other one (using previous room name that no longer existed), when I go to device list, it doesn't even list the new room I set up after factory reset, but does display a previous name I had used, along with another room that was not present before setup. It is somehow not linking Sonos One Alexa function, to Sonos one device, keeps linking it to my Echo. (first generation I think)
Check the Alexa app to see if there are any duplicate names for your smart devices. Change them to unique names and ask Alexa to "discover devices" again.