Resolving (the majority of) Issues with Alexa on Sonos

  • 5 January 2018
  • 95 replies
  • 134140 views


Show first post

95 replies

Userlevel 7
Badge +20
There is no Forget All in the Alexa app. There is also no Settings on the Sonos link USA site. Terrible instructions.


I can't see the US site, as I have a UK account but they were there and still are on the UK site Also, are you trying to tell me that Amazon have removed the Settings page from the Alexa App in the US? How do you configure Alexa then?
I have a new Sonos Beam. All working well, except I can't setup Alexa. I've been onto the Alexa app/website and added the Sonos skill; I've then been through the steps of providing Amazon and Sonos credentials. But then when it asks to discover, it tells me that an error has occurred so the Beam never appears. I've tried restarting the Beam but to no avail. It is my first Alexa product fyi. Please can someone assist? Been going at this for hours.
There is no Forget All in the Alexa app. There is also no Settings on the Sonos link USA site. Terrible instructions.
Userlevel 2
Badge
This did not resolve the issue of Alexa skills not actually playing even though Alexa acknowledged the command and said "now playing..." I am having this same issue, followed all the instructions three times over, clearing out Amazon accounts, etc, and nothing. She still says, "playing *whatever*" and then nothing. This is very irritating. Anything I can do? If not I might have to return.

This was a known issue for a while with no amount of resetting addressing it, but it seems to have been fixed in one of the last two Sonos updates. Mine now works OK (previously no joy even with UK Media's steps).

So do check your application version on your phone/device and make sure Sonos is updated to the latest version.

As a test, enable "Babbling Brook" skill on the Alexa page and then say "Alexa, start babbling brook".

Good luck.
Userlevel 7
Badge +20
This did not resolve the issue of Alexa skills not actually playing even though Alexa acknowledged the command and said "now playing..." I am having this same issue, followed all the instructions three times over, clearing out Amazon accounts, etc, and nothing. She still says, "playing *whatever*" and then nothing. This is very irritating. Anything I can do? If not I might have to return.

Hi

This is an earlier post of mine which has some additional steps to those listed above. It's normally one of these three issues:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please open the Alexa App on a PC (https://alexa.amazon.co.uk or https://alexa.amazon.com)>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the PC version has this functionality.)

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (PC version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app , select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.
This did not resolve the issue of Alexa skills not actually playing even though Alexa acknowledged the command and said "now playing..." I am having this same issue, followed all the instructions three times over, clearing out Amazon accounts, etc, and nothing. She still says, "playing *whatever*" and then nothing. This is very irritating. Anything I can do? If not I might have to return.
Badback,

Are your sure the LED light is red and not orange? See below link for the meaning of the LED lights...

LED Lights on Sonos Products
Hmmm, so this worked...in a limited fashion. For some reason the sonos app wouldnt show my play:1s, so i tried to re-add them to the system. I cant get one of them to add (have tried everything right way back to a factory reset and i just get a solid red light), and now Alexa has stopped working again.

Will try the steps outlined here again, and see if it works, but any other tips would be gratefully recieved.

Im not sure if it makes any difference, but i have a second router in the loft, set up as a wireless ap. This is the router im trying to add the loft speaker too (although it worked fine in the past).

Thanks

Tom
Badback,

Ha ha ... I guess you will have to 'salute' your 7 year old. :D

Anyway, really glad to hear you are back up and running.

All the best.
Thanks Ken, that worked!! I must have done that 20 times before doing the full reset without it working, but never thought to do it again afterwards!

The only downside is that my 7 year old will be in charge of the music again now 😉 At least she has good taste (other than her obsession with Little Mix)!
Badback,

Go to the Alexa App... go to your skills and disable the Sonos Skill (assuming it’s there) and then simply re-enable it. The Skill will sign into your Sonos Account and you need to link it to the Amazon Account that has the Alexa links to your Amazon Music, Spotify or Deezer subscription.

After the accounts are linked and the Skill is installed, then close the Skill and it will automatically prompt you to scan for devices. Let the scan finish.

Then go to the devices tab in the smart-home section of the Alexa App and you should see all the names of your Sonos Rooms in there. Make sure there are no offline duplicates, if so, remove them and scan for devices again.

Don’t forget to set your chosen music subscription as the 'default service' in the Alexa App... this is done in 'Settings/Music & Media/Choose Default Music Services'.

You can then try to voice control your speakers ... the below link also provides a current list of Alexa voice commands that you can use with Sonos.

Controlling Sonos with Alexa
CLICK HERE for voice control instructions.
Ive tried all of these steps, but still getting the same issue. Alexa has worked well since Christmas, than a few weeks ago seemed to lose voice control - we can play music on the 1 with the sonos app, but anytime we try voice conrol, Alexa says "hmm, ensure that the sonos skill is enabled in the alexa app, then say discover devices."

Diagnostic code is 1680985445.
Userlevel 1
Badge +1
Maybe it's a typo, as it may support it in the future... anyway I gave up on the Sonos One, returned it and bought 2 Play 1 (for stereo pair) and an Amazon Echo Dot 2nd generation. I already have a Play 5 2nd generation for future Airplay 2 so no need for the Sonos One (for stereo pair it's so pointless to have two smart speakers next to each other)...

It's a same that It can't stereo pair with Play 1's because I would have just bought one of those and kept the Sonos One...

BAD... BAD... Sonos! 😛
Userlevel 7
Badge +19
Interesting... I will reach out to the team about this and get back with any information.

According to Amazon's support site, it only shows Echo devices and neither the Sonos One or Eufy Genie... :?

Userlevel 1
Badge +1
roman2810 & marianvlaza: Thanks for posting, I'm happy to clear this up. That particular feature is only available to Amazon Echo devices and is not supported on Sonos One. Should this change and I am able to provide an update I will be sure to reach out with an announcement on the Community. Thanks!

Then why is Sonos One listed as a supported device? thanks

Userlevel 7
Badge +19
roman2810 & marianvlaza: Thanks for posting, I'm happy to clear this up. That particular feature is only available to Amazon Echo devices and is not supported on Sonos One. Should this change and I am able to provide an update I will be sure to reach out with an announcement on the Community. Thanks!
Userlevel 1
Badge +1
It's the same for me but I can't find an exact answer....
Hello, guys! I perchased the Sonos One speaker resently. In Alexa app I found a function to adjust the speaker to my voice in order to make it respond only to my voice. When I press button to start setting this function, the app says that my device doesn’t support this function, though in help page of this function I found that Sonos One does support it. Why I can’t start this function?
Userlevel 7
Badge +20
Great news 🙂
Badge
Success! Thanks everyone for your advice and assistance, I finally sorted it. I did everything you suggested and was getting nowhere fast until I did a factory reset on each speaker.
Now all registered on a different email account and all is good. Thanks again. 🆒
Badge
Ok thanks, I will give it a go and let you know.
Userlevel 7
Badge +20
Thanks again, just a thought I was thinking my other option would be to wait for Google home to be supported apparently some time this year..?

I would expect the same issue. The cloud doesn't know you have two homes unless you have two accounts. I helped someone early on where someone's boyfriend was playing music through his girlfriends speaker and one was east coast of the US and the other west coast. It really is simple if you follow my instructions in my previous post.
Badge
Thanks again, just a thought I was thinking my other option would be to wait for Google home to be supported apparently some time this year..?
Userlevel 7
Badge +20
Thanks for that, I will try the wife's device route and let you know how I get on.
Cheers.


The best way to do this is when you open the Sonos App in your new home make sure you select New System and not Connect to Existing. (If you've already connected, just uninstall and then install the Sonos App again.)The Sonos app will then ask you to enter your email and password and if you enter a different email to your first home account then a new account will be created. When you add voice services for this new account, it will ask you to enter your Amazon account details, at this point you need to enter your wife's Amazon account details. (Make sure that you are not still logged into your Amazon account on the same device when setting up as otherwise it will default to this account.) Let us know how you get on, once this set-up is done, there will be no complication switching between addresses.
Badge
Thanks for that, I will try the wife's device route and let you know how I get on.
Cheers.

Reply