Resolving (the majority of) Issues with Alexa on Sonos

  • 5 January 2018
  • 87 replies
  • 109783 views


Show first post

87 replies

pjb904,

Go to your Alexa App ... remove the sonos devices in the smart-home section (Devices Tab) .. then goto skills and remove the Sonos Skill. Give it a minute or so. Now restart your Router and the two Sonos devices. Wait till they are booted and both speakers are back online and appearing in your Sonos App.

Now reinstall the sonos Skill in the Alexa App, logging into both your Sonos Account and your Amazon Account and accepting the sharing agreement.

As the Sonos Skill install finishes, it will prompt you to scan for devices .. during the scan it should find both your Play: 1, called Kitchen and your Play 5 Room too.

When the Alexa scan has finished try the voice command again “Alexa play music in the kitchen”.
Hi, nothing else called kitchen. The Echo Dot is called 'Echo Dot'. The volume isn't muted.......
Hi. It's a Play:1
The speaker is named by the Sonos App (as a location) 'Kitchen' . I asked the Echo Dot to discover devices via the Sonos Skill in the Alexa App, and it's discovered as 'Kitchen'. The Sonos Play:5 I have in another room always works - but I don't want to listen on that!
Any help???
Just for clarification do you have any other devices named kitchen? Like an echo dot for example? If not try this ... “Alexa, play some music in the Kitchen” ... make sure your speaker isn’t muted (with 'x' showing on volume slider) and the volume is turned up enough for you to hear it.
Hi. It's a Play:1
The speaker is named by the Sonos App (as a location) 'Kitchen' . I asked the Echo Dot to discover devices via the Sonos Skill in the Alexa App, and it's discovered as 'Kitchen'. The Sonos Play:5 I have in another room always works - but I don't want to listen on that!
Any help???
My problem is (like many) the Echo dot says 'playing on Kitchen' (Sonos:1) and no sound comes from there. The Play5 in another room always works when told to do so. Have tried *everything * suggested, and I'm tired of two 'proper' companies (this isn't a cheap gizmo from China with some half baked App to control it) saying this works when clearly there's a serious issue with compatability. I may just by an Echo with a speaker and ditch my Sonos Play:1 I'm so p**sed by this :-(
I would not be able to recommend Sonos in future. Very sad customer.

Are you using a 'Sonos One', or a Play:1 Speaker here ? ...and is the speaker uniquely named for Alexa purposes or does it have the same name as your echo dot device?
I did all the steps above. Still does not work. I have Spotify enabled as my Default Music Service. Like everybody else: I say, "Play Legs by ZZ Top". Alexa replies, "OK, playing Legs by ZZ Top on Spotify". Then it doesn't play anything. I submitted Diagnostic Code: 644701571
What device are you asking Alexa to Play your music to here? Is it a 'Sonos One' you are using? or are you using an Amazon Echo device?
I did all the steps above. Still does not work. I have Spotify enabled as my Default Music Service. Like everybody else: I say, "Play Legs by ZZ Top". Alexa replies, "OK, playing Legs by ZZ Top on Spotify". Then it doesn't play anything. I submitted Diagnostic Code: 644701571
My problem is (like many) the Echo dot says 'playing on Kitchen' (Sonos:1) and no sound comes from there. The Play5 in another room always works when told to do so. Have tried *everything * suggested, and I'm tired of two 'proper' companies (this isn't a cheap gizmo from China with some half baked App to control it) saying this works when clearly there's a serious issue with compatability. I may just by an Echo with a speaker and ditch my Sonos Play:1 I'm so p**sed by this :-(
I would not be able to recommend Sonos in future. Very sad customer.
Mendy45,

In the Alexa App Main Settings you will also see the Beam is listed twice, one will be the room name, like ‘Dining Room' for example, that’s the speaker side of the hardware ...and the other will be called something like 'mendy's Sonos Beam' or something similar to that, this is the Alexa device part of the hardware.

You will find the Alexa App will only allow you to set your location in the settings of the Alexa part of the hardware, it won’t let you set it in the speaker part.

However please note this is NOT your Amazon Alexa Account Country Settings, you need to do those somewhere online at Amazon. If necessary I would speak to Amazon Support and get them to check your account country settings for Alexa and explain the error messages you have been seeing. They maybe able to resolve the matter for you.
mendy45

You should see two devices for your Beam in the Alexa App smart-home device list ... see my screenshot. My Beam is located in the 'Dining Room' in my case. Make sure those entries aren’t duplicated in the device list and if so, remove them all and ask Alexa to rescan for devices.
Just to update, I have managed to locate my Beam in the Alexa app by configuring the voice function on my iPhone and then asking Alexa to find me devices. So that worked, but I still don’t seem to be able to talk directly to the Beam...
Yes...

Strangely, when I click on Voice Services in the Sonos App it tells me voice services are not currently available in my country. I’m in the UK.


Can you check your addess in your profile in www.sonos.com and also the device location in the Alexa app>settings>{your beam}


Sonos looks like it is set to UK, but I can’t check the device location on Alexa as the app isn’t picking it up. Tells me discovery has failed every time I try to search for it...
Mendy45 go to your Sonos Account here https://www.sonos.com/myaccount/ and look at flag on left hand side and make sure you are set to UK... you can click the flag to change country if necessary.

If it isn’t your Sonos account make sure your Amazon Alexa account is also set to UK. I’m not sure where the setting is for that, but hopefully you will find it, or can speak to Amazon Support to resolve that.


Thanks - both look like they are set to UK...
Userlevel 7
Badge +20
Yes...

Strangely, when I click on Voice Services in the Sonos App it tells me voice services are not currently available in my country. I’m in the UK.


Can you check your addess in your profile in www.sonos.com and also the device location in the Alexa app>settings>{your beam}
Mendy45 go to your Sonos Account here https://www.sonos.com/myaccount/ and look at flag on left hand side and make sure you are set to UK... you can click the flag to change country if necessary.

If it isn’t your Sonos account make sure your Amazon Alexa account is also set to UK. I’m not sure where the setting is for that, but hopefully you will find it, or can speak to Amazon Support to resolve that.
Yes...

Strangely, when I click on Voice Services in the Sonos App it tells me voice services are not currently available in my country. I’m in the UK.
Userlevel 7
Badge +20
I have a new Sonos Beam. All working well, except I can't setup Alexa. I've been onto the Alexa app/website and added the Sonos skill; I've then been through the steps of providing Amazon and Sonos credentials. But then when it asks to discover, it tells me that an error has occurred so the Beam never appears. I've tried restarting the Beam but to no avail. It is my first Alexa product fyi. Please can someone assist? Been going at this for hours.

Is your Beam visible to your Sonos App?
Userlevel 7
Badge +20
There is no Forget All in the Alexa app. There is also no Settings on the Sonos link USA site. Terrible instructions.


I can't see the US site, as I have a UK account but they were there and still are on the UK site Also, are you trying to tell me that Amazon have removed the Settings page from the Alexa App in the US? How do you configure Alexa then?
I have a new Sonos Beam. All working well, except I can't setup Alexa. I've been onto the Alexa app/website and added the Sonos skill; I've then been through the steps of providing Amazon and Sonos credentials. But then when it asks to discover, it tells me that an error has occurred so the Beam never appears. I've tried restarting the Beam but to no avail. It is my first Alexa product fyi. Please can someone assist? Been going at this for hours.
There is no Forget All in the Alexa app. There is also no Settings on the Sonos link USA site. Terrible instructions.
Userlevel 2
Badge
This did not resolve the issue of Alexa skills not actually playing even though Alexa acknowledged the command and said "now playing..." I am having this same issue, followed all the instructions three times over, clearing out Amazon accounts, etc, and nothing. She still says, "playing *whatever*" and then nothing. This is very irritating. Anything I can do? If not I might have to return.

This was a known issue for a while with no amount of resetting addressing it, but it seems to have been fixed in one of the last two Sonos updates. Mine now works OK (previously no joy even with UK Media's steps).

So do check your application version on your phone/device and make sure Sonos is updated to the latest version.

As a test, enable "Babbling Brook" skill on the Alexa page and then say "Alexa, start babbling brook".

Good luck.
Userlevel 7
Badge +20
This did not resolve the issue of Alexa skills not actually playing even though Alexa acknowledged the command and said "now playing..." I am having this same issue, followed all the instructions three times over, clearing out Amazon accounts, etc, and nothing. She still says, "playing *whatever*" and then nothing. This is very irritating. Anything I can do? If not I might have to return.

Hi

This is an earlier post of mine which has some additional steps to those listed above. It's normally one of these three issues:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please open the Alexa App on a PC (https://alexa.amazon.co.uk or https://alexa.amazon.com)>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the PC version has this functionality.)

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (PC version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app , select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.
This did not resolve the issue of Alexa skills not actually playing even though Alexa acknowledged the command and said "now playing..." I am having this same issue, followed all the instructions three times over, clearing out Amazon accounts, etc, and nothing. She still says, "playing *whatever*" and then nothing. This is very irritating. Anything I can do? If not I might have to return.
Badback,

Are your sure the LED light is red and not orange? See below link for the meaning of the LED lights...

LED Lights on Sonos Products
Hmmm, so this worked...in a limited fashion. For some reason the sonos app wouldnt show my play:1s, so i tried to re-add them to the system. I cant get one of them to add (have tried everything right way back to a factory reset and i just get a solid red light), and now Alexa has stopped working again.

Will try the steps outlined here again, and see if it works, but any other tips would be gratefully recieved.

Im not sure if it makes any difference, but i have a second router in the loft, set up as a wireless ap. This is the router im trying to add the loft speaker too (although it worked fine in the past).

Thanks

Tom

Reply