Dead Play:5, need schematics or tips


Hi

Play:5, manufacturing date sometime around 2009, is completely dead. No light in LED.

Found several cases of this online, but no solutions.

Does anyone have any knowledge about the problem, og better yet, schematics..

I mainly suspect problem in switch mode power supply. Have only done very basic measuring, but I find 220VAC on primary side, no power on secondary side. I think about ordering a mosfet, and/or a diode I suspect, but if I had schematics I could do some more pinpointing..

32 replies

For what it’s worth, my pin1/3 on secondary side are also shorted. So either we both have the same problem or it’s supposed to be that way!

Hi all

 

I have been making some fault analysis at my own Play:5. Unfortunately the rectifier bridge and fuse is ok. The MOSFET driver at primary side is at least not shorted.

However the driver (FET, or BJT) at the secondary side is shorted between pin1 and pin3.

However I cannot figure out the tyoe, so it’s a little difficult. However a short circuit between legs is normally not something good ;-)

Or could I be tricked by the fact that the transformer might be connect to pin1 and pin3, so there is a DC short between pin1 and pin3 ?

Hi jpotts

It sounds as though the SMPS is trying to start-up, and then it shuts down again, and runds in this cycle. Maybe the control loop is broken

Have you tried to measure if there is any reponse at the optocoupler ? It’s located in the bottom right. Just to the right of the transformer. It’s a SHARP PC817..

Hi there,

I have the same problems (sorry for my bad english). One of the 120K smd resistors was defect, i place a new one but nothing happens.

On the 2 big elcos i measure 319 vdc but the little one of100uF is charging up to 19v en then back to 5v and thats repeating. When i measure with my scope i see the elco is charge and then recharge. I also replaced the 8p ic on the prim side. I checked al the components on the primair side but nothings wrong??

Userlevel 2

Im going to piggyback onto this discussion to see if someone can help me out.

I have a Power supply issue with an issue on the switching side.

The unit has no power. 

Replaced most of the power side caps, rectifier, fuse, FET IC Driver, FET, (Also smt 120K resistor near the rectifier was blown.)

I feel like im close, but I have this problem where the voltage starts at 5v ramps up to 15v and then bumps back down to 5v to repeat the process.  Thought maybe a diode, but I cant find it.

When i remove the little 25v 100uf Cap between the two big filtering caps, the fluctuation goes away.  Still get no power though.

 

Any Thoughts?

 

I’m trying to repair my Sonos play-5 gen-1. It has a problem that others have discussed but I’ve found no posts describing a repair. I have spoken with Sonos support and they confirmed the problem and offered a discounted replacement. I’d like to repair it. I have had good luck fixing Sonos power supply problems in the past. This play-5 seems to work. I can connect and stream music to it. The problem is that the volume is barely audible, even when set to max. There are no volume limits. There’s no distortion and both channels are working. Do any of you have suggestions on how I can further pursue this? The large caps and the rectifier measure correctly. Might this still be a power supply problem or is it more likely an amplifier issue? Any help would be appreciated.

 

Thanks

Lendy

It was a qualified guess that the chip was defect

i found a video online of repair of a Sonos zp100 

here he changed the usual suspects. One of was the small chip So I just did the same.  
 

kind regards Anders

 

Thx Anders, I have a Sonos 5 (rev 1), with working rectifier (diodebro), fuse not blown, but not working. All caps seems to be fine on HV side so I guess that 2QS02G could be the problem child. Any proposals on where to get this chip easiest?

 

Mvh / Br

Jesper

It was a qualified guess that the chip was defect

i found a video online of repair of a Sonos zp100 

here he changed the usual suspects. One of was the small chip So I just did the same.  
 

kind regards Anders

Hi Jesper

 

How did you conclude that 2QS02G was defect? I have 1 of the capacitors 820uf 35V that are defect, so I will change them.

 

Br

Jesper

God news my sonos Play 5 sings


I have changed the small chip that controls the mosfet
2QS02G
I also changed the rectifier MBR20150TC, but I do not thing it was defect. I broke it during the removal. I had to take it out to read the type. And therefore had to install a new one.

also changed 5 pcs electrolytic capacitors 820uf 35V


1. Fuse is close to mains connector. Red cylindrical one I'd say. Maybe it was 3.15AT??? Not sure.
Measure every component in series with line voltage if you're unsure which one is a fuse.

2. Rectifier on the mains voltage side. There is only one rectifier. Black with 4 feet.

Sorry but if you do not recognize those components you may need to study some more electronics before repairing.

In fact you better measure capacitors and switching FET before you attempt to power it up.
Check as much as possible ...and preferably power it up with current limiting.
Some components cause lots of damage if unit is powered up with them blown or shorted.


Old thread i know, but i cam across this when researching my faulty Play 5 (1st Gen). The play 5 wouldn't show any signs of life. No power light and cannot be seen via app.

I opened it up follow logic and this take apart:
https://www.ifixit.com/Guide/Sonos+Play+5+Motherboard+Replacement/87677

I tested the fuse and bridge Rectifier and as you say both faulty.

Bit of a mission desoldering the Rectifer. But all swapped over for new parts got from RS next day delivery and about £7.
The Play 5 is ALIVE!!!!!!

Thank you so much for this post. If i have another son, i shall call him Jlithen!
Hi I have not done more work yet
I am not sure that the transistor is the fault. The dis coloring could be rubbed off

Hello I Have the similar problem of Anders J. (304DC ok, 240VAC ok etc...).

Anders do you have change this transistor on your last message ?

hi my 7 years old play 5 has also now stopped working. opened it up hoping it was the fault decribed with fuse and rectifier, but they are both fine,
have anyone fixed this error.


Which ones broke on yours? Nevertheless none of them seem to be damaged..

Mine did work right after i replaced the broken fuse&rectifier, the first time it broke. It then stopped working AGAIN 6 months later - but this time there was nothing wrong with the rectifier or fuse, so i don't think the problem has anything to do with the rectifier breaking...
Badge
Tried changing the Caps just after the rectifier ?
I could when the rectifier went it took the Caps out just before the fuse blew ?
My play:5 broke down about 6 months ago, and i fixed it bye changing the KBU606 and the 3.15AT fuse, as mentioned here. But now it broke down again, and i assumed the same fix would do the trick - but no - this time the rectifier&fuse are working as they should. Yet nothing happens when i plug it in. Anyone who's found another fix to the symptoms besides changing the rectifier&fuse?
Badge
This looks a great thread
I’ve been doing repairs on play 3’s and again it’s rectifier caps and fuses to blame ! Although there was a hole through the PCB on the play 3
Going to try and repair 2 play5 and 2 play 1s
Wish me luck
I find next day with RS is reliable
Thanks
Ian
Great article. My play 5 sings again. Thank you so much!
Thank you all for the contributions. I have been able to repair my play 5 without technical training. The play 5 was completely dead. The parts as described for a few euros ordered at aliexpress and after 4 weeks of waiting I could work on de play 5. It was the most awkward thing without damaging anything, removing the rectifier. In the end, the play5 plays for a few euros and a few hours of patient and meticulous it works again.
My Play:5 is suffering the same issue, checked the fuse and the rectifier, the ac side of the rectifier is showing signs of a diode short circuit and the fuse has blown. Parts on order, wish me luck.
And it worked! New rectifier and fuse, and the Dead:5 is now a Play:5 again...
Thanks!

Exact same symptoms. Just desoldered the fuse and rectifier. Fuse is blown and measuring the rectifier, it seems that one of the diodes has failed. Will be picking up spareparts tomorrow - crossing my fingers that it works!

But someone should confiscate the hot glue gun from the workers at the assembly-line! Damn :)

/Dennis
Thanks a lot Jine
I have a sonos5 first gen with a power supply issue and you're right, it was a problem of fuse and rectifier.
The rectifier was effectively hard to desolder. After replacement of both component my Sonos sings again !!
Thanks again to the community
JJH from France

Reply