Answered

Lost A Room On the Sonos App


Hi, I went on my phone and went on to the Sonos App , i went down to click T Bedroom and it wasn't there. It completely has disappeared and I can't listen to my music through Sonos. It has always worked as I always listen to music in my room. Do you know how I add my room back in? What is the problem? 
icon

Best answer by Edward R 21 June 2019, 16:08

Lately, we have noticed this topic getting a lot of traffic. Although diagnostics are much appreciated, we do not always get the opportunity to conduct one-on-one troubleshooting.

If you are still having issues maintaining connection to one or more Sonos devices, sometimes, it's as simple as turning the router off for a few seconds. If this doesn't help, below you will find some useful content that we strongly recommend reviewing.

This article, that talks about Speakers disappearing or dropping off controller. This is an issue commonly caused by WiFi interference.

If you are still having issues, you may wish to get in touch with our support team via telephone.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

144 replies

Userlevel 7
Badge +20
Hi Toni,
Please try rebooting your missing player by removing it from power, waiting ten seconds, then plugging it back in. If this does not bring the unit back, there maybe some wireless signal interference preventing connection. To see if this is the case, we'd like to see some data from your system. Please submit a diagnostic and reply with the confirmation number: Submit diagnostic.
Hi Sonos, Have the same issue, can't seem to reconnect players even after resetting to factory settings. Diagnostic confirmation number 4530838 Frederic
Userlevel 7
Badge +20
Hi Sonos, Have the same issue, can't seem to reconnect players even after resetting to factory settings. Diagnostic confirmation number 4530838 Frederic
Hi Frederic,

Your missing Sonos units are connected and communicating with the rest of your Sonos system. They do not show up because they have no IP addresses. Your router is responsible for assigning IP addresses to components on your network, including the Sonos speakers. Please try rebooting your router. Many times this will cause your router to send out IP addresses to all the components on your network.

If rebooting your router does not work, please let us know. We will get you in contact with our phone support team to help log in to your router to check settings.
Userlevel 2
I have the same issue - diagnostic confirmation number is 5567889
Userlevel 7
Badge +20
I have the same issue - diagnostic confirmation number is 5567889

Hi Mikefenna,

There looks to be some wireless interference on your system which could explain why one of your units is not showing up. Please check to make sure your BOOST is not too close to your router or any other wireless device. We generally recommend keeping a couple feet of distance between them.

It may also help to change the wireless channel on which your Sonos system operates, here's how.

You can also try rebooting your router to ensure that it is sending out the most up to date network information to your connected devices.

Please let me know if these steps help or not.
Userlevel 2
I re-added the device and it seems to be working at the moment - I guess we'll see if it disappears again (it had been working fine for months and I didn't move the boost).

I have the same issue - diagnostic confirmation number is 5567889

Hi Mikefenna,

There looks to be some wireless interference on your system which could explain why one of your units is not showing up. Please check to make sure your BOOST is not too close to your router or any other wireless device. We generally recommend keeping a couple feet of distance between them.

It may also help to change the wireless channel on which your Sonos system operates, here's how.

You can also try rebooting your router to ensure that it is sending out the most up to date network information to your connected devices.

Please let me know if these steps help or not.
New user since December and love it and never had any issues until tonight. The unplugging the missing room component did the trick. Thank you
Hi. We've tried rebooting but with no luck. Our diagnostic number is; 6072692
Userlevel 7
Badge +20
Hi. We've tried rebooting but with no luck. Our diagnostic number is; 6072692

Hi Henry_123,

Your Sonos system has a high level of interference causing some communication errors. Your missing unit is still communicating wirelessly with your other units, but it's not a strong enough connection for the speaker to stay on the app. Please start by changing the wireless channel your system uses, here's how.

It may also help to update your Sonos system, here's how to do so.
Same problem. Was working fine yesterday, but now it won't connect. It's one of four (Office; other three are Master Bedroom, Dining Room and Living Room) and perhaps ironically, the only one in the same room as the router. Diagnostic confirmation 6103663
Userlevel 7
Badge +20
Same problem. Was working fine yesterday, but now it won't connect. It's one of four (Office; other three are Master Bedroom, Dining Room and Living Room) and perhaps ironically, the only one in the same room as the router. Diagnostic confirmation 6103663

Hi Bhatty2,

Your Sonos units are losing connection with your wireless network, causing them to drop from your system. We'd like to get you in contact with our phone team to troubleshoot this issue. Here's a support ticket: 160420-000794. Please give us a call and we'll help get things working. Our phone number can be found here.
Thanks! What are the hours? I won't be home until close to 6 PST
Userlevel 7
Badge +20
Thanks! What are the hours? I won't be home until close to 6 PST

Our hours differ from weekdays to weekends. The phones are open until 7pm PST on weekdays and 3:30pm on weekends.
Hi Sonos, I have a similar problem: a room sometimes suddenly disappears. Could you help me? I tried disconnecting the specific box but that didnt work. Diagnostic number: 6105097. Thanks in advance!
Userlevel 7
Badge +20
Hi Sonos, I have a similar problem: a room sometimes suddenly disappears. Could you help me? I tried disconnecting the specific box but that didnt work. Diagnostic number: 6105097. Thanks in advance!

Hi IngeSonos,

There's quite a bit of wireless interference showing up which is likely the reason your Sonos unit is dropping connection with the rest of your system. Please start by changing the wireless channel your Sonos system is using, here's how.

Also, it looks like your Sonos system is not up to date. Please run updates on your system, here's how.

If those steps don't help, please send in a new diagnostic report and reply with the confirmation number.
Hi Jeff, Thank you for your help. Unfortunately the box is still not working. I have changed the channels a couple of times (I have only 3) and the systeem is completely updated. I have a new diagnostic number 6105392.
Userlevel 7
Badge +20
Hi Jeff, Thank you for your help. Unfortunately the box is still not working. I have changed the channels a couple of times (I have only 3) and the systeem is completely updated. I have a new diagnostic number 6105392.

Hi IngeSonos,

The interference numbers look a bit better. Please try rebooting the missing Sonos unit. To reboot your Sonos speaker, just remove it from power for ten seconds then plug it back in. Once the light on the unit goes solid, see if it shows up on your Sonos app.

If the unit does not show up, or if the light on the unit does not go solid, try adding it back to your system, here's how.
Hi Jeff, thank you for your help! Adding the speaker helped; it is working again
Userlevel 7
Badge +20
Hi Jeff, thank you for your help! Adding the speaker helped; it is working again

Hi IngeSonos,

That's great to hear. Please let me know if you have any further troubles.
Have the same problem. Just started. Lost the living room with the bridge and two L1 sides. Completely disappeared. Diagnostic number 6155037.
Have the same problem. Just started. Lost the living room with the bridge and two L1 sides. Completely disappeared. Diagnostic number 6155037.

Unplugged bridge and plugged back in and the Living Room reappeared. 🙂
Hi, I have the same issue, tried changing channel, rebooting router and removing power from amp but still missing, diagnostics 6155104
Userlevel 7
Badge +20
Have the same problem. Just started. Lost the living room with the bridge and two L1 sides. Completely disappeared. Diagnostic number 6155037.

Hi AmericanSwede,

There are high levels of wireless interference showing. Please try changing your system's wireless channel, here's how.

After changing the channel, wait a couple minutes and see if the missing player returns. If not, try rebooting the player by removing it from power for ten seconds. It may also help to reconnect the speaker through this process.
Userlevel 7
Badge +20
Hi, I have the same issue, tried changing channel, rebooting router and removing power from amp but still missing, diagnostics 6155104

Hi Waggers5009,

There isn't too much interference showing on your diagnostic report. Please follow these steps to reconnect your missing unit. It is possible that range is a factor. How far is the missing player from the nearest Sonos unit? Which unit is closest to the missing player?
The closest unit is just a connect box and is approx 15 metres apart, it was showing and working but has disappeared. I have tried removing power and adding but keeps saying it has already been set up, can I get into back to green light and start again? Thx